RawTherapee 5.3 Released


#161

Ok, but I tried to say that the 5.3 Windows release contains the non-fixed, not-worked-around bugs in gtk3. And that the -test.exe I’ve tried today launched and responded almost instantly.

I understand that the complete workaround is not yet done? And we (= users of RT) still have to do more testing/digging/using the product?


(Ingo Weyrich) #162

Yes, it’s correct that rt 5.3 (and also pre 5.3 gtk3 builds of rt) on Windows suffer from this slowness on some systems. Currently @agriggio made a great workaround to this special behaviour of the file chooser buttons which I really appreciate :+1:


(Sebastien Guyader) #163

Impressive @agriggio


(Christian Malchus) #164

I do admit that I’m having quite some difficulty following this thread - I don’t have a clue about programming…
Maybe I’m simply too patient? I never worried about the time RT needed to start; I simply waited until it was up and running - and then it worked without any kind of problems. After reading (and trying to understand) this thread I tried deactivating the formats that I don’t use or (most probably) won’t be needing. As a result my RT 5.3 now starts in app. 7 sec. instead of app. 12 sec. before…
More than good enough for me! :grinning:


#165

Just wondering…

It was clear that the ‘special’ rawtherapee-test.exe version was much, much faster. And it seem to be working ok.
Thanks to @agriggio (?). But why is this version still not released and/or available @ the regular download section of the RT website?
http://rawtherapee.com/downloads


RawTherapee + LocalLab version RT ==> RawTherapee! (?)
(Morgan Hardwood) #166

A new release will be made soon, possibly in the next week.


#167

I’m eagerly waiting for the new release…:yum:

FYI:
I’ve updated my system to Fall Creators Update 1709 Win 10.0.16299 and the startup time of the rawtherapee-test.exe version is now 3 seconds in a directory with dozens of large images! The ‘Preferences’ Window appears almost instantly, when I click that icon.
And when started for the second time, (from cache), rawtherapee-test.exe starts in under 2 seconds when started with an empty directory (no images)


(Morgan Hardwood) #168

We were going to release 5.3.1 with mostly speedups and fixes but without new features, but much has happened in the last few weeks, so it looks like we’ll make the usual large new release when things stabilize.

RawTherapee 5.4 Roadmap:


#169

@Morgan_Hardwood I can’t wait. :smiley:

Maybe something else to consider regarding startup time:
Most programs start within a few seconds, but display their first window/screen/messages almost instantly and after that, the rest of the initialization continues.
E.g. with PS CC 2018; you see the logo screen appear immediately after starting the program, then you will notice some messages scrolling through the logo screen and finally the program is ready for use.
The same with for example, Microsoft Office programs.

Seems to be something psychological? First display any kind of picture/logo/message, so that the user has a confirmation that there is something happening, and in the background, the rest of the entire software package is loaded & initialized.
Tip for RawTherapee also?
E.g. start RT, display a kind of startup logo and/or window frame, let some single messages scroll through a window, as to let the user know the program is doing something, and then finally open up the final RT full screen window?
Or something like that…


(Peter Lo) #170

Very good point about the “initial display” thing, it certainly improve people’s impression towards a software regarding startup speed.

Unfortunately this is not my case. While RT 4.x started quickly here (i7-5960x, 32G, Win 10 Creator and SSD), it took almost 5 minutes to start 5.2. For 5.3, when I click and try to start the program, it appear in the task manager for one or two minutes (but nothing else), and disappears afterwards as if I’ve never clicked anything before. So I’m sure the issue isn’t entirely psychological.


#171

@Peter_LO Did you try the rawtherapee-test.exe? Which was made available by @agriggio ?
Just read back some posts in this thread.


(Peter Lo) #172

Thank you for the advice, PanoMeister. But the only difference is that the -test version disappears from Task Manager a bit sooner, as shown in the video clip:

https://www.dropbox.com/s/o9ahtfgqw93akzh/WP_20171118_20_03_44_Pro.mp4?dl=0


(srowed) #173

I’m having problems updating to RawTherapee 5.3 on Kubuntu.
I followed the instructions on the RT site:
Open the terminal and paste this code into it:
sudo add-apt-repository ppa:dhor/myway
sudo apt-get update
sudo apt-get install rawtherapee

But then I get:
rawtherapee is already the newest version (5.1-1dhor~yakkety).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

When I open RT it’s still 5.1.
Any suggestions? Thanks.


(Mica) #174

First uninstall RawTherapee: sudo apt remove rawtherapee. Then run the apt install command again.


(srowed) #175

Still the same. I used apt-get remove, then ran the install command again. Still 5.1.


(srowed) #177

I just did a “mark for complete removal”, then apply, in Synaptic. Then I went through the same commands again:
sudo add-apt-repository ppa:dhor/myway
sudo apt-get update
sudo apt-get install rawtherapee

It’s still 5.1. It even shows 5.1 in the terminal.

scott@scott-VPCF1290S:~$ sudo apt-get install rawtherapee
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following NEW packages will be installed:
rawtherapee
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/12.5 MB of archives.
After this operation, 69.6 MB of additional disk space will be used.
Selecting previously unselected package rawtherapee.
(Reading database … 228638 files and directories currently installed.)
Preparing to unpack …/rawtherapee_5.1-1dhor~yakkety_amd64.deb …
Unpacking rawtherapee (5.1-1dhor~yakkety) …
Processing triggers for mime-support (3.60ubuntu1) …
Processing triggers for desktop-file-utils (0.23-1ubuntu1.1) …
Setting up rawtherapee (5.1-1dhor~yakkety) …
Processing triggers for man-db (2.7.5-1) …
Processing triggers for hicolor-icon-theme (0.15-1) …

I’m at a loss for figuring this out. Maybe I’ll try installing on another computer, but this is my main graphics machine.


(Mica) #178

I don’t think that yakkity is supported anymore (that is 16.10, right?) which may explain that.


(srowed) #179

Thanks paperdigits. That is very likely the problem. Yes yakkety is 16.10 and I just checked the Kubuntu site and it’s only supported for 9 months. I’d thought it was LTS but it’s definitely not. Looks like i should install Kubuntu 17.10 asap. Feeling a bit sheepish!


#180

@troodon See

image

Alternatively, you can try the appimage: https://github.com/aferrero2707/RawTherapee/releases/


(Simon Frei) #181

Updating might be anyway the right thing to do, but you could also try the other repo given on the download page from the open build service, which seems to have 5.3: http://download.opensuse.org/repositories/home:/rawtherapee/xUbuntu_16.10