RawTherapee 5.9-rc1 ready for testing

Edition Windows 10 Home
Version 22H2
OS build 19045.2251
Windows Feature Experience Pack 120.2212.4180.0

Intel(R) Core™ i5-3450 CPU @ 3.10GHz 3.10 GHz

Worked fine on a Leica SL .dng file. Previously, RT would start these Leica files with a very high Temp value, around 30000K and higher. RT 5.9 rc1, with default processing of Camera white balance, started with more “reasonable” temp, that is, just a few thousand degrees Kelvin above or below 6500K.

As I mentioned it is fairly basic, it’s a spot and not a brush, but it does work well


Minor cosmetic glitch, probably GTK. On the HSV Equalizer (at least), the first time I expand it, the entire curve widget isn’t visible – bottom is cut off. Once I move my mouse over it, it shows up completely.


Windows 11 Home

1 Like

My 5.8 does the same since february 2020

Tested out the AppImage on Fedora 36 main workstation. No problems so far, tried out the local adjustments tool a little bit. Always like how RT handles the highlights vs darktable. Sometimes doesn’t seem to detect the lenses on my Nikon D7500 files for correction for some reason. The D800/D850 and Fuji stuff seems OK.

Sadly this is a known issue, it’s been around for years.

1 Like

Can you elaborate a little? We try to have full backwards compatibility, but apparently something is not working for you. I hope you have backups of the pp3 sidecar files, because as soon as you opened them in 5.9, there may not be a guaranteed identical result if you the reopen them in 5.8.

As stated by Roel you do need to provide more details but this immediately came to mind as a possible cause:

An unsupported (stable 5.8) vs a now (maybe partially) supported (5.9) camera.

If I load a RAW from my Nikon Z6ii in (stable) 5.8 and apply a neutral profile and compare that to the same RAW in 5.9, with a neutral profile, they do not look the same.

So, because the starting point is different, an edit done in 5.8 and then loaded in 5.9 will not look the same in this case. I’m not aware of a way to overcome this (short from manually editing the camconst.json file).

If this is the case: I personally do not see this as a bug/shortcoming (as one is using an unsupported camera in the older 5.8).

1 Like

This is great news!

I second that!

I’ve had similar problems with curve windows and controls in the lab adjustment and wavelet modules in 5.8 and dev versions

Really should be sorted - there’s nothing more off-putting than a buggy GUI

Is there a way of configuring ~/build-rawtherapee to install the test version?

Asking for a friend…

Just installed Windows RT 5.9-rc1 and Gimp-2.99 on my 64bit Win10 Pro. This is all new to me and a quick test makes me wonder if there are a couple of issues related to the External Editor feature.

I set the External Editor Gimp path to C:\Program Files\Gimp 2.99\bin where the gimp 2.99.exe file is. Sending a file (.tif) to the External Editor Gimp alternative does no start Gimp, but RT generates the RT .tif The filename is as expected, it appears ok in Windows tools and I can navigate Gimp to that file and open it.

Using the External Editor Custom command line alternative starts Gimp, but Gimp fails with a message that indicates the file name was formatted by a utf-8 confused application, or maybe Windows is playing tricks here.

Affinity Photo fails with the same kind of error message as Gimp (no such file…).

There is likely a setting somewhere…

Yes, this has been an issue ever since RT switched from GTK2 to GTK3 several years ago. No known solution.

cd ~/programs/code-rawtherapee
git checkout 5.9-rc1

Once you’re done, go back to the dev branch:

git checkout dev

If you just move the mouse pointer over this symbol
the whole area will appear

@martbetz would it be possible, you upload a raw-file and both pp3-files the RT5.8 one and the RT5.9rc1 one to see the difference you mention?

The work around, at least for me, is to leave the HSV Equalizer module expanded by default. I can then turn it on or off as desired. I do the same for Lab* Adjustments and RGB Curves.

I’m afraid it doesn’t like doing it - this after ./tools/build-rawtherapee

From https://github.com/Beep6581/RawTherapee
   3b93365f0..bce946040  uglyartifacts -> origin/uglyartifacts
fatal: HEAD does not point to a branch

Thanks a lot for this RC1. Tested it on a AMD Ryzen 7 2700X and Windows 10Pro 21H2 (19044.2251). Works fine with Nikon NEF and JPEG.
Looking forward to the offical release!

1 Like

That’s how it’s supposed to be, afaik (not possible differently from the technical point of view). Use excluding spot to prevent it.
At least I hope I understood you correctly. I think I encountered the same issue.