Release of PhotoFlow 0.2.8


(Carmelo Dr Raw) #1

I finally managed to get a new PhotoFlow release out! This new 0.2.8 version should be much more stable than the previous one, in addition to having an improved user interface and some nice new features.

You can get more details from my blog post and GitHub release page (where you can grab the pre-compiled packages for Linux, OSX and Win64).

Here is the changelog for this version:

New features:

  • [raw processing] added fallback RAW decoding based on RawTherapee code.
    Used for example for opening floating-point DNGs not supported by RawSpeed
  • [film CLUTs] added support for reading bundled gmic_film_cluts.gmz file
  • [plugin] moved GIMP plugin to external project
  • Added optional support for sidecar files.
    When exporting an image to TIFF or Jpeg format,
    the editing configuration is saved into a file named .tif.pfi or .jpg.pfi.
    Also, when opening an image named image.ext, the program looks for a sidecar
    file named image.pfi or image.ext.pfi (in this order) in the same folder.
    If a sidecar .pfi file is found it is opened instead of image.ext.
    The sidecar files functionality is disabled by default, and can be enabled
    via the settings dialog.


  • Re-worked the UI layout, now with a single left panel showing both the layers tree and the controls for the active tool. Masks editing is now also performed in the same panel.
  • Various improvements and polishing of widgets layout
  • Removed dependency on GExiv2. Code now only depends on Exiv2. A bundled 0.2.6 version is used if not found on the system.
  • [tools/raw processing] reduced memory usage during RAW image loading
  • [tools/raw processing] RAW decoding updated to current RawSpeed/DT git version (as of 2017-05-25)
  • [tools/raw processing] added support for per-cahnnel black levels
  • [tools/lens corrections] completed optical corrections support, now also included in the RAW processing module
  • [tools/lens corrections] added support for fixed-lens camera (from Darktable)
  • [tools/crop] added top/left handles and fixed handling of image boundaries
  • [gui] replaced GTK idle callbacks with Glib::Dispatcher signals, and improved thread-safety
  • [gui] added expander for grouping additional tool controls, like horizontal/vertical shifts
  • [gui] added more keyboard shortcuts (layer copy/cut/paste/deletion)
  • [gui] using vips_resize() for fit-to-screen scaling
  • [batch] enable outputting of .PFI files
  • [build] moved GMIC code into a separate static library, to speed up parallel compilation

Bug fixes:

  • [base] fixed threading of cache buffers for VIPS versions 8.4.*
  • [tools/raw processing] fixed issue with SPOT WB when output is gamma-encoded
  • [tools/raw processing] fixed spot WB when output image is in Lab colorspace
  • [tools/shadows-highlights] Fixed processing of highlights
  • [tools/clone-stamp] fixed various bugs leading to unpredictable crashes
  • [tools/uniform fill] fixed initialisation of color selector button in UI
  • [tools/lens corrections] fixed crash due to un-initialised pointers when camera/lens not found


Just started using this and looking good so far. Thanks for all your efforts to make this such a great program.


Using the draw mask seems to cause a crash (macOS 10.12.6) at the point I start to draw.

(Andrew) #4

hi, well done with your new version!

I thought I’d give it a go, so just tried to install on Ubuntu 16.10. It didn’t go too well, perhaps it’s my system.
I followed your install details for the “Highly Explosive” PPA

  1. sudo add-apt-repository ppa:dhor/myway

  2. Just in case I had used an older version:-
    sudo apt-get remove photoflow
    (none was not installed)

  3. sudo apt-get update

  4. sudo apt-get install photoflow
    ***** this went wrong …
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package photoflow is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package ‘photoflow’ has no installation candidate

So I tried the “potentially more unstable version” (I like that this is more unstable than the explosive one, is it the North Korea version?!)
sudo apt-get install photoflow-git

It all seemed ok until it got to here -
Selecting previously unselected package nip2.
Preparing to unpack …/22-nip2_8.3.0-1_amd64.deb …
Unpacking nip2 (8.3.0-1) …
Selecting previously unselected package photoflow-git.
Preparing to unpack …/23-photoflow-git_1%3a2.6+git20170619-1003~ubuntu16.10.1_amd64.deb …
Unpacking photoflow-git (1:2.6+git20170619-1003~ubuntu16.10.1) …
dpkg: error processing archive /tmp/apt-dpkg-install-vQAqcu/23-photoflow-git_1%3a2.6+git20170619-1003~ubuntu16.10.1_amd64.deb (–unpack):
trying to overwrite ‘/usr/include/exiv2/basicio.hpp’, which is also in package libexiv2-dev 0.25-3
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

(Carmelo Dr Raw) #5

I confirm that there is something wrong with the hand drawing tool (too bad I didn’t notice before!), but I cannot get a crash… could you shortly describe the exact steps that produce the crash in your case?


(Carmelo Dr Raw) #6

There seems to be some problem with VIPS/PhotoFlow in the “Highly Explosive” PPA, @Dariusz_Duma can probably clarify? If help is needed, I’m available!

The photoflow package is still at the 0.2.7 version, and the photoflow-git package is a bit outdated and contains some mess with EXIV2 headers that I have recently fixed in preparation of the 0.2.8 release.

While waiting for updated packages, why not to give the AppImage a try? It should work without issues under Ubuntu… just grab it from the GitHub release page.


I was trying to apply a blur to part of a photo. Opened the draw mask, selected the size of brush, which showed on the screen, but as soon as I clicked the mouse to apply it the program crashed.

(Dariusz Duma) #8


I’m going to clean up the PPA and I’ve one question:

-- Checking for module 'vips>=8.5.1'
CMake Error at /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:367 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.5/Modules/FindPkgConfig.cmake:532 (_pkg_check_modules_internal)
  CMakeLists.txt:112 (pkg_check_modules)

Photoflow (GIT) is checking for Vips >= 8.5.1 - is it ok? I mean, you mentioned about Vips 8.4.x. Packages for 8.4.x I have already. However, there’re some issues with vips > 8.5.x (can’t build package).

best regards,

(Carmelo Dr Raw) #9

Hi! Unfortunately, I really need VIPS 8.5.x, due to some changes in the way caching is done internally by VIPS.

The VIPS error seems to be related to gtk-doc. I can try to have a look later this evening, otherwise I can contact the VIPS developer directly (with you in copy).

(Dariusz Duma) #10

Great, I’ll try to figure out what’s wrong with this gtk-doc. Any suggestions are more than welcome :slight_smile:

(Dariusz Duma) #11

I’m glad to inform you that new libvips 8.5.7 is in repository and PhotoFlow 0.2.8 was compiled successfuly (not uploaded to repo yet). I wonder if it’s better to stick with GTK2 interface for official release or maybe we are ready to switch to GTK3?


Hi @Carmelo_DrRaw

I am using the latest version of your GIMP appimage (20170809) and Photoflow appimage (v0.2.8).

And I can successfully invoke Photoflow from within GIMP.

However, after I make some edits in Photoflow and click “ok”, it would just return to GIMP but I cannot see the Photoflow edited layer in GIMP. In other words, it seems like I have never had made any edits in Photoflow in GIMP.

Do you know what might caused the problem? Thanks in advance.

(Carmelo Dr Raw) #13

Not at the moment, but I will try to repeat your steps and see if I can confirm the issue.


(Carmelo Dr Raw) #14

Thank a lot Darius! I would prefer to stick to GTK2 for the moment for the official release, as the UI in this case is well stable. I have the impression that GTK3 theming is still evolving quite quickly, so due to lack of time I do not feel ready to support it as the default option…

Thanks for your strong support with your PPA!

(Patrick Depoix) #15

Congratulations Dr Raw! I wishes you nice vacancies to this summer!
At soon…
Patrick D.

(Carmelo Dr Raw) #16

Thanks Patrick! Vacations are already over since a while, but they’ve been really nice. All the best for you as well!

(Andrew) #17

hi @Dariusz_Duma, just wondering where things are with getting 0.2.8 uploaded. I just tried to install but I’m getting the same errors as above. @Carmelo_DrRaw, sorry I haven’t tried the appimage. I tried one previously but had some odd things happening such as with icons in the launcher bar, so I’ve hesitated since.


Hi Carmelo,
Just wondering if you’ve had a chance to test it out. Thanks.

(Carmelo Dr Raw) #19

Not yet… I had to take a break for personal reasons, but I’ll be back into business in one week from now. Thanks for reminding me!

(Carmelo Dr Raw) #20

Short update on this: I have been able to reproduce the issue, and I’m currently working on a fix. As soon as the fix is ready I will make a new GIMP AppImage package for testing.