RT 5.1 crashing - mostly on zoom


I have recently installed RT 5.1, and it is looking very good… except for a tendency to crash without warning. :slightly_frowning_face: When it happens, there is no error message - it just drops completely out of the program, with nothing to indicate what went wrong. The problem isn’t confined to a single file type (it happens with RAF, CR2, ARW) and seems to happen mainly (but not exclusively) when zooming (either in or out) on an image.

It’s running under Windows 7 Home Premium 64-bit SP1 on an HP Pavilion G6 with 6GB of ram.

Any suggestions? TIA.

(Morgan Hardwood) #2

Update to 5.2 as soon as we have a Windows build.


Thanks - will do.
Any rough idea when 5.2 for Windows might be available?

(Sebastien Guyader) #4

You can find my 5.2 Windows 64 build from yesterday here: https://filebin.net/hfuhl8olgqv92cfc
Tested by a couple of people and it seems to work fine.

(Morgan Hardwood) #5

Windows and macOS builds are now available from our website:


Great - thanks to both of you, for your replies.


Unfortunately, 5.2 is still crashing.

(Ingo Weyrich) #8

Please try to give a more detailed report because noone experienced this except you afaik.


Thanks for the reply. There’s nothing more to report than I said in my first post. The program just drops out completely. No warning, and no error message. It usually happens when using the zoom buttons.

That’s as much as I can report.

(Ingo Weyrich) #10

there’s at least a bit more you can provide:



Ok, from the link that you provided, here’s the information (in bold) on the points listed:-

Complete version information of the RawTherapee build you’re using (e.g. “RawTherapee 5.0-r1-gtk3-253-g42047cb6”). RawTherapee version information is available by clicking on “Gtk-preferences.png Preferences > About > Version” - in most cases that tab will be full of information, all of which you should copy and paste into your bug report. If that tab is empty, then you can get the RawTherapee version from the RawTherapee window’s titlebar.

Version: 5.2
Branch: release-5.2
Commit: 78e921cb
Commit date: 2017-07-23
Compiler: gcc 6.3.0
Processor: generic x86
System: Windows
Bit depth: 64 bits
Gtkmm: V3.22.0
Build type: release
Build flags: -mwin32 -m64 -mthreads -msse2 -std=c++11 -mtune=generic -Werror=unused-label -fopenmp -Werror=unknown-pragmas -Wall -Wno-unused-result -Wno-deprecated-declarations -mwindows -Wno-aggressive-loop-optimizations -DNDEBUG -O3
Link flags: -m64 -mthreads -static-libgcc -mtune=generic -mwindows -s -O3
OpenMP support: ON
MMAP support: ON

System information: your operating system name and version, your CPU type and speed, and how much RAM you have. Windows users can find this information by pressing the ⌘ Win+⎉ Pause keyboard shortcut.

OS Name Microsoft Windows 7 Home Premium
Version 6.1.7601 Service Pack 1 Build 7601
System Manufacturer Hewlett-Packard
System Model HP Pavilion g6 Notebook PC
System Type x64-based PC
Processor Intel® Core™ i5-2450M CPU @ 2.50GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
Installed Physical Memory (RAM) 6.00 GB
Total Physical Memory 5.95 GB
Available Physical Memory 2.83 GB
Total Virtual Memory 12.2 GB
Available Virtual Memory 8.33 GB

Tell us where you downloaded the RawTherapee build from. Be specific, don’t just say “your website”; provide the URL if you can by right-clicking on the link which downloads the build and selecting “copy address” or something similar to that, depending on your web browser.


Explain the exact steps to reproduce the problem. Apply the “Neutral” processing profile to your photo and then explain what needs to be done to trigger the problem from there.

The program crashes randomly, but with a noticeable tendency to happen when clicking on a zoom button

Make your raw file and PP3 file available to us by uploading them to a file sharing service such as www.filebin.net if your bug involves a particular raw file, a particular setting, or lack of support for your raw file.

The program crashes with any of the following Raw file types: RAF, CR2, ARW.

Show a screenshot of the problem, you can upload them to www.imgur.com

Not possible - the programs runs normally, until it just drops out completely.

Search the forum and our issue tracker before filing a new report as chances are that someone has already reported the problem before you, and duplication wastes time.

I tried, but I could find no-one reporting the same problem.

Make sure you use the latest version of RawTherapee as it’s likely that a bug in an old version has been fixed in the latest one.

It is the latest (5.2).


I’ve just noticed that it seems that the problem is more likely to occur when clicking the “fit crop to screen” button.

I can’t recall whether this was the case on every occasion, but I’ll continue to try to provoke it into happening again, to test the theory. It definitely does NOT happen every time the “fit crop to screen” button is clicked, though. :confused:

(Morgan Hardwood) #13

@porchard if our 5.2 Windows build includes a debug executable, could you produce a stack backtrace? It’s the most useful piece of information. You don’t need to understand what’s happening, it’s enough to just follow these instructions:

If the build does not include a debug exe, @sguyader could you provide one?

(Sebastien Guyader) #14

My build contains the debug exe as well as gdb.exe.

(Morgan Hardwood) #15

Fantastic @sguyader


Ok, thanks - I’ll try the other download, since mine didn’t include gdb.exe.

(Morgan Hardwood) #17

@porchard @sguyader was referring to this build: http://rawtherapee.com/releases_head/windows/RawTherapee_5.2_WinVista_64.zip


I downloaded from the link that you provided, and installed the program. When I ran it, I tried to provoke the crash, and this time it took much longer to crash… but, it did eventually crash.

However, I can’t find a debug file anywhere. Would you confirm the procedure to extract the debugging information - thanks.

(Sebastien Guyader) #19

First, open a new issue in github (https://github.com/Beep6581/RawTherapee/issues).

Then open a command prompt in the installation folder (Program Files\RawTherapee), type gdb rawtherapee-debug.exe.
At the gdb prompt, type run.
It will launch Rawtherapee’s debug executable. Use it and try to provoke the crash. When in has crashed, in the gdb prompt type bt full, it will produce a lot of text, copy this text and paste it in the new issue you just opened at github.


I followed your description, and this was the result (copied from the command line editor):

C:\Users\tp>gdb rawtherapee-debug.exe
’gdb’ is not recognized as an internal or external command,
operable program or batch file.

There is no gdb.exe file included with your build, either. :confused: