RT: EXIF not exported


#1

It worked just fine. Then I don’t know what happened. Maybe I changed something in the settings but the exported TIFFs do not contain (almost) any of the original metadata. No exposure data, no focal length, no GPS. There only appear to be the camera make and model.

Under Preferences > Image Processing, the “Copy exif/IPTC/XMP unchanged to output file” is checked.

What have I done now?


#2

Problem solved.

Apparently unchecking the “Uncompressed TIFF” in the Queue module screws up the metadata. A bug?

Oh, well… Everything’s back to normal now.


(Morgan Hardwood) #3

@the-old-david please upload your raw image using http://filebin.net/ so we can reproduce the problem and state which version of RawTherapee you’re using.


(Morgan Hardwood) #4

@the-old-david have you seen the message?


(Yann) #5

Hi there!
I meet the same problem: when exporting in a tiff format or opening in an external editor (gimp), exifdata is lost…
Copy metetada is checked.
I tried to uncheck uncompressed TIFF as the old David did but nothing has changed.
Raw file is here:
http://filebin.net/tw1ji5o79u.
Thankyou for you help! :wink:


(Morgan Hardwood) #6

Which version of GIMP?


(Yann) #7

2.8.10 under Ubuntu (14.04 LTS)


(Morgan Hardwood) #8

Ancient, try with a current version.


(Yann) #9

I will,but I don’t think the problem is in GIMP, because when I export a raw picture from RawTherapee to tiff format, metadata are already lost…

… I have tryed to update GIMP, but Ubuntu says I 've got the most recent version of it…
In French in the text: “gimp est déjà la plus récente version disponible.”


(Yann) #10

OK, I’ve exported the picture again , exif are present!
Now with the “external editor”: exif are gone … Maybe it is because of the conversion in a 32 bit tiff image. Morgan, you may be right … I’ll try to update my Gimp version. Or there may be a set up to open in the external editor in a 32 bit image? Do you know that?
Confirmed: Gimp 2.8 does not import exif data from tiff pictures. I’ve been told it’s fixed in 2.9 version. Not yet available in Ubuntu official repositories… Wait and see…


#11

I seem to have stumbled upon this (or similar) missing exif issue on Windows 7, but since I only have one computer at hands, I would be glad if somebody could verify this, before I declare this as a bug.

With all raw files that I have checked, with gtk3 4.2.880 and master 4.2.773, saved compressed tiffs (8- and 16-bit) have broken exif data, causing ExifTool warning Bad format (1403) for ExifIFD entry 0. Uncompressed tiffs seem to be OK, but they trigger an RT TIFFOpenW Error: Cannot open during saving process.

On virtual Ubuntu Studio (last release, last “unstable” dhor/myway RT) I see no problems.


(Ingo Weyrich) #12

@Jacal Didn’t verify but sounds like an old issue with compressed tiffs in rt


(Dominik) #13

Hi

I have similar situation.

RT 4.2.992 (previously I had version from repository, probably 4.1(?) and there was the same problem)
OS Debian 8.5

I exported RAW with all possible options, and only JPG has exif data. PNG 8/16bit, TIFF 8/16bit compressed/uncompressed, all of them lost exif.
Of course when I export image directly to GIMP I also lose all information.

Is it problem with RT or problem with Debian? Can I fix it myself?


(Pat David) #14

I don’t think PNG has exif data options in the standard. You can embed ‘chunks’ in the file, but this is hackish at best (iirc).


(Robert Thorsby) #15

Phil Harvey posted the following in response to a question somewhere:

ImageMagick stores EXIF information in a PNG “Raw profile type APP1” zTXt chunk when converting from JPEG images. This method of storing EXIF in PNG images is also supported by ExifTool (and I believe Exiv2 too), but it is not part of the PNG or EXIF specification.

If anyone knows, it would be Phil (he wrote ExifTool)


(Morgan Hardwood) #16

What does that mean?

PNG does not officially support Exif and RT does not attempt to support it for PNG, at least not at this point.

GIMP notoriously discarded all metadata for years, this was a major GIMP bug, now fixed in 2.9.4. I don’t know whether its fixed in 2.8.18. Don’t use GIMP to examine metadata as that introduces another point of failure, rather use exiv2 or exiftool directly.

If you re-check your situation with the above in mind, and you still think RT loses metadata, upload both your input raw photo, and the saved TIFF 8-bit/16-bit image. Enable resizing when saving the TIFFs in RT to some small size, 16x16 for example, so we don’t spend time downloading unnecessary image data. Upload using http://filebin.net/


(Denis) #17

I get exif in tiff files only with “Uncompressed TIFF” setting selected. I checked it with windows file properties. And when I have exif in a file, I always have it in GIMP too.


#18

Exif is partly exported in the tiff and png files now (in upcoming RT5.4), compressed and uncompressed. The unsolved problem is exporting the MakerNotes. Exif.UserComment is now better supported too.