RT is running slow on my new iMac

Really? There is at least half a second of delay every time I press a button or pull on a slider. Perhaps it is really not so bad, or it may not transfer well to video. It may also perhaps be unreasonable to expect more responsive behavior, but it feels awkward and sluggish to work with.

This sounds sensible to me. I don’t notice much difference, however, when I reduce the preview window (se video).https://pixls-discuss.s3.dualstack.us-east-1.amazonaws.com/original/3X/a/9/a90e15f774a7292b711e10a61b3a5c2fbf4582e9.mp4

It’s hard to tell what you’re seeing because your video is very jerky, maybe your system is incapable of recording a smooth video at 4k.

Try setting both AdjusterMinDelay and AdjusterMaxDelay to 0 (while RT is closed).

Hi I have the same issue. Brand new iMac retina 5K, 27inch 2017, 4,2 GHz Intel Core i7, 40 GB 2400 MHz DDR4, Radeon Pro 575 4096 MB

Opening pictures takes about 1,5 seconds, scrolling through the folders is quite slow also. I could live with that but when I use the sliders there is a serious delay between the movement of the mouse and the actual slider. Up to a point that it’s very difficult to work and almost impossible to be precise. This is a real bummer because I really wanted to use RT. I haven’t found any solutions anywhere. Nothing worked for me.

I recently downloaded Capture1, the free trial, and that works much smoother. Is the problem due to the 5K 27 inch screen? Is there no way RT will work smooth on a 27 inch 5K iMac?
I have an SSD and was convinced this iMac would have no issues with any photography software. I had Lightroom on my previous iMac 21 inch and that worked very smooth, no delay whatsoever.
I’m quite disappointed having spent almost 3000€ on a computer that’s now slower then my old one…

1 Like

Have you tried the dev branch build? Also which macos version?

I dont know if it’s related, but I experience similar problems with darktable and other gtk software on Mac OS. I tried 10.13,10.14 my hackintosh and an original MacBook, and the Ui is always very slow and unresponsive.
Running dark table the same specs on my hackintosh under windows or Ubuntu 18.04 it is much faster. On Ubuntu it really flies.

To isolate the problem a bit:

  1. As @HIRAM wrote, use the latest development build when testing,
  2. Change your screen resolution to 1920x1080 and test. (i.e. do not just resize the RT window to 1920x1080 because then you’re still running at 4k or whatever)
  3. If you can reproduce the problem at a screen resolution of 1920x1080, record a 30fps video and upload it here.

I have the a slightly lower end model of iMac (27in 5K, 3.4Ghz core i5, 16GB ram, Radeon Pro 570) and RT is super slow on it. I just timed it with a stop watch. RT takes 14.45 seconds to open. When I grab the exposure slider and move it to the right it takes a second or more for the slider to catch up to where the mouse pointer has moved.

On my other computer, an old windows 10 machine with an AMD FX 8350, 32GB of ram, and a 1920x1080 monitor, RT is much faster. The sliders move in conjunction with the mouse pointer. The program opens in just a few seconds. It’s like a totally different program.

I’ve tried most of the suggestions in this thread to make it faster on the iMac. Lowering the screen resolution helps a little but RT is still far too slow. This is with both 5.5 and 5.6.

Output quality from RT seems to be at an all time high though. It’s excellent.

Have you tried the dev branch build? Also which macos version?

It’s been this way in both macOS 10.14.4 and 10.14.5 and with both RT 5.5 and 5.6. The dev branch is not noticeably faster.

I assumed that RT was slow on my old iMac, a 2013 model, because everything was slow on it. But, RT feels about the same on the new machine as it did on the old machine while the other programs I use are significantly faster.

The video is not jerky on this side. I think what you are interpreting as a jerky video is the sluggish rawtherapee behavior that I am trying to demonstrate.

Please post / link your AboutThisBuild.txt file so we can eliminate common mistakes.

AboutThisBuild.txt file:

AboutThisBuild.txt (610 Bytes)

Please try with a 5.6 build from here

@heckflosse Could there be an issue with -mtune=generic on MacOS ? Or an issue with clang ?

I don’t know anything about MacOS, means there could be an issue or not. I just don’t know.


I could suggest going down to regular 1080p resolution and see if that helps.

I could try a targeted build for cpu you have. It would only affect the RT code, a the dependencies I have built up should be all generic.

I’m still not having any sluggishness issues on the macs I have access to, which are i3, i5, and E5.

Ps. I think I added -mtune=generic for compatibility with Core2Duo.

Hi. Tried the 5.6 build. I can’t notice any any difference.