Scroll wheel problem in darktable for MacOS


#1

I tend to use an iMac for photoediting, as the screens on my Linux machines aren’t as good. Version 2.4.4 of darktable for Mac generally works OK for me.

But there’s one persistent problem: changing a mask’s feather size with ‘shift + scroll’. Movement of the mousewheel in either direction only increases the size of the feather. I’ve tried several other mice (by various manufacturers), and all have the same issue. The only devices on which ‘shift + scroll’ works correctly are (a) the scroll wheel on my Wacom Intuos Pro L tablet; and (b) the scroll function on an Apple wireless mouse.

I suspect this is an issue specific to darktable on MacOS, as the Logitech Trackman works fine with darktable 2.4.4. on Debian Stretch.

(I prefer to use the Trackman as I get RSI problems with standard mouse devices.)

Has anyone else noticed this issue with darktable for Mac? And, more particularly, does anyone have any thoughts about a fix — apart from the obvious cludge of using an Apple mouse to do scrolling where needed! :wink:

TIA for any thoughts.


(Daniel Catalina) #2

I guess it is a problem from how the Trackman (or scroll wheels in general) works on Mac. I used darktable with the MacBook trackpad and all was fine…

Maybe you can have a look in the Trackman settings and see if there is something funky there?

To make my comment clear, Based on the experience with the trackpad I think it is not a darktable issue, but more a MacOS driver/way to interpret scroll wheels …


#3

@Daniel_Catalina Thanks for your reply. I’m not sure it’s entirely an issue due to MacOS rather than darktable, because the mouse wheels of various devices do work correctly in other Mac software, and with other aspects of the darktable GUI — just not with darktable’s ‘shift + scroll’ .

What’s odd is that the problem is specific to ‘shift + scroll’ for changing feather size. Odd.

I should say that like most ‘third-party’ mouse devices with scroll wheels that I’ve tried, the Trackman doesn’t have its own driver. You just plug in the USB cable. (The Wacom tablet does have its own driver). I suspect the problem is due to the way darktable interacts with the native MacOS mouse driver.


#4

How do I pass this information to the devs who maintain darktable for Mac?