shrunken workspace (mac)

I opened a photo in Rawtherapee and find that the workspace has become very small and crammed into the upper right corner of the window. I deleted my copy of the software and reinstalled, but have the same problem. How do I make it normal-sized again (usable, that is?) Thanks!

a) Operating system?
b) Rawtherapee version?
c) From where did you obtain your version?

Sorry, of course that would be helpful.
Mac OS 12.5.1, RT ver 5.8, downloaded from the Rawtherapee website

Here’s a screenshot

You are using a rather old version, upgrading to a newer one is advisable. Have a look here:

Not sure if that solves the shrunken window problem (assuming it was normal sized before), you might give it a try. It will give you a better RawTherapee experience in a broader sense, though.

Most likely your configuration file is having an issue. Without RT running, locate it on your mac (not a mac user here so I dont know where it is kept) and rename it. then start RT and see if that solves the issue

With the mouse, grab a corner to adjust the width and height to suit.

Thanks, @jimoe . That was the first thing I tried. There isn’t a live corner to grab and when I try, it just grabs the photo in the tiny window and moves it around within the window.

Thanks, @AdmFubar. I looked for the config file to try this, but where I expected it to be (in the Rawtherapee config folder in the library) it was not there (folder was empty).

Thanks, @Jade_NL. Waiting for it to download now.

@Jade_NL I removed the old version, emptied the trash, and tried the newly-downloaded Universal Mac application you pointed to, but it is doing the same thing as pictured above. It’s all very strange, given that I have been using the program on this machine for awhile now with no problems…

hang in there some mac user prolly knows where to look.

Not sure if this is a RawTherapee issue or a MacOS one (mind you: I’m not a MacOS user).

If I look at your screenshot I notice that the window created by MacOS does seem to be large (almost full screen) and that RawTherapee is small inside that dedicated window. I’m not aware of that being an option that MacOS offers (based on some on-line searching and digging).

Is this issue restricted to RawTherapee or do other applications also show this?

Either way you might want to also have a look at your MacOS preference settings (possibly the ones that are RawTherapee specific).

The configuration file (called options) should, on a MacOS based system, reside in:

~/Library/Application Support/RawTherapee/config/

Assuming you found it: Rename it to options_org or something similar and start RawTherapee.

Restore the saved file if it doesn’t solve the problem (this will give you your personalized configuration settings back).

Just in case: Leaving the options file as-is and removing the [GUI] section in that file (on my machine that would be up to and not including [Crop Settings]) would probably suffice. This would keep all your other configuration settings as they are.

I am confused by your screenshot. You said the image was squished into a small space in the upper left corner? Your screenshot looks normal to me.

@jimoe The window is normal sized. The workspace is only in the upper left quadrant. The text is too tiny for these old eyes to read. This is a change from the usual, where the workspace always filled the window.

Aha! Thanks, found it. But alas, it did not solve the problem. The only thing similar I have had happen was when Thunderbird’s text got very tiny. I had to go into the config file and edit pixels there. Is there something similar in the options file? Here is stuff that might be relevant, but not sure what all the referents are so not sure which to try:
FontFamily=Helvetica Regular
CPFontFamily=Helvetica Regular

How large is your screen? I’m asking because your screenshot has a 2942x1638 resolution, but the info shown in the RawTherapee options files says: 1464x748. OK, that needs a little extra room for the workspace header and the window manager, but it isn’t even close to the aforementioned screenshot size. It is, in fact, a factor 4 smaller and exactly what you are seeing. Maybe you can force it:

Assuming for the moment that 2942x1638 is your screen size: (Stop RT first) Try editing the options file and change:






The actual numbers are an approximation and well within the screenshot size, I don’t have a clue how much is taken by MacOS’ WM (in Linux I can use the full screen resolution). If this works you might want to play with these numbers.

Anyway; Not sure what is going on here and I’m still not certain that this is an actual RawTherapee related issue. The screen size (workspace size on a Mac?) is provided by the OS and picked up by RT when first starting the program. Something seems to have gone wrong there. I do not have the MacOS expertise to help you with the MacOS bit, though.

Thank you. I tried this. It made the window bigger but not the workspace. When I opened the config file again to try some larger numbers, I found that something (the OS?) had changed the WindowWidth to 1512 and the WindowHeight to 851. The meow numbers did not change. I think you may be right about it being a mac OS issue, but not sure where to go from here. Is there a way to call attention to this question so that knowledgable mac folks are likely to see it?

That is correct. RawTherapee writes some info to the options file when it is closed, the window size at the time of closing is one of them.

You posted in the correct section, added info and OS in the title and this topic has been pushed to the top multiple times over the last few days, not much more can be done. Maybe someone will pick it up after the weekend.

Assuming you haven’t already: Might want to ask on a MacOS specific board about this behaviour.

@Jade_NL I posted to a mac board that seemed to have developer types on it, but so far no useful responses. I went ahead and filed a bug report, in case someone might want to develop a patch for this problem. I’m wondering if the new 5.9 will play nicer with the Monterey OS.