Siril 1.2.0-beta1

A little more than a year ago, we released version 1.0.0 of Siril. This version number, highly symbolic, symbolized the age of maturity of a software that we believe had become stable and powerful. Since then, many updates came to improve little by little this version 1.0 by fixing many bugs and by bringing small improvements. In parallel to the development of this so-called stable branch, we have continued to intensively develop new features, resulting in profound changes.
This is a companion discussion topic for the original entry at

Some bugs in the Mac ARM version. When I select something that allows for multiple pop-up entries (eg: select sequence), a truncated popup window appears which only gives me 2 options. I can not scroll to pick other sequences. In the Registration tab, under Registration Method, I can only access 1-2-3… and Global Star. I can not get to Comet Registration as I could with the previous version. In fact, this seems to affect all options with a down arrow for selection. Can’ really use this β until this is remedied. Looks like lots of new options.

Are you on Ventura?
Can you choose with arrow key?

Bug on Ventura are difficult to fix. I don’t think we can do something…

When I tried it again, it seemed to work. I have to keep the left mouse. Button pressed down to display the menu, but no problem.

Jack M. Bernstein

Its fixed in the latest gtk3 release, if its the same bug as darktable saw, which is sounds like it is. Not sure if brew/macports has picked up that release yet.

Hi, I have just tried Siril after update and I have 2 suggestions. First, Some kind of preview tool, where you choose small fragment of the image, would be nice, to quickly test for example denoise or deconvolution parameters. Secondly, I think that you should be able to use normal Asinh and histogram transformations while doing star recomposition.

For preview, as we suggest in the documentation, you can make a crop, make your tests, and undo to the crop when you’re happy with the results.

Good idea, didn’t think about that! Thank you

Hi Devs, thank you for this amazing software, being using it for a while now. New features are amazing too, the star removal doesn’t work at all for me, any suggestions on how to get it to work?

Error show in Box: “No valid StarNet executable found to configure Starnet installation directory. Check your StarNet installation and Siril configuration”

I tried launching from the .bat bust still the same.

Thank you for your time

Did you set the StarNet++ Command Line Tool installation directory path in Preferences?

1 Like

Thank you for your quick reply! Originally no i haven’t but after seeing your comment i set it and it still nothing, even restarted my pc. Should i place the tool in sirils directory? its placed on my desktop at the moment

Did you make sure you are NOT using the GUI version of starnett++. It doesnt work with that. Only the command line version.

1 Like

aaah i see, i AM using the GUI version, thank you for the clarification, i will try the command line and report back

Thank you Cheman, everything works beautifully now, the CLI version did the trick!

Again, thank you for your help!

1 Like

Congratulations on the new release! Amazing addition of features… I’m fairly new to SIRIL (have been using APP and PI) but I need SIRIL for it’s speed… it is so fast! I need this because I shoot very short exposures on an Unguided GOTO Dob, so I’m hoping to switch to SIRIL.

Anyway, one feature I need is the new “-framing=max” option/feature on Seqapplyreg because due to my field rotation I need an expanded frame for stacking. So thanks for the new feature!

I tried testing it and modified the OSC_Preprocessing_NoDarks script to this:

Align lights

First doing: register pp_light -2pass -noout

register pp_light -2pass -noout

Now doing: seqapplyreg pp_light -framing=max

seqapplyreg pp_light -framing=max

It stacked, but my stack was very low quality compared to if I left off the “-framing=max” feature. If I leave that off, it stacks with the same quality as before, but when I put in “-framing=max” the stack is a smooth (low noise) result that has almost no details of the target. It did expand the frame to capture all the rotated lights (yay!), but something messed up with the integration.

Here is the good result (cropped and only a few lights so ignore the noisy results):

And here is with the “-framing=max” option:

I tested two different data sets with similar results. Perhaps the feature isn’t ready for testing yet?

Autostretch depends on the histogram. Including areas that does not have the same noise level or even black borders will change it. So it’s probably just a different way of visualizing the same data. You could probably get the same result by stretching both images manually.


it should be ready for testing :thinking:
Could you share the scripts you’re using here, and possibly the 2 stacks through wetransfer or else?



Our mac dev includes everything in Siril. The problem is that the upstream fix is … not very good apparently.

OMG, you are absolutely correct. The oversized frame has solid black and that really threw the autostretch off, in both SIRIL and Astro Pixel Processor. It took a fair bit of manual stretching to make them similar, but if I cropped them both to the same inner image, than the pre-stretch was almost identical.

I am humbled! Thanks for the quick response. I’m going to love this new feature!

1 Like

Great upgrade. Love the new features. Thanks to all the dev team. :clap: :+1:
I have a question on the 3 stretch tools:

  • I notice that GHS has the option to select a modified ArcsinH as well. Is this different to the AsinH option?
    SUGGESTION: Could you add the sliders at the bottom of the histogram to the GHS view (similar to whats available in the Histogram Transformation option) as well please.