Siril 1.2.0-rc1 platesolving fails (local and network based)

Hi all.
I downloaded the latest 1.2.0-rc1 version on both a Windows 10 and 11 machines, and loaded a .fits image that was correctly being plate-solved by Siril 1.2.0-beta2. After following the same procedure of Dynamic PSF star finding, and then providing a more or less central star coordinate, plate solving fails ither using a local solver or the online solver. After reverting to 1.2.0-beta2 it works correctly, and installing 1.2.0-rc1 fails again, on both machines.

I tried using the configuration dialog to point Siril to the local and kstar catalogs, but it makes no difference.
When trying with the local solver, the emerging dialog shows a typical “Plate solving failed. The image could not be aligned with the reference stars”, plus the long text.
When trying an online solver, however, instead of the long text it shows “Could not load the star catalog (generic error)”, and the console shows “Failed to read the local NOMAD catalogue”.

I even used the same reference star on both cases.

1 Like

Could you share the image please

Sure thing:

Use pixel size 4.28, focal length 135mm (but it matches at 129.6mm).
This happens with another image as well, and the same image I’m sharing when saved as astro-tif.

When trying plate solving with GAIA DR3, Siril becomes unresponsive.

I made a platesolve very fast just by writting NGC 2070 in the search field. That’s all.

I just tried with NGC 2070 and it still fails for me, whether using the online catalogs or the local solver. It works without issues again if I revert to 1.2.0-beta2. Maybe the issue happens in Windows machines due to a difference in compilation? Sadly I don’t have a Linux machine anymore to try it.
I also tried other star catalogs: if I force Tycho2, NOMAD and Bright Stars, besides the error message dialog, the console says it “failed to read the local NOMAD catalogue”. To emphasize, it still mentions NOMAD even if I choose Tycho2 or Bright Stars.

PPMXL does load correctly but fails to align even if I manually detect stars first.

Failed to read the local NOMAD catalogue

It is not properly installed

1 Like

I have checked the NOMAD installation several times, and even did a clean reinstall. Please do keep in mind that:

  • When I revert to beta2 it works without issues, I’m pointint to the same catalogue file.
  • Siril complains about NOMAD even when selecting Tycho2 and Bright Stars.
  • GAIA DR3 hangs Siril.
  • PPMXL doesn’t solve.
  • A local astrometry dot net installation works with beta2 but not with rc1.
  • All of this happens in two different machines with Windows 10 and 11.
  • I tried using two completely different network connections for online solving, same result.
    Thank you.

I did it with RC1, and it works on my computer. I use local NOMAD.

In fact it is because it is very long to download such a wide field. You need to be patient.

Again. I tried and it works on my machine.

Thank you. Are you using a Linux machine? If so, are you able to try in a Windows one, please? Otherwise maybe someone else could test that, if possible. Maybe there was a compilation difference for the windows version.

However, is it normal for Siril to complain about NOMAD when pointing to other catalogues for plate solving?

Apparently it doesn’t work on windows, that’s what it means… When the local catalogues are installed, they often take precedence.
Remove the reference to at least one of the four catalogue files in the preferences and it will return to the normal online mode…

@david_od ,

I’m the only dev here with a Windows machine… and it does work for me, both local catalogue and astrometry dot net (both cygwin_ansvr and a local build with a more recent version). Could you run the command:

get -a

and paste the output here, check if I can spot smthg?



1 Like

And maybe trying to disable all AV on your machine.

Here it goes, thank you!

core.wd = (not set)
core.extension = .fit
core.force_16bit = false
core.allow_heterogeneous_fitseq = false
core.mem_mode = 0
core.mem_ratio = 0.9
core.mem_amount = 10
core.hd_bitdepth = 20
core.script_check_requires = true
core.pipe_check_requires = false
core.check_updates = true
core.lang =
core.swap_dir = C:\Users\INVITA~1\AppData\Local\Temp
core.binning_update = true
core.wcs_formalism = 1
core.catalogue_namedstars = ~/.local/share/kstars/namedstars.dat
core.catalogue_unnamedstars = ~/.local/share/kstars/unnamedstars.dat
core.catalogue_tycho2 = ~/.local/share/kstars/deepstars.dat
core.catalogue_nomad = ~/.local/share/kstars/USNO-NOMAD-1e8.dat
core.rgb_aladin = false
core.copyright =
core.starnet_exe = (not set)
core.starnet_weights = (not set)
core.gnuplot_dir = (not set)
core.asnet_dir = C:\astro2\astrometry
core.fftw_timelimit = 60
core.fftw_conv_fft_cutoff = 15
core.fftw_strategy = 1
core.fftw_multithreaded = true
starfinder.focal_length = 0
starfinder.pixel_size = 0
debayer.use_bayer_header = true
debayer.pattern = 0
debayer.interpolation = 8
debayer.top_down = true
debayer.offset_x = 0
debayer.offset_y = 0
debayer.xtrans_passes = 1
photometry.gain = 2.3
photometry.inner = 20
photometry.outer = 30
photometry.inner_factor = 4.2
photometry.outer_factor = 6.3
photometry.force_radius = true
photometry.aperture = 10
photometry.minval = -1500
photometry.maxval = 60000
astrometry.asnet_percent_scale_range = 20
astrometry.asnet_sip_order = 0
astrometry.asnet_radius = 10
astrometry.asnet_keep_xyls = false
astrometry.asnet_keep_wcs = false
astrometry.asnet_max_seconds_run = 10
astrometry.asnet_show_output = false
astrometry.update_default_scale = true
analysis.panel = 256
analysis.window = 381
compression.enabled = false
compression.method = 0
compression.quantization = 16
compression.hcompress_scale = 4 = false
gui_prepro.equalize_cfa = true
gui_prepro.fix_xtrans = false
gui_prepro.xtrans_af_x = 0
gui_prepro.xtrans_af_y = 0
gui_prepro.xtrans_af_w = 0
gui_prepro.xtrans_af_h = 0
gui_prepro.xtrans_sample_x = 0
gui_prepro.xtrans_sample_y = 0
gui_prepro.xtrans_sample_w = 0
gui_prepro.xtrans_sample_h = 0
gui_prepro.bias_lib =
gui_prepro.use_bias_lib = false
gui_prepro.dark_lib =
gui_prepro.use_dark_lib = false
gui_prepro.flat_lib =
gui_prepro.use_flat_lib = false
gui_prepro.stack_default = $seqname$stacked
gui_prepro.use_stack_default = true
gui_registration.method = 0
gui_registration.interpolation = 4
gui_registration.clamping = true
gui_stack.method = 0
gui_stack.normalization = 3
gui_stack.rejection = 5
gui_stack.weighting = 0
gui_stack.sigma_low = 3
gui_stack.sigma_high = 3
gui_stack.linear_low = 5
gui_stack.linear_high = 5
gui_stack.percentile_low = 3
gui_stack.percentile_high = 3
gui.first_start = 1.2.0-rc1
gui.silent_quit = false
gui.silent_linear = false
gui.remember_windows = true
gui.main_win_pos_x = 0
gui.main_win_pos_y = 0
gui.main_win_pos_w = 2560
gui.main_win_pos_h = 1342
gui.pan_position = 1735
gui.extended = true
gui.maximized = true
gui.theme = 0
gui.font_scale = 100
gui.icon_symbolic = false
gui.script_path = C:\Users\guest\AppData\Roaming\siril\scripts ; C:\Users\guest\Downloads\siril-1.2.0-rc1_win\siril\scripts
gui.warn_script_run = true
gui.show_thumbnails = true
gui.thumbnail_size = 256
gui.selection_guides = 0
gui.show_deciasec = false
gui.default_rendering_mode = 0
gui.display_histogram_mode = 0
gui_astrometry.compass_position = 1
gui_astrometry.cat_messier = true
gui_astrometry.cat_ngc = true
gui_astrometry.cat_ic = true
gui_astrometry.cat_ldn = true
gui_astrometry.cat_sh2 = true
gui_astrometry.cat_stars = true
gui_astrometry.cat_user = true
gui_pixelmath.pm_presets =

I created a new, clean windows user account with admin privileges. I downloaded the portable versions of rc1 and beta2, and with rc1 I get some results. Now I can solve with Tycho2 and PPMXL, but NOMAD fails no matter what I do, with or without local catalogues with either rc1 or beta2.
In rc1 a local astrometry dot net installation does not work.
In beta2 local astrometry works immediately and fast.

What I see in the “get -a” results is that the core catalogues point to a place in ~/.local/share/kstars, but they are actually at C:\astro2\kstars_catalog (unless the first one is just a pointer to the actual location).
After installing the local catalogues in beta2, Tycho2 and others now stop working for some reason (they worked in my other original installation before the release of rc1). Local astrometry works without issues.

So in terms of practicality, the main issue now is that with rc1 the local astrometry dot net solver is not working for me even with a clean installation. I’m using a 10 degree radius, beta2 solves without issues.

I don’t use anything besides MS Defender. I still disabled Real Time Protection and Tamper Protection, and it makes no difference. Still, beta2 works has worked without issues since I installed it.

I don’t understand how with linux paths configured on windows it can detect that the NOMAD (and other) local catalogue is available.
Did you actually point to their real location in the preferences?

Yes, I only discovered this after learning the “get -a” command. To be fair, I have not tried offline solving and color calibration (besides astrometry dot net) until now.
On my Windows 11 machine they point to the right file paths.

I installed Ubuntu on VMware. I downloaded the AppImage, installed the astrometry-tycho2-* packages, and it solves with local astrometry dot net (to the surprise of nobody, I suspect).

I tried once again with the Portable Windows version of rc1 and beta2, and this time I unpacked the .xz files :grimacing: which I assumed were intended to be used in compressed format, as it happens in other specific software cases. Now rc1 solves using the local NOMAD database without complaints.

The remaining issue is that local astrometry net still does not work with rc1. I reinstalled astrometry dot net, and the issue persists. beta2 works, rc1 doesn’t. They access the same folders with the auxiliary executables and catalogues, and I triple checked this is the case.

One issue I’ve noticed is that when calling the local astrometry net solving, in beta2 a small windows briefly flashes: it emerges and closes itself immediately; it’s impossible to see what it is, but I’d wager it’s a console (terminal) window. This does not happen when doing the same in rc1.


so let’s see.

yes, this is documented there: Installation on Microsoft Windows — Siril 1.2.0 documentation

I’ve had to change the way we handle 3rd party software for rc1 because we had many problems with some Windows configurations (losing handles to all these consoles allocated on the spot). We don’t need to allocate a new console like in beta2 because there’s already one available throughout the whole time Siril runs (it minimizes when you open Siril but it’s there).

Now, I will need to see some logs, otherwise, I’m just blind to what is happening on your end.
Could you please do the following? I’m assuming you still have the regular package installed. If not, modify the path below to point to the portable executable).

  • Open a cmd terminal and type “C:\Program Files\Siril\bin\siril.exe” >log.txt
  • In Siril, set as Home directory the location where the fit you have shared is saved (I saw in the get -a output none was defined)
  • Still in Siril, type the following commands:
    • set astrometry.asnet_keep_xyls=true
    • set astrometry.asnet_keep_wcs=true
    • set astrometry.asnet_show_output=true
    • get -a
    • load result_old
    • platesolve -platesolve -localasnet -focal=135 -pixelsize=4.28
  • Close Siril. A log.txt should be saved at the location where the cmd terminal was opened.
  • Please share it here.

Also, can you show the architecture of your folder C:\astro2\astrometry?



If it helps, I tried on my Macbook pro using 1.2.0-rc1 and it doesnt platesolve. If I choose a larger focal length such as 1000 it hangs Siril

Thanks a lot Cecile. Here goes the Siril log:
log.txt (6.6 KB)

And the astrometry net folder structure (now C:\Astro\Astrometry_net, but it’s pointing there):
astrometry.txt (7.3 KB)