[Solved] Darktable UI messed up after Ubuntu 17.04 upgrade


#1

Hi,

After upgrading to Ubuntu 17.04 from 16.10, I noticed a couple of things changed (for worse) in my darktable.

  1. icons became unusually large (see screenshot below) and now my right panel get really cramped.
  2. Two thick red rectangles and another bottom think red line suddenly appears.

My darktable version is 2.2.5 and I installed it from the pmjdebruijn-ubuntu-darktable-unstable ppa

Does anyone know how I might fix the issues?


#2

When upgrading your Ubuntu to a new version you also have to change all the PPAs to pull packages for that version. So in your case you have to go to /etc/apt/sourced.list.d/ and edit the right files. Then apt-get update and apt-get dist-upgrade.
The reason for those red borders is that its the default warning-look of darktable that gets shown whenever GTK breaks our theming.


#3

Thanks a lot @houz.

I forgot to mention in my original post that I had already updated the PPA for Ubuntu 17.04. And that didn’t cure the problem.

After trials and errors, I found that problem was caused by this file: ~/.config/darktable/darktable.css

I noticed that this file wouldn’t exist in a fresh install of the latest version of a darktable. After I deleted the file, darktable is back to normal.


(Torsten Stocklossa) #4

Hi All,
well same here after upgrading from 16.04 LTS to 18.04 LTS as far as I can see I updated all package sources. I do not have the darktable.css file

cheers
Torsten


(Torsten Stocklossa) #5

forgot to mention darktable version 2.4.4.


(Massimo Bill) #6

Hi @Torsten, you may want to have a look at this topic: horrible red frames around all elements and way huge icons in dt 2.4.4

I had the exact same issue. I could solve just by uninstalling and installing darktable again (simply with apt-get).

In the topic there are maybe a few more details.


(Torsten Stocklossa) #7

Hi
thanks for pointing me to the right direction… I just edited the .css file as mentioned in there. ( the font … line ) et voila… it works. I still get GTK errors when I start darktable from command line but it at least looks ok now

Viele Grüße
Torsten