[SOLVED]Lost thumbnails in RPD interface

I’m running Manjaro, fully updated. Seems to be a python issue. Anyone else experience this or do I have a stale file/package hanging around on my system and if so, which could be the offending one? @damonlynch - can you take a guess by the following output from the CLI?

    File "/usr/lib/python3.10/site-packages/raphodo/thumbnailextractor.py", line 890, in <module>
    thumbnail_extractor = ThumbnailExtractor()
  File "/usr/lib/python3.10/site-packages/raphodo/thumbnailextractor.py", line 191, in __init__
    super().__init__("Thumbnail Extractor")
  File "/usr/lib/python3.10/site-packages/raphodo/interprocess.py", line 1178, in __init__
  File "/usr/lib/python3.10/site-packages/raphodo/thumbnailextractor.py", line 878, in do_work
  File "/usr/lib/python3.10/site-packages/raphodo/thumbnailextractor.py", line 853, in process_files
SystemError: PY_SSIZE_T_CLEAN macro must be defined for '#' formats

The problem is in PyQt5 / PyQt5-sip. If your system is fully up-to-date, Manjaro needs to update PyQt5 and PyQt5-sip to incorporate a bug fix for exactly this problem. The PyQt5 / PyQt5-sip fix was released a month or two ago — I don’t recall exactly.

Oops, should have read this first I suppose…SOWWY!

Trying to “install PyQt5.15.6 yourself using pip” as suggested by Damon.

Got it, I’ll sit back and wait for the packagers to catch up or try to get something from AUR myself.

Thanks, Damon! Djeez, you’re fast!

Update: solved by temporarily using this ARCH package: python-pyqt5-5.15.6-7-x86_64.pkg.tar.zst from Arch Linux - python-pyqt5 5.15.6-7 (x86_64)

I’ll replace it as soon as Manjaro updates but for now, thumbnails are back!

1 Like