[solved] Reading CR3 file problem of Windows binary of Ver. 1.22.1

Hi, Alberto
It seems that ART 1.22.1 Windows binary cannot read canon CR3 files.
I tried CR3 file in link below.

Linux binary of 1.22.1 and windows binary of 1.22 have no problem in reading this CR3 files.

Thank you for your attention and support.

strange, it seems to work fine here…

anyone else having troubles?

No problem here. Also some more cr3 files I had ready to hand work fine.

I tried cr3 file processing with ART-cli in Verbose mode.
I could get final jpeg file, however it takes very long time (more than 15 minutes).

Here is the log.

After output message “Raw preprocessing white balance: temp 6107.357025, tint 1.076171, multipliers [2.068785 1.852288 1.869823 | 2.068785 1.852288 1.869823]”, the process became very slow.

Thanks for the effort, but this is not of much help unfortunately. Does this happen with the neutral profile or with a specific arp? Also can you try disabling exiftool?


Thank you for your reply.

I tried following attempt but there was no effect. It seems that is is not arp setting problem.

Making default profile neutral and reading CR3 file.

Temporary deleting exiftool.exe and reading CR3 file.

And putting CR3 file in new directory, the CR3 file does not appear in file browser of Ver. 1.22.1. However once opening the file with Ver. 1.22 (or earlier), the file appears even in file browser of Ver. 1.22.1.

Also I tried install Ver. 1.22.1 in other computers with Windows 10 or 11 (of course Japanese version), the result was same.

Thanks for the info. V1.22.1 is basically identical to v1.22. the only big change is that I upgraded my version of exiv2 to 0.28.something (like I use on Linux), to addess the issue with om systems lens metadata. Maybe that is the culprit?
Can you try one of @gaaned92’s opimised builds from ART-W64NightlyBuilds – Google Drive ?

Certainly is. Exiv2 0.28 lost wide char support on Windows, and Windows apps now must be built as UTF-8 native.

Aha! Thank you, I totally missed that. I’ll see if I can go back to 0.27.x at least temporarily then

I went back to exiv2 0.27.7 and uploaded a new windows installer:
Let me know if this works

Thank you.

I tried Ver., and Nikon, Olympus / OM System, Panasonic, Sigma files are OK, but unfortunately with Canon files (CR2, CR3) there is still problem.

I installed Ver. and deleted all cache files and restarted Windows.

Exif2 may have a UTF-8 specific problem with Canon settings, however I have no clue what is the problem.

It turns out that I uploaded the wrong file by mistake…
Here’s a new link, hopefully this time I did it right:

1 Like

Thank you very much.
It is very good!