Starnet in 1.2.0-beta2

Ah, some progress! So it seems it can’t run outside of Siril either… I’ll try to look up what kind of error this is

Best I could find is that… not encouraging

Glad I could be of little help. BTW, I’m really enjoying your new Star Processing options. I already took a few of my .jpgs that had bloated stars and greatly improved them using Siril. Keep up the good work! Looking forward to trying your new live stacking.

1 Like

In one of the other posts, the one from Stargazer’s Lounge, I noted that some of the failures were caused by starnet++ not working on older processors. That may be the issue, as I have several PC’s running Win10 and one running Win11. One of the Win10’s that is failing has an older AMD processor. However my Win11 which is failing has a more modern processor, but it’s a mini-pc (a Mele Quieter3) that has the Celeron n5105 processor. The same error message (0xc0000142) is present.

I have the MeLe Quieter 3 as well so I tested it there, and can confirm I receive the same error running StarNet. What I discovered is Starnet requires the AVX instruction set from the CPU, and the n5105 does not have it. I confirmed this by running HWINFO. If AVX was supported, it would be green, and as you can see it is not.
@cissou8 So quickest way to answer this is download, install , and run HWINFO and have them check that AVX is in green.

@Rich_Stevenson , thanks for the investigation.
I had seen this hwinfo program mentionned somewhere. But as I don’t know what’s behind (not open source, not sure whether it would install other stuff), I don’t want to recommend…


Ah yes. Good point!

Hello everyone,

I am a new to astrophotography, and rather ignorant on many things - i’m learning as I go. Boy do I have a lot to learn, but emthusiastic about this hobby.

I am using Windows based systems, specifically, Windows 10 v22H2 running at 64-bit and using an Intel (R) Pentium (R) processor, G4560T @ 290GHz. I just cannot figure out how to get Siril to recognize Starnet ++. I uninstalled the Siril version I had and installed the latest Siril 1.2.0-beta 2 and installed the Starnet++ (StarNetv2CLI Unzipped the Starnet file and saved it to my C drive. I went into Siril, clicked on preferences & miscellaneous, then set the link to startnet++.exe. Siril will not recognize the link (the Execute is grayed out). Siril doe show Starnet for software location when I go back to preferences & miscellaneous.

Can you please lett me what I am doin wrong. I’ve been “WORKING” on this for almost 2 weeks and getting more frustrated. Any ideas or suggestions would be greately appreciated.


are you able to run starnet from a cmd prompt? What do you get if you cd to the folder where you have unzipped starnet and run
starnet++.exe mono_test5.tif starless.tif



Sorry for the delay in my response, I was working a 12 hour shift…when using rgb_test5.tif is get a beautiful image of a nebula with starts. When using starless.tif image the same image without the stars.


can you type in Siril command line:
get core.starnet_exe
and paste here the output shown in the Console tab?


1 Like

Thank you for your continued efforts. below is the result.

By the way, I saw something on YouTube where someone dragged and dropped the rgb_test5.tif into starnet++.exe and watched the program remove the stars. When I did this I go an error message so maybe there is something wrong with Starnet++, or just my downloading of Starnet++ (I would not be surprised if it is something I’m doing).

Can you try relocating the whole starnet folder to someplace else than C:\Program Files?
This is a special folder that needs special permissions. Could be blocking the execution


Well I Uninstaller and reinstalled both Siril and Starnet++. I then reinstalled Siril and it put itself in the Programs folder. I installed Starnet++ on the Desktop. Got the same result with the drag and drop on Starnet and when I enter the command in the Siril command line.

Im getting that starnet isnt found! I cant even get the thing ready to launch.

Probably because StarNet CLI can’t work on your machine.

Well i have avx so what other requirments are there? It just cant find it. For some reason the exicute button stays grey with no starnet being found when i have the un zipped file. Idk man. Super strange.

If you don’t show us error messages we won’t be able to help. Try running starnet CLI outside siril first please.

Hi, I am having the same issue, I have installed the latest version of Siril, 1.2.0-rc1 and downloaded Starnet++ v2 (StarNet2CLI-Win). Starnett is installed in my c directory, not program files.

I have uninstalled Siril, reinstalled Siril, downloaded Starnett again all to no avail. Siril itself works beautifully!

I can see Starnett under Preferences, Miscellaneous, but the following error is displayed when trying StarNet removal: No valid StarNet executable found in the configured StarNet installation directory, check your StarNet installation and Siril configuration. Execute button is disabled.

Running on a i5 Intel Core i5-5200U with Windows 10.

Please help!

Hello, try running starnet CLI outside siril first please.