Test of RawTherapee on MacOS 10.14-15, 11, 12β Mojave-Catalina-Big Sur-Monterey (intel code)

RawTherapee Development Build for MacOS 10.14+

I have built and tested this in the Monterey beta, but this should also work for Mojave, Catalina and Big Sur.

The dependencies are 98% from brew running on 10.14 Mojave.

However, libomp is using a load command introduced in 10.15 Catalina. Libomp and unwind now load on 10.14 Mojave.

llvmorg-12 libomp crashes during RT options loading. (11.1.0 is used)

Please test / report any successes or failures.
5.9 is almost ready; head over to Issues · Beep6581/RawTherapee · GitHub if you can help out.

Thank you Hiram!
CrashReport.pdf (947.2 KB)

My first impressions:
This build is much more stable with denoising etc. in 1:1 magnification than the previous one, but I did manage to make it crash :grinning: (crash report attached).
Also, the new Spot Removal module does not appear in the Detail group.

1 Like

Thanks for the report! The crash might have been caused by libomp or unwind, both of which I have rebuilt to an early macOS SDK. The bundle has been replaced under the same download link above. See if that still happens to you, or could you specify which actions cause the crash.

Hi, working fine in 11.4. Did not manage to crash it yet, but I will keep trying :grinning:

1 Like

I had to fetch and merge the most recent features; spot removal is now there.


@neversetsun Which macos are you using?

macbook pro mid2014
i5 dual core
macOS 11.4

@neversetsun Thanks for following me over to this thread… are you able to obtain the system crash report?

Testing the macOS 12 Monterey beta… round slider buttons are not grabbable, but do move when the slot is clicked as normal. It has got to be a gtk+ thing going on, either gtk or gtk-mac-integration. This is with homebrew libs. (macports libs don’t launch atm).

a late reply: tried homebrew install gtk gtk-mac-integration, but still reports:
Termination Reason: DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  dyld: Using shared cache: 4A889CE9-8D7E-304E-A5F7-84D819B0BF9C
Library not loaded: /Applications/RawTherapee.app/Contents/Frameworks/libgtkmacintegration-gtk3.4.dylib
  Referenced from: /Applications/RawTherapee 2.app/Contents/MacOS/rawtherapee
  Reason: image not found

The app can’t handle being renamed, or having duplicates, btw.

i see, thanks
it works now with apple raw :grinning:

Thanks so much for these builds @HIRAM.

I have an issue with this latest build though ( RawTherapee_OSX_10.12_64_5.8-3048-gc901f644a ) where I can no longer select ICC profiles under ‘Color → Output Profile’ that are stored in either in /Library/ColorSync/Profiles or ~/Library/ColorSync/Profiles with the exception of profiles in the subfolder /Library/ColorSync/Profiles/Displays.

Previously I could select profiles in /Library/ColorSync/Profiles or ~/Library/ColorSync/Profiles without issue.

If I revert to a previous version ( RawTherapee_OSX_10.9_64_5.8-397-g276ae214f ) then it works fine.

I’m on macOS 10.15.7 (19H1323)

Thanks again, looking forward to your reply.

Hmmm, I will have a look as I am getting a new build environment running.

Thanks @HIRAM , much appreciated!


This latest build doesn’t exhibit the slider-button non-grabbage issue in Monterey.

Also note that your contribution is optional and useful, as Apples don’t exactly fall off trees.


For those following along, https://kd6kxr.keybase.pub/RawTherapee_macOS_10.14_x86_64_5.8-3046-g5268b94cf.zip
the new build has the RgbDenoiseThreads defaulting to 2 instead of 0 to fix a crash occurring in RGB luminance denoise.
To do this I have updated the options keyfile. That means, to have the new default behavior, delete your '~/Library/Application Support/RawTherapee' or if Big Sur+, the ~/Library/Containers/RawTherapee folder before first launch.