Testing CR2 Upload (And Failing - Can anyone else upload one?)


(Pat David) #1

Just testing an upload of .CR2 files, I’m having trouble getting one of them uploaded for some reason.

Can anyone else please upload a .CR2 file in this topic for me? I’m wondering if it might be this one file.

I am also unable to upload the file from @Stampede in this post:

@darix the extension CR2 is in the list of allowed file types to upload, but when you get a moment could you please double check? I’m wondering if it’s just this particular CR2 file.


(darix) #2

CR2

so first problem: it didnt like the filename starting with a number it seems. after I renamed it to DCF_ it let me upload it. but somehow discourse treats it as a tiff :frowning:


(darix) #3

this is a 5Ds IIRC … same problem it tries to treat it as tiff.

CR2


(darix) #4

testshot2


(Stampede) #5

The file that I posted, and that Pat tried to re-post came from a 5D Mark 4.

But I have the same problem with CR2 files off of my Powershot G7X Mark 2.

I just tried uploading IMG_0555.CR2 that came from my Powershot, and I got the “file not authorized” once it finished uploading. So I do not think that the filename starting with a digit has anything to do with it.


#6

Same thing here, 80D, IMG_1850.CR2.

sorry


#7

@patdavid Silly idea: people have tried to upload CR2 (upper case)
while only cr2 (lower case) is permitted?

Have fun!
Claes in Lund, Sweden


(Stampede) #8

When I brought up the uploading issues a few days ago, I did try renaming my file to *.cr2 and the site still rejected it.


(Pat David) #9

We’re looking into this. Not quite sure where the hiccup is yet, but @darix did some preliminary digging already.

So sorry for any inconvenience at the moment! :frowning:


(darix) #10
  1. With upstream we tracked down the bug https://meta.discourse.org/t/cr2-raw-files-are-being-treated-as-tiff-files/96775
  2. we have a “workaround” in place. you can now upload tiff files. as fastimage treats CR2 as tiff, you can upload them now. but it also means that after downloading you have to rename them from tiff to cr2.

(Mica) #11

Great work @darix! Thank you.


(darix) #12

Better workaround applied.


#13

Thanks @darix! I wonder why it worked before. Probably some changes in the back end…