Testing : Qt-based version of the G'MIC plug-in for GIMP


(David Tschumperlé) #1

Hello friends,

As you may know, we are currently implementing a brand new interface for the G’MIC plug-in, based on Qt. It is intended to become a kind of ‘universal’ plug-in that could be ported for other software than GIMP (in particular, we have Krita in mind, of course!).
By the way, this is still a beta project, but we have managed to build a version of this Qt-based plug-in for Windows, and I’d like to share the news with you.
So here is the new plug-in in action :

As you can notice, this plug-in has an adjustable preview, as well as a filter search engine (by keywords).
We would be really interested to get your feedback about it.
So, Windows users, if you want to test it, you can get it from these two URLs:

There are probably some regressions compared to the current GTK-based implementation, so please be indulgent :slight_smile:

Any feedback, bug report and suggestions are welcome !

Note 1: The sources are not yet available for this plug-in, but they will someday :slight_smile:
Note 2: No Linux versions available due to probable library version mismatches.


(Artur Flinta) #2

Does it mean that GTK version will be abandoned in the future, or QT is just another option?


(David Tschumperlé) #3

Well, yes probably the GTK version will not be updated anymore in the future.


(Shreedhar Inamdar) #4

does this work on GIMP 2.8.18? Or do you need GIMP 2.9.5.


(David Tschumperlé) #5

I’ve tested it with GIMP 2.8 only. Should be working with 2.9 also I guess.


(Silvio) #6

Hello David,

Just downloaded the .exe installer to test it both on Windows 7 and Windows 8.1 (64 bit).
I have installed this new version with Gimp 2.8.20

Both on Windows 7 - 8.1 (Gimp 2.8.20) it fails to work :frowning:
The new QT version is available as option in the Gimp > Filter Menu but it does not work when you hit the button to launch it.

Here is the window message with the error:


(David Tschumperlé) #7

Thanks, apparently there are some DLLs missing.
I’ll try to fix that today.


(David Tschumperlé) #8

I’ve posted new pre-release packages at the same address. Should be working now !


(David Tschumperlé) #9

It doesn’t work apparently.
I’ll just let it down for the moment. I’ll try again maybe in the future. :frowning:


#10

Qt interface? For Linux? Yes!!! (I know…)
Qt interface? For Gimp (not this monowindow interface I hate, of course)? For Linux? Yes!!! (I know…)


(samj) #11

You can test a new archive from :
http://samjcreations.blogspot.ca/2017/02/test-gmic-gimp-qt-64-bit-version.html


#12

Same error with samj’s qt version as Silvio has above. gimp 2.8.18, windows 10. Thank you for your time and work.


(samj) #13

I made a third version of this plug-in accessible from the same link http://samjcreations.blogspot.ca/2017/02/test-gmic-gimp-qt-64-bit-version.html
Thank you for the relevant information received :o)


#14

@samj,

Now it works. :slight_smile: :+1:

It will take some time to test all filters.

edit: Every filter seems to work for me. But I’m an amatateur. So the professionals can investigate further :smile:


(Silvio) #15

THANKS so much for this latest version ! :slight_smile:

Now it works fine (Samj’s third version)

I have tested several filters and they all behave correctly : Windows 7 - 64 bit (Gimp 2.8.20).
In short, no crash so far :slight_smile:


(Shreedhar Inamdar) #16

The third version works over all on Win 10.

But the User Defined option of Film Emulation tab does not seem to work. More reports after some sleep!


(Lyle Kroll) #17

Get the following error, samj. :slight_smile:

https://s17.postimg.org/91amtmqkv/qt_gmic_error.png


(Silvio) #18

Filter > colorize interactive does not work as expected (Gimp 2.8.20 - Windows 7 64 bit):
*** Error in ./ *** Command ‘-fx_colorize_interactive’: Undefined argument ‘$4’, in expression ‘$4’ (for 10 arguments specified).

On the contrary, same jpeg image works fine with Gmic 1.7.9 (Colorize interactive)
This same filter has been often reported as broken on Krita (Windows versions) in the past as well.

BTW, this new QT version is already extremely responsive and stable on Windows ! :slight_smile:
Tested for more than 2 hours now…


(Lyle Kroll) #19

OK; after the error (about 30 seconds) the QT app does launch but continues to ask to import favorties but the import continues to fail. Regardless, it does work (and quick). Not sure what causes the error though and I’ll remove the plugin for now, but at least it appears, for the most part, to work. :slight_smile:


(samj) #20

I will try again when the source files become public.
Thank you