Testing : Qt-based version of the G'MIC plug-in for GIMP


#21

Wow, this is fantastic! Very responsive and generally just “feels” better than the old plugin. Great work :smiley:

A feature request (obviously low priority): some kind of theme selection, even just being able to change the overall interface colour would be great :wink:


(David Tschumperlé) #22

Based on the compiling environment and archive from @samj, I’ve tried building working pre-release packages and installers by myself : http://gmic.eu/files/prerelease/
I’ve recompiled the plug-in today, with (hopefully) some bugs fixed.
If someone wants to test and tell me if that is working as expected, that would be great.

I’ll try to automate the package builds for the Qt version, so I could propose pre-release binaries more often (each time bugs are fixed basically :slight_smile: ).

Thanks a lot for all your tests !


(Lyle Kroll) #23

What I posted at GIMPChat:

Still get the no disk in drive K error with this one, David. Also, the favs never do import (and it keeps asking for this). Regardless, once the plugin finally does launch (about 20 seconds; possibly due to the missing K drive error), it runs very fast (even faster than your 2.0.0 build; perceivable twice as fast if not 3 times faster). Hopfully the missing K drive error gets fixed (and the import issue too). Now, going back to the GTK 2.0.0 build for now. :slight_smile:


(Silvio) #24

Hello David,

Just tested your new installer (Windows 7 - 64 bit with Gimp 2.8.20)
The .exe does not work (it is not even available in the Filter menu).

Here is the message (translated from Italian into English) which pops up when I fire up Gimp:
Error

gmic_gimp_qt.exe - impossible to look for it

impossible to look for (not found) pthread_setname_np as regards the procedure for the dynamic link libwinpthread-1.dll.

OK

On the contary your Zip works fine (as usual, I set myself its path with Gimp 2.8.20 later on).

EDIT:
As proposed by Garagecoder it would be extremely useful to have an option to set your theme (e.g. with Gray as Background).
At present, on Windows 7 the new icons (e.g. to zoom in - out in the preview window) are hardly visible.
I have recorded a video to show this problem:
https://dl.dropboxusercontent.com/u/3095134/BUGS_REPORT/GMIC_ICONS.avi


(Lyle Kroll) #25

Funny; the installer worked fine and the filter would eventually run (after the k-drive error runs its course). Only issue I see is the favs never transfer (zip or installer). Weird how everyone’s experiencing different issues. Crazy stuff. :slight_smile:


(Ingo Weyrich) #26

Funny that G’MIC Qt on Windows has a similar issue as RT gtk3 had on Windows (the famous missing drive bug) :slight_smile:


(Lyle Kroll) #27

What ended up being the solution or work-a-round, then, heckflosse? :slight_smile:


(Ingo Weyrich) #28

For gtk3 it was this:

#ifdef WIN32

// suppression of annoying error boxes
    SetErrorMode(SEM_FAILCRITICALERRORS | SEM_NOGPFAULTERRORBOX | SEM_NOOPENFILEERRORBOX);
#endif

Could also work for Qt

Edit: for reference

Edit: Kudos to @gaaned92 for his finding :slight_smile:


(David Tschumperlé) #29

Ah thanks @heckflosse, I’ll try that !
The reference is quite funny actually, as it clearly states that the default behavior for this function is not what a Windows application should want to do. I wonder why they chose it as default then :slight_smile:

  • 0 : Use the system default, which is to display all error dialog boxes.
    SEM_FAILCRITICALERRORS
  • 0x0001: The system does not display the critical-error-handler message box. Instead, the system sends the error to the calling process.
    Best practice is that all applications call the process-wide SetErrorMode function with a parameter of SEM_FAILCRITICALERRORS at startup. This is to prevent error mode dialogs from hanging the application.

(David Tschumperlé) #30

Also thanks for all your replies, We’ll try to fix all the bugs step by step.
New pre-release binaries of the Qt plug-in will be posted today, hopefully !


#31

@David_Tschumperle,

The latest zipped version gmic_gimp_qt (03-03 15:45) has an empty gmic_gimp_ qt.exe file. Is that correct?

You latest executable installation file (03-03 15:46 )also has an empty exe.file and also doesn’t work.

Your files from yesterday do work.


(David Tschumperlé) #32

I’ve just posted new pre-release binaries for 2.0.0_pre version, both for Linux (.deb packages) and Windows.
Now, the Qt-plug-in has a dark theme included :

Please let me know if it’s better (or worse) than before :slight_smile:


#33

Thank you. I like the dark theme very much. It seems to work nice.

The color picker has changed. Is a color wheel (or something else with opposing colors) also possible?

I asked earlier:

Separate slider reset in G'MIC-GIMP possible?

Is it possible now, to make this?


(Lyle Kroll) #34

What I just posted at GIMPChat. Pretty good stuff, David. :slight_smile:

Both GTK and QT work great, David. Even the error messages in the QT version are now gone and it launches like you would expect (and it’s fast). The only problem I have now with the QT version is it keeps asking me to import favs and there are no favs afterwards. Regardless, the QT version runs the plugins at warp speed; impressive. :slight_smile:


(Lyle Kroll) #35

I like the new dark theme too, iarga. :slight_smile:


(Sebastien Guyader) #36

Hi David,

Will it be possible to try compiling the plugin on Linux? I run an Arch-based distro (Manjaro) and I would really like to test this new plugin.

Sébastien


(David Tschumperlé) #37

I’ve compiled the plug-in for Ubuntu-based distributions.
I can try on Manjaro too. We didn’t already release the source code for the plug-in, so I have to compile it by myself :frowning:


#38

Just for info, the gmic_gimp_qt plugin works in PClinuxOS Gimp 2.8.20 which bodes well for other distros.


(David Tschumperlé) #39

I’ve just compiled it on Manjaro:

Can be downloaded from here : http://gmic.eu/files/prerelease/gmic_gimp_qt_manjaro.zip

(Interestingly, it seems this binary also works on my Ubuntu distro, so it may also work for other distros as well).


(Sebastien Guyader) #40

Great, thanks David!

It works here, though I encountered a problem with a dialog box popping up saying it failed to update the filters (it seems to try updating automatically by itself?) and a crash after finishing applying a filter (Illustration look).
I also got a message the first time I loaded the Qt plugin, asking if I wanted to import faves. I answered “yes”, but it imported only 4 faves (in duplicate in fact) out of 10+ I had set up from the Gtk plugin. The good news is that it asked me to import the faves only the first time.

So far it works as fast as the Gtk version on my system (not faster, not slower… though the Gtk version was self compiled using -march=native).