Testing : Qt-based version of the G'MIC plug-in for GIMP

(David Tschumperlé) #81

@Silvio_Grosso, Sébastien has made some progress on improving the dark theme, as you can see below:

The state of the check-buttons and radio-buttons will be probably more clear like this.
We have posted new binaries on http://gmic.eu/files/prerelease, yesterday, if you wanna test it :slight_smile:

(Sebastien Guyader) #82

@David_Tschumperle still no updated Manjaro binary?

(David Tschumperlé) #83

Here it is, dated from today : http://gmic.eu/files/prerelease/gmic_gimp_qt_manjaro.zip

(Sebastien Guyader) #84

Thanks David!

(Sebastien Guyader) #85

@David_Tschumperle I think I found a bug in the Qt GUI. For any filter, if I click on the groove of any slider (right or left of the handle), the slider moves correctly by increments, but the value of the parameter isn’t updated, neither is the preview image.

(David Tschumperlé) #86

Indeed ! I’ve done a bug report for Seb Fourey, the developer of the plugin :slight_smile: Thanks !

(Silvio) #87

Hello everyone,

Just tested this new version on Windows 7 - 64 bit (Gimp 2.8.20).
I confirm Sebastian Guyader’s report about the bug in the QT GUI.
In all truth I didn’t even know that you could click on teh groove of the slider, right-left, to increase - decrease the value :slight_smile:

Just 2 very minor issues noted:
Some Italian strings are not translated (fichier de log: should be “file di log”)

On the same screenshot there is a little encoding problem in the names of the G’mic developers (which are not showed correctly).

Just out of curiosity, what does it mean the X and the S: new(x)layer(s) in the current translation ?

BTW, in the current QT plugin there is still the old search filters option (in the About Section) by Garagecoder. I am wondering why you don’t remove it since the new atop current search filter is much more intuitive (maybe it has some more features I am missing…) ?
Yes, there is no hurry to remove it but it looks redundant now :slight_smile:

(Lyle Kroll) #88

Brian (at GIMPChat) just gave me a head’s up that another update was released today. Just did a few tests and so far great (and fast). Just a question. When will the qt version be official and also, is anyone working on an 8bf (Photoshop) launcher for the stand-alone qt version so that PS can pipe layer(s) to the new G’MIC preset and get results? Just curious. :slight_smile:

(David Tschumperlé) #89

When it’s done ? :smiley:

No, and that’s not a priority for now. To be honest, our next big hope is to see the plug-in running in Krita. Boud, the manager of the Krita project, has fortunately started to hack something, so we are confident!

(Lyle Kroll) #90

Thanks for the update, David. I did post a sample image with alpha that can be used to test the preview engine (details of the issue at link). Not able to duplicate the color inversion issue with preset with felt pen after I restarted GIMP, but again not too worried about that. :slight_smile:


(Lyle Kroll) #91

OK; here’s an image that shows the color inversion issue. Nothing really special about this capture that I took a few years ago, but if you feed it into felt pen, it shows inversion. Strangely, though no alpha channel (which means nothing happens to solidify), when you see the preview in solidy the colors are also inverted (at least for me). :slight_smile:

(David Tschumperlé) #92

Lyle, that’s right I’ve got the same problem. Not sure why it happens.
What I did is trying selecting the ‘normal’ theme (in Settings), then the preview worked again !
Selected the dark theme again, then, and the preview was OK.

Certainly a bug somewhere, I’ll see if I can reproduce it.

(David Tschumperlé) #93

Sébastien has told me these bugs should be fixed now. I’ll try to post new binaries of the pre-version today !

(David Tschumperlé) #94

New files available here : http://gmic.eu/files/prerelease

(Lyle Kroll) #95

Just installed both gtk and qt versions David. Don’t see the inversion artifact in the qt version now. Thankyou and your team for the update. The qt version’s getting better and better by the way (also launches faster but still just noticeably slower than gtk version at first launch. If you launch it again within the same GIMP session, it’s near instantaneous). :slight_smile:

(Silvio) #96

Hello David,

Today’s build breaks the option to apply G’MIC filters inside the selections previously made with Gimp.
This does look like a regression : A previous version works fine on a different computer (Windows 8.1).
Tested today’s regression on : Windows 7 - 64 bit (Gimp 2.8.20).

I have recorded a video to show my steps to always reproduce it [1].
In essence:

  • open no matter what image ;
  • create a selection with Gimp 2.8.20 (rectangular, circular, etc) ;
  • Select no matter what G’MIC filter and modify it ;
  • Click on Ok to apply your filter inside the selection: it never works !

At present, this QT version looks indeed VERY powerful. Well done indeed ! :slight_smile:

Compared to the very old version available now with Krita 3.1.2 there is only a feature which is not available yet.
In short, with Krita 3.1.12 (G’MIC you can apply your change directly on the image available in the Krita canvas while you move the G’MIC sliders pertaining to the current filter you are working with. By doing so the G’MIC preview in the window is not necessary since you see your change directly on the image.
On the contrary, with Gimp you need to click on apply (or Ok) to modify your image. Of course you can simulate your change thanks to the preview window as well :slight_smile:
This being said, the G’MIC version on Krita has always been buggy and with many features never implemented. For instance, custom code “filters” (Various section > global - local) are not implemented on Krita now, thus you can not type any code.

[1] https://www.dropbox.com/s/728m8z2cc4lucnx/GMIC_SELECTIONS_BUG.mp4?dl=0

(Lyle Kroll) #97

Just verified that error, Silvio. Using the update dated 4/3/2017 so should be the latest. Hopefully David’s team will address this issue with the qt version. The latest gtk version works fine. :slight_smile:


Some glitches I’ve come across with win64 gimp QT from April 3rd:

Any filter which changes aspect, followed by another that uses full image preview. Example: reflection followed by perspective. The aspect remains, right clicking on the preview fixes it.

Pressing reset for any filter in favourites (seemingly only in favourites) causes sliders to stop working. Selecting a drop down or another filter then back fixes it.

My update file didn’t want to update even though there were changes, it would only update after I manually deleted. I don’t know if that only affects me!

Edit: I would test manjaro version if it’s updated :wink:

(David Tschumperlé) #99

Hello there,

I’ve posted new pre-release binaries today (dated 2017/04/10), including binaries for Windows / Ubuntu / Debian / Manjaro. It should fix most of the bugs you have been running into with the previous versions. As usual, your feedback is very welcome ! Download link: http://gmic.eu/files/prerelease/

(Lyle Kroll) #100

Just installed both gtk and qt, David. It appears Silvio’s selection bug issue has been fixed too. :slight_smile: