Testing : Qt-based version of the G'MIC plug-in for GIMP


(David Tschumperlé) #141

Thanks @MrQ, I’ve fixed the Sample image filter. Should be OK after you update your filters.

Yes, .ts files are being updated and should be available shortly on github. Any help for translating the two or three strings remaining will be appreciated :slight_smile:


(David Tschumperlé) #142

Translation updates requested !
We have added a few new strings to translate in the G’MIC-Qt plug-in, you find the .ts files to update here :

Any help appreciated !!


(Lyle Kroll) #143

Thanks for the update again, David. Left you a reply at your GIMPChat thread. :slight_smile:


(Edgardo Hoszowski) #144

Is it possible that the plugin version for linux has only the readme file?


(David Tschumperlé) #145

Hum, no I don’t see that, with file http://gmic.eu/files/linux/gmic_gimp_linux64.zip (nor with the 32bits version).
About what file are you talking about ?


(Edgardo Hoszowski) #146

I was following the previous link: http://gmic.eu/files/prerelease/gmic_gimp_qt_linux64.zip, this one does not seems to be the qt version


(David Tschumperlé) #147

Ha yes, actually you are right, the link displayed on the download page is broken :frowning:
Cannot fix this right now, as I’m having a long quiet week end, but I’ll be back and fix this on Monday !
Thanks for your report !


#148

Where is the reset-button? Ah, I see, it moved to the corner.


#149

When I set preview off and then on, it doesn’t show the preview anymore, but the original. If I then change the zoom-factor, it shows the preview again. (edit: only in QT)

Can this please be corrected, so I can use preview off,on,off,on,off, on…, so I can compare? (this is solved with final release , thank you.)

I like that the zoom-factor is showed now. Is it possible that you can manual enter the zoom-factor in future releases? So I can, for example, enter 100% as zoom-factor?


(David Tschumperlé) #150

Note that you can also press the right mouse button over the preview to quickly switch preview on/off. This is more convenient than using the checkbox for that particular task.

Yes, that should be possible in the next release, thanks for your suggestion :slight_smile:


(Oleg Kozheltsev) #151

Hi David,

Could you please share this version of gmic-qt for GIMP 2.9 once again? I’ve tried to compile gmic 2.0.2 with latest gmic-qt for GIMP 2.9.2 and 2.9.4 and got the same errors as @sguyader before. Also, I found some patch for gmic_gimp_gtk.cpp, it allows to compile it, but plugin doesn’t work with protocol not supported message from the GIMP (both versions).

Thank you.


(David Tschumperlé) #152

I really doubt the plug-in binary will work if it has been compiled with a version of the GIMP API which is not the same as the one you are using! I can compile the plug-in for 2.9 only on Linux, Ubuntu 16.04.
For other systems, I can’t do anything right now.


(Oleg Kozheltsev) #153

Thank you for the reply, David.

Of course I’m using GIMP 2.9 and trying to compile it for GIMP 2.9 with no luck (tried for versions 2.9.2 and 2.9.4). I’m getting these error messages:

src/host_gimp.cpp:63:9: error: ‘GimpLayerMode’ does not name a type; did you mean ‘GimpTransferMode’?
 typedef GimpLayerMode GimpLayerModeEffects;
         ^~~~~~~~~~~~~
         GimpTransferMode
src/host_gimp.cpp:66:23: error: ‘GIMP_LAYER_MODE_NORMAL’ was not declared in this scope
   { QString("alpha"), GIMP_LAYER_MODE_NORMAL },
                       ^~~~~~~~~~~~~~~~~~~~~~
src/host_gimp.cpp:66:23: note: suggested alternative: ‘GIMP_RGB_COMPOSITE_NORMAL’
   { QString("alpha"), GIMP_LAYER_MODE_NORMAL },
                       ^~~~~~~~~~~~~~~~~~~~~~
                       GIMP_RGB_COMPOSITE_NORMAL
src/host_gimp.cpp:67:24: error: ‘GIMP_LAYER_MODE_NORMAL’ was not declared in this scope
   { QString("normal"), GIMP_LAYER_MODE_NORMAL },
                        ^~~~~~~~~~~~~~~~~~~~~~
src/host_gimp.cpp:67:24: note: suggested alternative: ‘GIMP_RGB_COMPOSITE_NORMAL’
   { QString("normal"), GIMP_LAYER_MODE_NORMAL },
                        ^~~~~~~~~~~~~~~~~~~~~~
                        GIMP_RGB_COMPOSITE_NORMAL
src/host_gimp.cpp:68:26: error: ‘GIMP_LAYER_MODE_DISSOLVE’ was not declared in this scope
   { QString("dissolve"), GIMP_LAYER_MODE_DISSOLVE },
                          ^~~~~~~~~~~~~~~~~~~~~~~~
src/host_gimp.cpp:68:26: note: suggested alternative: ‘GIMP_ERROR_CONSOLE’
   { QString("dissolve"), GIMP_LAYER_MODE_DISSOLVE },
                          ^~~~~~~~~~~~~~~~~~~~~~~~
                          GIMP_ERROR_CONSOLE
src/host_gimp.cpp:69:24: error: ‘GIMP_LAYER_MODE_BEHIND’ was not declared in this scope
   { QString("behind"), GIMP_LAYER_MODE_BEHIND },
                        ^~~~~~~~~~~~~~~~~~~~~~
src/host_gimp.cpp:69:24: note: suggested alternative: ‘GIMP_RGB_COMPOSITE_BEHIND’
   { QString("behind"), GIMP_LAYER_MODE_BEHIND },
                        ^~~~~~~~~~~~~~~~~~~~~~
                        GIMP_RGB_COMPOSITE_BEHIND

… and so on. You wrote previously about special fork of gimp-qt that is different from c-koi/gmic-qt (dtschump/gmic-qt). But I can’t get access to it right now :frowning: This is on Linux too (Fedora).


(David Tschumperlé) #154

Hello @axel,
what I meant is you probably need to recompile GIMP from git master, in order to get the G’MIC plug-in compiling and working as expected. The GIMP team has made recent changes concerning the variable names used to describe the different blending modes in the sources of GIMP 2.9. The G’MIC plug-in source code takes these recent changes into account, so you really the latest GIMP API to make the plug-in compile. To get it, there is no other solution than re-compiling an up-to-date version of GIMP 2.9, from the latest git repository (or maybe ask the maintainer of the GIMP 2.9 package to do that for you!).
I had forked the G’MIC-Qt source code once, but as my pull request has been merged in the main project, I’ve just deleted my fork, as it has become useless.


(Oleg Kozheltsev) #155

I see. I will clone and compile the latest GIMP (no problem, 2.9.2 and 2.9.4 I compiled myself) and will try to re-compile gmic-qt with it.

Thank you very much, David! Especially for your GREYCstoration tool. I use it for years in my work.
http://axel.dp.ua/