Using the Windows installer for version 2.0.3+ of G'MIC


(G'MIC staff) #1

Dear friends,

There will be a slight change in the future versions of the GIMP plug-in installers for Windows users, and I think I must tell a bit about it.

Basically, the default installation folder changes: instead of installing the plug-in binary and all the required DLLs in the default GIMP plug-in directory (something like C:\Users\my_name\.gimp-2.8\plug-ins), it installs it in a sub-folder gmic_gimp_qt/ instead (so : C:\Users\my_name\.gimp-2.8\plug-ins\gmic_gimp_qt). It does this because we’ve got a lot of user complaints about G’MIC providing DLLs that are incompatible with other GIMP plug-ins (or worse, incompatible with GIMP itself !) and this makes those other plug-ins (or GIMP!) stop running as they should. And if we try to stop providing those ‘incompatible’ DLLs, then it appears some people cannot run the G’MIC plug-in at all (missing DLLs error). There is only a single way to stop that mess :slight_smile:
Now, the G’MIC plug-in and all its DLLs are installed in a separate folder so that it doesn’t break anything with other plug-ins, and we can more easily ensure all DLLs are bundled in the installer.

A direct consequence of all that: If you install the G’MIC plug-in with the new installer (and default parameters), GIMP won’t be able to locate the G’MIC plug-in, as it is not located in a known plug-in path for GIMP. But this is is really easy to fix, by following these simple steps:

  1. Run GIMP, go to Edit / Preferences / Folders / Plug-Ins, then add a new entry in the Folder list, by adding the path to your newly installed gmic_gimp_qt/ folder.

  2. Exit GIMP, then launch it again.

  3. Done! The G’MIC plug-in should appear in the Filters/ menu

Note that the GIMP team is aware of that kind of issues and has recently added some code to GIMP to allow sub-folders being defined in the default GIMP plug-in directory. I’m not sure this is already available, but this will for sure appear for next major version GIMP 2.10 (in which case, the steps described above will be useless).

Note also that the very first time you launch the plug-in, it can take a few seconds to appear.

I’ve recorded a quick video to show how this work with GIMP 2.8 on Windows. I hope this will be useful.


Hue Overlay Masks - my first filter
(G'MIC staff) #2

(Patrick A McKinley) #3

Hi David,
Thank you for the tip here, but perhaps it does not apply to me since I am trying to install G’MIC plug-in for GIMP (2.8+ Windows installer file) after installing GIMP 2.9.8.

I did follow your advice but still cannot get GMIC to install and run. I have GIMP 2.9.8 installed, and the GMIC installation seemed to go normally. I modified the Preferences > Folders > Plugins to include the folder where I installed GMIC (v.2.1.9_pre) (C:\Users<username>\AppData\Roaming\gmic_for_gimp\plugins).

On restarting GIMP I get a window titled “gmic_gimp_qt.exe - Entry Point Not Found”, with description “The procedure entry point FT_Get_Var_Design_Coordinates could not be located in the dynamic link library C:\Program Files\GIMP 2.9\bin\libcairo-2.dll.” I do see this file, and it appears to me that string exists in it. FYI I’m running Windows 10 Enterprise 64-bit.

The GIMP Output window also has 22 errors: “GIMP-Error: Unable to run plug-in “xyz”, Failed to execute child process (Exec format error)”,
where the message repeats 22 times for related .dll file in the gmic plugins folder.

Is there any chance you have seen this and know what I might try differently?

BTW, I did not use the .gimp folder for plugins installation since I had read elsewhere that Windows 10 prevents executing files in the Users hidden folders. Locating them in the Appdata\Roaming was recommended.
Also FYI, my User has Admin permissions.

Thank You,
…Patrick


(G'MIC staff) #4

Hello Patrick,
The installer provided on the G’MIC website is known to be not working with current development version of GIMP 2.9.8+. It used to work before, but it’s not the case anymore. I suspect the GIMP team has made some changes in the plug-in API or whatever that breaks the compatibility of the plug-ins between GIMP versions 2.8.x and 2.9.x.

On the G’MIC website, we currently only provide plug-in built for the stable version of GIMP (so 2.8.x).
I know some good folks are providing binaries of the G’MIC plug-in that is working with GIMP 2.9.8, so you should check what they propose on their website.
I’m aware of two sources to get a working G’MIC plug-in for GIMP 2.9 :

I cannot ensure it will work as expected, I don’t have GIMP 2.9.8 installed on a Windows machine, I’m sorry about that. But for sure, they probably will be glad to help if you get troubles with what they propose.


(Patrick A McKinley) #5

David, Thanks for the quick response and info. I realize I’m on the
cutting edge of developers work here so really appreciate your help and
pointers. It looks like from Partha’s site both GIMP and GMIC were updated
again today, so I’ll try to reinstall both tonight.

Awesome!
…Patrick


(Picman) #6

Hi David!
I’m a G’MIC-User since many years, and I really love it. And I use to connect the G’MIC-Plugin to GIMP in the way you discribed above: I create a seperate folder, unpack or install G’MIC into it and connect it in GIMPs Preferences. But now I have a problem with G’MIC 2.0.3 under GIMP 2.10.2. Most of the Functions of G’MIC seem to work fine, but anyway the Film emulation doesn’t. It always ends up with the following message:
“***Error in ./fx_emulate_film_bw_preview/gui_split_preview/*repeat/(…)/*if/*repeat/*if/local/***gmic::fopen():Failed to open file 'C:\Users\my name\AppData\Roaming\gmic\gmic_film_cluts.gmz’with mode ‘wb’.”
Possibly it’s because there is an umlaut (ä) in my Username (that I replaced in this post), Could that be the problem? But how can I solve that problem without reinstalling Windows? I’m already desperate about Windows 10. Really don’t like it.

Any idea? Would be verry grateful.

Thanx and best Greatings

Michael


(G'MIC staff) #7

That’s probably the reason yes, G’MIC does not support UTF-8 or extended coding in strings and filename.
This is annoying indeed…
I would suggest defining a variable environment %GMIC_PATH to a path with only “standard” characters in it. It will be used by G’MIC as a new path to store all G’MIC-related files.


(Picman) #8

Ah OK, thanx for your quick reply, David! That sounds good, but I don’t know how to do that.