Weekly GIMP 2.9.x AppImage builds

appimage

(Carmelo Dr Raw) #1

After having spent quite some time in setting up a Travis CI environment for the GIMP AppImage creation, I have finally reached a stage where things seem to run quite smoothly.

The AppImage build environment is mainly composed of two pieces:

  • a Docker container which provides the necessary updated dependencies installed on top of an Ubuntu 14.04 system (Dockerfile here)
  • a Travis CI configuration that builds the git HEAD versions of BABL/GEGL/GIMP plus few additional plugins (PhotoFlow, NUFraw, resynthesizer and liquid rescale) and bundles the whole thing into an AppImage package

The package is then uploaded to a dedicated GitHub release page.

At this point, the last step has been to set-up a recurrent Travis cron job to update the AppImage weekly… from now on, there will be a new package built and uploaded every Thursday evening, in time for letting you start the week-end with a freshly updated GIMP version!

If any of the GIMP developers out here is interested, we can discuss wether to make those packages officially visible from the GIMP web site…

Happy editing!!!


GIMP-CCE won't be updated past the release of default GIMP 2.10
GMIC QT doesn't do negative parameters in Gimp-devel
(Carmelo Dr Raw) #2

A new weekly GIMP AppImage build is available for download: https://github.com/aferrero2707/gimp-appimage/releases/download/continuous/gimp-2.9.9-20180118_2116.glibc2.14-x86_64.AppImage


(Tobias) #3

It would be nice, if you could G’MIC to the AppImage.


(Carmelo Dr Raw) #4

I know… it’s a mere question of lack of time for integrating and testing a QT-based code into the appimage. The old gtk code was routinely included…


#5

Thanks so muc for this! I tried the older 2.95 app iimages but they did not work, would not startup on my system but this version works fine.


(Carmelo Dr Raw) #6

I have just prepared a new AppImage package that includes the git head version of the G’MIC-Qt plug-in.

The new package can be downloaded from here.

I’d really like to have feedback on this, as this is the first time that I bundle some Qt-based tool.
Pinging @paperdigits and @David_Tschumperle as they likely want to jump on it…


(Morgan Hardwood) #7

@Carmelo_DrRaw GIMP+G’MIC from your AppImage work fine here in Sabayon

Console log:
https://filebin.net/koee2uaxg07m5w5c/gimp-2.9.9-20180309_1153.glibc2.14-x86_64.AppImage.log


(Carmelo Dr Raw) #8

Nice!!! Thanks for the feedback.


#9

I tried this on a Debain system and it will not run. Here is the beginning of the out-put from the CMD line

./gimp-2.9.9-20180309_1153.glibc2.14-x86_64.AppImage
DIR: /tmp/.mount_R1k6p4
GTK_PATH=/tmp/.mount_R1k6p4/usr/lib/gtk-2.0
GTK_IM_MODULE_FILE=/tmp/.mount_R1k6p4/usr/lib/gtk-2.0:/tmp/.mount_R1k6p4/usr/lib/gtk-2.0
PANGO_LIBDIR=/tmp/.mount_R1k6p4/usr/lib
/tmp/.mount_R1k6p4/AppRun: line 49: ldconfig: command not found
System stdc++ library: ""
strings: ‘’: No such file
System stdc++ library version: ""
Bundled stdc++ library version: "3.4.22"
Newest stdc++ library version: "3.4.22"
Using bundled stdc++ library
GDK_PIXBUF_MODULEDIR: /tmp/.mount_R1k6p4/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders
GDK_PIXBUF_MODULE_FILE: /tmp/.mount_R1k6p4/usr/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache

There’s more, Hope this helps


(Gys Van Zyl) #10

Great news, I’ve been hoping for G’MIC to be included in AppImage!

Works fine in ubuntu 17.10:


(Carmelo Dr Raw) #11

Could you provide me the full terminal output(you can send me a pm if you prefer)?

I need to see if the cause are the missing ldconfig and strings commands in your system.

Thanks!


(Christian Kanzian) #12

@Carmelo_DrRaw
Works fine for me on Debian 9 aka Stretch, which is the current stable release. I tried a G’MIC film simulation.

Only the filter update failed with following message (tranlated from German): time out for download of http://gmic.eu/update221.gmic. Pressing the update button in the middle beside the Internet check box worked.
Looks good to me.


(Andrew) #13

hi @Carmelo_DrRaw, when I tried the appimage from a few days ago, it failed, so I got the new one above ( gimp-2.9.9-20180309_1153.glibc2.14-x86_64.AppImage) but it also fails the same way. I get -

libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007fd43aad5000)
libexiv2.so.26 => ././/lib/libexiv2.so.26 (0x00007fd43a4e5000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fd43a163000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fd439f4d000)
libffi.so.6 => ././/lib/libffi.so.6 (0x00007fd439d45000)
libpcre.so.3 => ././/lib/libpcre.so.3 (0x00007fd439b07000)
libXau.so.6 => ././/lib/libXau.so.6 (0x00007fd439903000)
libXdmcp.so.6 => ././/lib/libXdmcp.so.6 (0x00007fd4396fd000)

/gimp.bin --pdb-compat-mode=on “”
/tmp/.mount_KuhZ7l/usr/bin/python
GLib-GIO-Message: Using the ‘memory’ GSettings backend. Your settings will not be saved or shared with other applications.
This is a development version of GIMP. Debug messages may appear here.

(process:3056): GLib-GObject-CRITICAL (recursed) **: g_object_get: assertion ‘G_IS_OBJECT (object)’ failed
(process:3056): GLib-GObject-CRITICAL (recursed) **: g_object_get: assertion ‘G_IS_OBJECT (object)’ failed
(process:3056): GLib-GObject-CRITICAL (recursed) **: g_object_get: assertion ‘G_IS_OBJECT (object)’ failed

and lots of this same msg until finally a segmentation error occurs.


(David Tschumperlé) #14

I’m just back from vacations. I’ll take a look ASAP, thanks @Carmelo_DrRaw !


(Carmelo Dr Raw) #15

Which Linux distro/version are you using?


(Andrew) #16

I s/have said, Ubuntu 16.04.3 LTS.


(Carmelo Dr Raw) #17

Could you provide me the full terminal output? Seems to be some incompatibility with the gobject library…

Have you also installed GIMP from some PPA?


(David Tschumperlé) #18

Tested the appimage today here, Ubuntu 17.10 artful 64bits, and it works flawlessly. Congrats!


(Andrew) #19

hi, yes I installed Gimp via ottokessel PPA. The whole sequence was -
. install ub16.04 about a week ago
. saw old Gimp included, so un-installed
. linked to PPA then saw it was only 2.8
. removed PPA
. ran appimage 7/3/2018 ok
BUT at some point - not sure whether before of after running your Gimp, sorry - I removed various libs left over from un-installing Gimp 2.8.

I’ve just run appimage 9/3/18 and it’s crashed as above. Here is the log - appimage-log.txt (293.4 KB)
I just did “sudo apt update” and it says all packages up to date, and mentions no items that can be removed.

Thanks.


(Andrew) #20

hi, do you think I should re-install Gimp via the 2.8 PPA in the hope this will then enable your appimage to run?