[Win64] RawTherapee 5.3 Release Candidate 1 for testing


(Sebastien Guyader) #1

Here’s a 64-bit Windows build of Rawtherapee 5.3 RC 1:

For testing: this build comes bundled with the lensfun database, so please test the lens correction (Tansform tab).

(Silvio) #2

Just testing this candidate release :slight_smile:

I have noticed how weird are the icons. E.g. on the top right corner: The ones to minimize, close RawTherapee.
They are hardly recognizable from each other. All of them look quite similar…

Here is my screenshot (Windows 7 - 64 bit):

(Karlheinz Lehmann) #3

Thanks for the build. However, in this version lensfun does not work for me, if the lens is not detected automatically.


It works if the lens and the camera are detected automatically.

I use dynamic profiles in the following sequence, as discussed with Alberto @agriggio :


LFCameraMake=Nikon Corporation
LFCameraModel=Nikon D7200

TAMRON 70-300 Di VC USD.pp3
LFLens=Tamron Tamron SP 70-300mm f/4-5.6 Di VC USD

However, the resulting profile looks like that (so it looks different to the screenshot)

LFCameraMake=Nikon Corporation
LFCameraModel=Nikon D7200
LFLens=Tamron Tamron SP 70-300mm f/4-5.6 Di VC USD

Do you need any more info?

(Karlheinz Lehmann) #4

This I can’t confirm on Win 10 64 bit



I also am experiencing missing icons in windows 10, clean machine.


The lensfun tool worked fine, auto detected my canon kit.

(Sebastien Guyader) #7

@ChasingShadows I’m not sure to understand what you need. Why do you need to set things manually; if it works in auto detection?

(Sebastien Guyader) #8

Well, I only have Windows 7, and it works on my machine.
Have you tried changing the RT theme? Did you tweak you Windows theme?


All RT themes are without interface buttons (file browser triangles, window close buttons). Nothing done to the default windows theme.


Tested on WIN10 lens corrections worked fine, set to automatic and manual.

(Ingo Weyrich) #11

iirc showing maker twice is fixed. Maybe you need to update your dynamic profiles

(Sebastien Guyader) #12

@HIRAM sorry I have no idea what’s going on.

(Ingo Weyrich) #13

maybe @TooWaBoo has an idea ?

(Sebastien Guyader) #14

@HIRAM can you try this build?
In fact I move my building environment to another machine, reinstalling the whole building environment so maybe I forgot to install something in this environment. This build was made in the older environment.

(Silvio) #15

Hello sguyader,

Thanks a lot for this second build.
I have installed it now on Windows 7 (64 bit), again, and all my icons are available again ! :slight_smile:

BTW, I have also tried the previous , first, build on Windows 10 (64 bit) and all icons were missing too…

(Sebastien Guyader) #16

Ok, I think I have to refresh the gtk icon cache in my new build environment. Sorry about that.


Same thing here, icons ok in this build.


You probably might want to delete the cache.


I’m observing the same behavior, with icon issues.

(Sebastien Guyader) #20

Ok, in fact simply forgot to add the icons folder in my new environment.
Here’s the last build, but with the icons included: https://filebin.net/66j7upcextrlmpo6

Let me know if it’s ok now.
Sorry again for the mistake.