Windows build of R&Darktable....

Thanks, what a shame. I didn’t see there was a readme file, sorry.

Nicolas

@nwinspeare I have been using a self-compiled version on my M1 macbook pro. It seems to work fine for me. I can post an unsupported build if you or others are interested. Again, this is the arm version not intel.

2 Likes

Welcome to the forum! @procopio @jg24

Sure, why not. Just put a disclaimer that it is the fork and the M1 build is unsupported.

1 Like

I did a build on Linux (ZorinOS-Ubuntu 20.04 base). Got something built that runs, but it’s not the R&d version! Think I may have gone wrong when choosing tags. I was following AP’s youtube video on optimization, but got a bit confused here. The version I ended up with says unknown version in the upper left corner, but seems to have the layout of a 3.x version. I think I chose 3.6.0 for the tags. I did get the dependencies worked out, so I’d like to try another go. Anyone have any advice for a buffoon level computer operator? Thanks

I just followed my usual method for Master as detailed here

except I did
git clone https://github.com/aurelienpierre/R-Darktable.git folder
instead of
git clone https://github.com/darktable-org/darktable.git folder

I built it ok on my mac yesterday – it is an intel mac, haven’t tried on an M1 mac.

Hi Matt is it too much to ask if you can share the build? I have a iMac intel and have been using current dt builds, and checking for bugs and performance, from MStraeten for a long time, and would be curious to compare both dt and R&Dt

I tried building an app bundle, but it doesn’t seem to package up properly. Normally I just run darktable directly out of the install directory, and don’t normally worry about app bundles. If I can sort out why it is not working, then I’ll post here, but I am not really an expert on Mac.

I understand!!! Thank you

Same here, I built the app from the instructions here : darktable/BUILD.txt at master · darktable-org/darktable · GitHub
but using the r&darktable git. Works like a charm.
I execute in the terminal with
GSETTINGS_SCHEMA_DIR=/opt/local/share/glib-2.0/schemas/ XDG_DATA_DIRS=/opt/local/share darktable --library /Users/nick/dtlibrary/dtlibrary
so that the library doesn’t conflict with the normal darktable library.

When I try to use the gtk-app-bundler as per instructions, I get the following error.

./make-app-bundle{}:8: Error: command `~/.local/bin/gtk-mac-bundler darktable.bundle` failed with exit code 127

If I work out the problem, I’ll share the file.

1 Like

I’m normally building and using Darktable direct from master , more as an editor then something to really store and catalog my photos in. So i don’t care if i loose edits or settings (i started over often enough without regrets so far ).

So I’ve been using this one , once I’ve read the rant / description of it :wink:. Seems like something I can understand , or get behind.

Since I don’t use the light table that much , i don’t notice so much difference, which is a good thing. I do like that deprecated modules are gone. “If it is there , you can use it” did actually go through my mind once :).

But, a weird question. It was described that the new filtering stuff has been ripped out . So, i was surprised to see in the collection ‘module’ still the possibility to add a query and add a refinement… If this is still here , then what IS the filtering stuff that is ripped out ?

Apparently it’s a new feature that i never noticed in DT3.9-master since I thought it was this ?

1 Like

Not sure what’s new but did a new build tonight for WIndows…

Looks like AP updated the tags…

He may have added this too… I have had no time to check… I think its a PR for DT as well…

2 Likes

I built R-Darktable for Intel Macs

It does not contain the new ColorEqualizer module, and also it contains my patch of the cairo library - such that it does not render to its default sRGB but to macOS’s monitor profile. This allows a wider gamut than sRGB and also speeds up some gui operations on my iMac. For correct color management, please also select that profile in R-darktable.

(Edit, nearly forgot) Please remember to backup your config directory, and consider the build unsupported :wink: It works well on my side, though.

2 Likes

Something is not working as expected with dropbox, I could neither download nor copy to my dropbox. What can I be doing wrong?

Retry (link to the folder containing the app, not to the app directly). Does it work now?

Thank you for the effort, when trying to download directly the error message is : The zip file is too large. I was able to copy to my dropbox space, but then when trying to download the error message is Zip download failed. I think is the lid file that is the heart of the problem. Will try to download individual files and see if I can get all the files and run the soft. Will keep you informed. And thank you again for sharing

Strange, as it’s not a zip file but a macOS app container.

Thanks a lot, I will try it.

No, it seems there is no color equalizer yet in that distribution, just the old color zones which is similar but seems that AP is replacing it with the new one.

Last time I looked it was in 2 branches of his new forked project and only a PR in the darktable one…haven’t checked today…I build a Win version with it just to test…works as you might expect with some small side effects at the moment…

I wonder if there’s someone feeling sane enough to help a completely noob building this.

Trigger warning: I’ve never done anything like this before.

I got this msys64 stuff and did all the preparation from here.

Building and running DT works fine. I then cleaned the msys64 folder from the DT stuff and tried R&DT.

What I did:

git clone https://github.com/aurelienpierre/R-Darktable.git
cd r-darktable
git checkout dev
git submodule init
git submodule update
./build.sh

What I got:

[ 65%] Linking C shared module libmap_settings.dll
[ 65%] Linking C shared module liblocation.dll
[ 65%] Linking C shared module libgamepad.dll
[ 65%] Building C object lib/darktable/plugins/CMakeFiles/highpass.dir/introspection_highpass.c.obj
[ 65%] Built target image_infos
Detaching debug infos for midi.
[ 65%] Generating introspection_lowpass.c
[ 65%] Built target global_toolbox
Detaching debug infos for map_settings.
Detaching debug infos for location.
C:/msys64/ucrt64/bin/../lib/gcc/x86_64-w64-mingw32/12.2.0/../../../../x86_64-w64-mingw32/bin/ld.exe: C:/msys64/ucrt64/lib/libSDL2main.a(SDL_windows_main.c.obj):(.text+0x152): undefined reference to `SDL_main'
collect2.exe: error: ld returned 1 exit status
make[2]: *** [lib/darktable/plugins/lighttable/CMakeFiles/gamepad.dir/build.make:223: lib/darktable/plugins/lighttable/libgamepad.dll] Error 1
make[1]: *** [CMakeFiles/Makefile2:3655: lib/darktable/plugins/lighttable/CMakeFiles/gamepad.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 65%] Linking C shared module libmap_locations.dll
[ 65%] Generating introspection_shadhi.c
[ 65%] Built target midi
[ 65%] Built target map_settings
[ 65%] Built target location
[ 65%] Building C object lib/darktable/plugins/CMakeFiles/lowpass.dir/introspection_lowpass.c.obj
Detaching debug infos for map_locations.
[ 65%] Linking C shared module libgeotagging.dll
[ 65%] Building C object lib/darktable/plugins/CMakeFiles/shadhi.dir/introspection_shadhi.c.obj
[ 65%] Built target map_locations
Detaching debug infos for geotagging.
[ 65%] Linking C shared module librawprepare.dll
[ 66%] Linking C shared module libsoften.dll
[ 66%] Built target geotagging
Detaching debug infos for rawprepare.
Detaching debug infos for soften.
[ 66%] Linking C shared module libbloom.dll
[ 66%] Built target rawprepare
[ 66%] Built target soften
[ 66%] Linking C shared module libhighpass.dll
Detaching debug infos for bloom.
Detaching debug infos for highpass.
[ 66%] Built target bloom
[ 66%] Built target highpass
[ 66%] Linking C shared module liblowpass.dll
Detaching debug infos for lowpass.
[ 66%] Linking C shared module libshadhi.dll
[ 66%] Built target lowpass
Detaching debug infos for shadhi.
[ 66%] Built target shadhi
make: *** [Makefile:156: all] Error 2

I just found out that others used to have this SDL_main error too with DT, but building continued nevertheless. Is there anything obvious I’m doing wrong? Trying with master (just leaving out git checkout dev, because already in master as far as I understand) leads to the same result.