current OSX Build

Just for info (I know it is not too much help) it is working here, as well as the previous build, on iMac with OS 11.5.1. Only issue was related to OpenCL which was not available in pref, but the problem was solved after deleting cache and running the script previously proposed to enable OpenCL

cannot reproduce. Maybe you can run dt via lldb debugger (maybe Xcode commandline tools needs to be installed first) to see what exactly fails.

Thanks, bit of a neophyte in coding here. I spent some time and found that .raf raw files import fine but it is the dng files that make dt crash. I get dng files from panos and HDR (assembled in capture 1).
Here is a dng file that crashed darktable (not a great photo, a pano of my living room I made to sell the house).

X-Pro3-2022-04-02-14h23min58s_Panorama.dng (82.8 MB)

It is likely that those products produce some sort of invalid dng file, which is often the case. If that is the case here, you should let the company know so they can bring that into compliance.

Since your DNG files are not raw, you’re probably just as well off with a 16 or 32 bit tiff.

Hi, I confirm the issue with DNG files. I have dt (last build) crashing when opening .dng files from dji. It was not a problem opening these files with previous builds.

This DNG opens just fine w/ the recent Windows build:

Please send any output concerning rawspeed complaints from the log.

Same: please send any output concerning rawspeed complaints from the log. (And also please upload samples to RPU if not there for your model.)

Any problems w/ DJI files should probably be reported to DJI, as it is not the first time they write corrupt/invalid DNGs.

I don t know if this may help, I went to the previous builds and the last one that can open the .dng files from DJI is build 3.9.0+1362.
With the following one (3.9.0+1453) I got the crash when trying to open with the following report (I don’t know where to look for the rasped complains, so any help there will be good):

Process: darktable [3767]
Path: /Applications/
Identifier: org.darktable
Version: 3.9.0 (
Code Type: X86-64 (Native)
Parent Process: bash [3733]
Responsible: Terminal [3731]
User ID: 501

Date/Time: 2022-05-18 11:52:31.591 +0200
OS Version: macOS 11.5.1 (20G80)
Report Version: 12
Bridge OS Version: 5.5 (18P4759a)
Anonymous UUID: 87497CFF-84A7-441C-8159-36B651EA99E8

Sleep/Wake UUID: F3083D88-CE54-45DF-8121-D8CFDE160899

Time Awake Since Boot: 170000 seconds
Time Since Wake: 170000 seconds

System Integrity Protection: enabled

Crashed Thread: 7 worker 3

Exception Codes: KERN_INVALID_ADDRESS at 0x0000020200000000

VM Regions Near 0x20200000000:
CoreAnimation 120211000-120965000 [ 7504K] rw-/rwx SM=PRV

STACK GUARD 70000517b000-70000517c000 [ 4K] —/rwx SM=NUL stack guard for thread 96

Application Specific Information:
abort() called

Thread 0:: Dispatch queue:
0 libsystem_kernel.dylib 0x00007fff204e2bb2 __semwait_signal + 10
1 libsystem_c.dylib 0x00007fff20462c1a nanosleep + 196
2 libglib-2.0.0.dylib 0x0000000104a16e46 g_usleep + 71
3 libdarktable.dylib 0x00000001043abf2a dt_control_import + 298 (control_jobs.c:2353)
4 0x000000011a513fd1 _import_from_dialog_run + 625 (import.c:1900)
5 0x000000011a51153d _lib_import_from_callback + 77 (import.c:1945)
6 libgobject-2.0.0.dylib 0x00000001058618de _g_closure_invoke_va + 205
7 libgobject-2.0.0.dylib 0x00000001058762b8 g_signal_emit_valist + 983
8 libgobject-2.0.0.dylib 0x0000000105876d28 g_signal_emit + 120
9 libgtk-3.0.dylib 0x0000000104b97f4a gtk_button_do_release + 57
10 libgtk-3.0.dylib 0x0000000104b97b38 gtk_real_button_released + 167
11 libgobject-2.0.0.dylib 0x00000001058618de _g_closure_invoke_va + 205
12 libgobject-2.0.0.dylib 0x00000001058762b8 g_signal_emit_valist + 983
13 libgobject-2.0.0.dylib 0x0000000105876d28 g_signal_emit + 120
14 libgtk-3.0.dylib 0x0000000104b97ff2 multipress_released_cb + 38
15 libgtk-3.0.dylib 0x0000000104de5301 _gtk_marshal_VOID__INT_DOUBLE_DOUBLEv + 192
16 libgobject-2.0.0.dylib 0x00000001058618de _g_closure_invoke_va + 205
17 libgobject-2.0.0.dylib 0x00000001058762b8 g_signal_emit_valist + 983
18 libgobject-2.0.0.dylib 0x0000000105876d28 g_signal_emit + 120
19 libgtk-3.0.dylib 0x0000000104c44e77 gtk_gesture_multi_press_end + 109
20 libgobject-2.0.0.dylib 0x000000010586481b g_cclosure_marshal_VOID__BOXEDv + 166
21 libgobject-2.0.0.dylib 0x00000001058618de _g_closure_invoke_va + 205
22 libgobject-2.0.0.dylib 0x00000001058762b8 g_signal_emit_valist + 983
23 libgobject-2.0.0.dylib 0x0000000105876d28 g_signal_emit + 120
24 libgtk-3.0.dylib 0x0000000104c41d3f _gtk_gesture_check_recognized + 55
25 libgtk-3.0.dylib 0x0000000104c4339b gtk_gesture_handle_event + 254
26 libgtk-3.0.dylib 0x0000000104c464a4 gtk_gesture_single_handle_event + 463
27 libgtk-3.0.dylib 0x0000000104c13961 gtk_event_controller_handle_event + 107
28 libgtk-3.0.dylib 0x0000000104da3ff0 _gtk_widget_run_controllers + 111
29 libgtk-3.0.dylib 0x0000000104ddfec9 _gtk_marshal_BOOLEAN__BOXEDv + 171
30 libgobject-2.0.0.dylib 0x00000001058618de _g_closure_invoke_va + 205
31 libgobject-2.0.0.dylib 0x00000001058762b8 g_signal_emit_valist + 983
32 libgobject-2.0.0.dylib 0x0000000105876d28 g_signal_emit + 120
33 libgtk-3.0.dylib 0x0000000104da3b69 gtk_widget_event_internal + 253
34 libgtk-3.0.dylib 0x0000000104c84f9e propagate_event + 369
35 libgtk-3.0.dylib 0x0000000104c8442b gtk_main_do_event + 1077
36 libgdk-3.0.dylib 0x0000000105265955 _gdk_event_emit + 49
37 libgdk-3.0.dylib 0x0000000105289783 gdk_event_dispatch + 50
38 libglib-2.0.0.dylib 0x00000001049f35e4 g_main_context_dispatch + 257
39 libglib-2.0.0.dylib 0x00000001049f38ca g_main_context_iterate + 431
40 libglib-2.0.0.dylib 0x00000001049f3b32 g_main_loop_run + 250
41 libgtk-3.0.dylib 0x0000000104c83ec2 gtk_main + 74
42 libdarktable.dylib 0x000000010447dcba dt_gui_gtk_run + 202 (gtk.c:1275)
43 org.darktable 0x00000001042a1f4e main + 62 (main.c:94)
44 libdyld.dylib 0x00007fff20530f3d start + 1

Thread 1:
0 libsystem_pthread.dylib 0x00007fff20511420 start_wqthread + 0

Run from terminal darktable -d all > darktable-log.txt and then check the produced log file after it exits. You can search for “rawspeed” to see if it complained about loading problems - if nothing is present, the problem might be somewhere else, perhaps even not related to DNG support (you can try to figure out if there is something else interesting in the log)…

The only recent DNG related change I’m aware of happened in 3.9.0+1479~g9552de237, but it seems you have a problem earlier than that…

Thanks for the feedback, I never had problems previously with dng files from C1. This build and the previous one crash. C1 makes dng and not tiff so it is not practical to convert… and darktable could do it before!
Glad it works on windows, it means that the problem is not in the dt code but with the Mac.

I tried : darktable -d all > darktable-log.txt
The last line of the output are :

15,337135 [add_job] 0 | 15,337141 import | queue: 0 | priority: 015,337142

15,337170 [run_job+] 06 362280041,618826 15,337176 import | queue: 0 | priority: 415,337178

15,337233 [sql] /Users/martinstraeten/src/darktable_debug/src/common/film.c:100, function dt_film_get_id(): prepare “SELECT id FROM main.film_rolls WHERE folder = ?1”

15,337320 [sql] /Users/martinstraeten/src/darktable_debug/src/common/image.c:1753, function dt_image_get_id(): prepare “SELECT id FROM main.images WHERE film_id = ?1 AND filename = ?2”

Magick: abort due to signal 11 (SIGSEGV) “Segmentation Fault”…

Abort trap: 6

Is it a problem with imagemagick ?

Doesn’t sound like regular file format issue, so some macOS developer will have to dig in here…

crash is reproducible:

Process 62366 stopped
* thread #8, name = 'worker 2', stop reason = EXC_BAD_ACCESS (code=1, address=0x20200000000)
    frame #0: 0x00007ff81a3776b2 libsystem_platform.dylib`_platform_strlen + 18
->  0x7ff81a3776b2 <+18>: pcmpeqb (%rdi), %xmm0
    0x7ff81a3776b6 <+22>: pmovmskb %xmm0, %esi
    0x7ff81a3776ba <+26>: andq   $0xf, %rcx
    0x7ff81a3776be <+30>: orq    $-0x1, %rax
Target 0: (darktable) stopped.
(lldb) bt
* thread #8, name = 'worker 2', stop reason = EXC_BAD_ACCESS (code=1, address=0x20200000000)
  * frame #0: 0x00007ff81a3776b2 libsystem_platform.dylib`_platform_strlen + 18
    frame #1: 0x0000000100872a18 libdarktable.dylib`dt_imageio_get_type_from_extension(extension=<unavailable>) at imageio.c:111:38 [opt]
    frame #2: 0x00000001008689f5 libdarktable.dylib`_image_import_internal(film_id=99, filename="/Users/martinstraeten/Downloads/X-Pro3-2022-04-02-14h23min58s_Panorama.dng", override_ignore_jpegs=0, lua_locking=1, raise_signals=0) at image.c:1510:12 [opt]
    frame #3: 0x00000001008686cd libdarktable.dylib`dt_image_import(film_id=<unavailable>, filename=<unavailable>, override_ignore_jpegs=<unavailable>, raise_signals=<unavailable>) at image.c:1764:10 [opt] [artificial]
    frame #4: 0x00000001008d72af libdarktable.dylib`_control_import_job_run [inlined] _control_import_image_insitu(filename="/Users/martinstraeten/Downloads/X-Pro3-2022-04-02-14h23min58s_Panorama.dng") at control_jobs.c:2154:25 [opt]
    frame #5: 0x00000001008d7273 libdarktable.dylib`_control_import_job_run(job=0x0000000118b8c740) at control_jobs.c:2262:16 [opt]
    frame #6: 0x00000001008d0505 libdarktable.dylib`dt_control_job_execute(job=0x0000000118b8c740) at jobs.c:300:17 [opt]
    frame #7: 0x00000001008d0bd7 libdarktable.dylib`dt_control_work [inlined] dt_control_run_job(control=0x000000010a814e00) at jobs.c:319:5 [opt]
    frame #8: 0x00000001008d09bf libdarktable.dylib`dt_control_work(ptr=<unavailable>) at jobs.c:564:8 [opt]
    frame #9: 0x00007ff81a3644e1 libsystem_pthread.dylib`_pthread_start + 125
    frame #10: 0x00007ff81a35ff6b libsystem_pthread.dylib`thread_start + 15
(lldb) up
libdarktable.dylib was compiled with optimization - stepping may behave oddly; variables may not be available.
frame #1: 0x0000000100872a18 libdarktable.dylib`dt_imageio_get_type_from_extension(extension=<unavailable>) at imageio.c:111:38 [opt]
   108 	  }
   109 	  for(const char **i = _supported_ldr; *i != NULL; i++)
   110 	  {
-> 111 	    if(!g_ascii_strncasecmp(ext, *i, strlen(*i)))
   112 	    {
   113 	      return DT_IMAGE_LDR;
   114 	    }

btw: dji mavic pro dng are fine

A little more info, .dng files added to the library with 3.9.0+1362 or previous builds are not a problem and can be develop with +1493 build. +1493 crashes when trying to add .dng files to the library. Thus, until the issue is resolved a workaround is possible if one wants to use the last build to develop .dng files.

Hello, world.
People, where do you get the source code for these versions? (3.9 etc)?
And on GitHub - darktable-org/darktable: darktable is an open source photography workflow application and raw developer only 3.8 sources, or didn’t look well.
There is a desire to improve the performance of this program on mac os. The program lags too much ;( :wink:

1 Like

see darktable/BUILD.txt at master · darktable-org/darktable · GitHub

git clone --recurse-submodules

1 Like

If I build the last version ( GitHub - darktable-org/darktable: darktable is an open source photography workflow application and raw developer ) from source, for some reason opencl is sent on a long journey.
build.txt (202.2 КБ)
darktable.txt (1.2 КБ)
darktable_cltest.txt (4.7 КБ)

Topic Mirror. documentation: Building darktable on macOS using homebrew · Issue #10583 · darktable-org/darktable · GitHub

I also was not able to run the 1493 build. when starting darktable it will ask for updating the database and it will freeze at that point. I simply reinstall the previous version and no problem.

Quick question, is anybody running the new builds on OS Monterey? I am thinking in upgrading from Big Sur.

I only see the latest (current 3.9) and 3.8.1 releases. I can’t figure out this github. Its own logic. Links to releases, as a result, are scattered across forum threads and discussions on github. There is no centralization or something. Well, or I’m a dinosaur) - What’s the 1493 assembly, not a peep at all.
Everything looks beautiful, though. This is not a complaint against the developers of darktable, or the oss.
Maybe someone knows where to find a release/“build” before this same “1493”?