darktable 3.8.0 released

you can override the exiv2 lens detection until lensfun fixes this:

No problem, I am updating Lensfun. The hard part is to get the PR applied https://github.com/lensfun/lensfun/pull/1505
I am also publishing updated mil-canon.xml and slr-canon.xml on my own page because nothing happens at Lensfun Github.

just in case anyone is curious what the problem was


Hi Peter. I’m not sure if this replies directly to your issue (honestly I haven’t understood if yours was a statement, a request or something else).

Anyway, I did the lens corrections for the RF24-240 and RF50 f1.8, and later updated the files by adding “Canon” to the lens names as was asked by others.

So now the lens is picked up correctly by the new exiv included with dt 3.8… But only on my computer – and that’s because I copied lensfun.xml to .local/share/lensfun/!

So… am I missing something with the lensfun database? Is there anyone doing the actual integration with the main database of all the calibration files arriving via pull requests and issues on github?

On this page only the RF24-105 and the RF24-70 are listed for the Canon RF mount: Lensfun's coverage

I am collecting the new Canon lenses and cameras at my own page for anyone to download because our issues and pull requests are not merged into Lensfun database. There are around 35 pull requests just waiting to be integrated.

I have written a notice about Canon model name at my page and I am also trying to update my pull request and mil-canon.xml at my own page when I know that they work together with latest exiv2.

1 Like

I have found it does not work really well with Canon RF lenses yet, because all RF lenses have Exif.CanonCs.LensType=61182* and using a .exiv2 file with (for example) 61182=Canon RF 50mm F1.8 STM leads to all RF lenses being identified as Canon RF 50mm F1.8 STM!

(*there is a new Exif.CanonFi.RFLensType field, but I don’t know if/how it is used by exiv2/darktable, and also the (not new) Exif.Canon.LensModel which contains a Ascii name like RF 50mm F1.8 STM)

Using exiv2 0.27.5 with darktable 3.8, my Canon RF 50mm F1.8 STM lens is identified as the F1.2 version and my other lenses are correctly identified.
What I do is import my cr3 files in darktable, then add the .exiv2 file in my /home with [canon] 61182=Canon RF 50mm F1.8 STM, set a collection in darktable with lens=Canon RF 50mm F1.2 USM, refresh exif information for this collection only. The lens is then well defined. I then remove the .exiv2 file.

Not really ideal, but it works. I hope it can help someone else.

You can match on a different metadata parameter, you’re not limited to just the one.

That sounds good because then it may solve the wrong Exif tag darktable reads in this case due to the wrong order Lensfun - Not finding the right lens

Any guide how to fetch the right Exif tag like Exif.CanonCs.LensModel

Thanks, I did not know that.
However I tried with 280=Canon RF 50mm F1.8 STM (280 is the Exif.CanonFi.RFLensType) and it did not seem to work.

Problem solved! 142=000 was the solution.

Where can i get help? Darktable 3.6.1 works like a charm on my Windows 10 Professional Desktop. Intel i7-7700K 4200MHz on a Asus B150M-C with 32GByte memory.
Darktable 3.8 hangs on startup. The window freezes. There’s just an empty window which i only can close after waiting some seconds.
Deinstalling, reinstalling etc …no change. It just don’t run.


After a couple year hiatus from photography I am getting back into things with a new-to-me Pentax.

DT 3.8 installed great on Ubuntu 20.0.4 LTS after adding the repository. In fact, after running apt update it found libexiv2-27 and offered to upgrade it to 0.27.5-3.1, and afterwards a manual installation of the .deb file works fine, but I re-installed from apt for kicks and grins.

UX is almost identical to the older version I had been using, and it runs very fast now on my newer hardware these days with a Radeon GPU. A big thank you to the devs for maintaining and continuing to polish this marvelous piece of software. cheers

Welcome, @MichaJo ,

Where can I get help?

Hopefully here, in this forum :slight_smile:
(I am not a windowsian, but some forumers are)

First question: From where did you obtain dt 3.8?

Have fun!
Claes in Lund, Sweden

Work perfectly for me. But recall some people had issues. It’s often graphic driver related. You found the right group! You may get more advise with your own topic.

You could execute it from the command-line:

  1. Open a command prompt (press Win + R, type cmd, press Enter)
  2. Change to the directory where it is installed (on my system, it’s at C:\Program Files\darktable\bin).
    – Type: c: (or whatever drive you installed darktable on) and press Enter
    – Type cd \Program Files\darktable\bin
  3. Launch darktable with full diagnostic logging. Type darktable -d all and press Enter.

You will find a file called darktable-log.txt (substitute your home directory path) has been created:

Attach that file to a response here.
Once darktable gets stuck, close it.

1 Like

Thanks for all of your replies!
Claes: It’s darktable-3.8.0-win64.exe
st.raw: I’ve got an NVIDIA GeForce GTX 1660 6G and an actual Driver Version: (GeForce 496.49) from 20-Oct-2021
kofa: Thanks for your detailed advices!
darktable-log.txt (458.9 KB)

I noticed your OpenCL seems to be off at the preference settings (but it should not matter for this issue).

I also noticed this error:
36,149997 LUA ERROR : cannot open C:\Users\User\AppData\Local\darktable\luarc: No such file or directory

Yes. I’ve switched OpenCL off while running with 3.6.1 because i suspected OpenCL to be the reason for the problem.
There is a file called “luarc” in C:\Program Files\darktable\share\darktable
I’ve copied this file now to C:\Users\User\AppData\Local\darktable but that didn’t change anything. Darktable 3.8 still won’t run

I’m not sure how to help you with these issues. I would start by renaming your configuration file to .old and letting the system start a new one when you install 3.8. I’m not sure if your previous settings are causing problems (eg. like looking for lua).

You can also wait to see if someone else has any other ideas.

@MichaJo have you made sure it isn’t being flagged by windows defender or some other anti virus?