darktable windows insider program 8/28

Here’s the link to the latest weekly snapshot of darktable 4.1, https://drive.google.com/file/d/1FgDWD130zexO1NXkqG3z20IqjCB0KBsD/view?usp=sharing. The list of latest changes can be found at Pulse · darktable-org/darktable · GitHub


I have not been able to get these compilations to work for a long time: Once installed the dt window opens a bit and immediately closes.

I have Surface Pro 8 i7 with windows 11 and Intel Iris Xe.
It also does not work on a hp Amd Ryzen 7 with win 10 and Radeon Vega Mobile Gfx.

The last build that worked for me was darktable-4.1.0+148~g242c03e75-win64.exe but I don’t remember where I downloaded it from (from @wpferguson , from @priort , or from the Nightly PKGs).

(Translated with DeepL).

Hace tiempo que no me funcionan estas compilaciones: Una vez instalada se abre un poco la ventana de dt e inmediatamente se cierra.

Tengo Surface Pro 8 i7 con windows 11 y Intel Iris Xe.
Tampoco funciona en un hp Amd Ryzen 7 con win 10 y Radeon Vega Mobile Gfx.

La última compilación que me funcionaba fue darktable-4.1.0+148~g242c03e75-win64.exe pero no recuerdo de dónde me la bajé (de @wpferguson , de @priort , o de las Nightly PKG).

Que error te dice? Intenta sin usar openCL.

What error do you get? Try without openCL.

There is no error message.
Simply, running the exe opens the window and closes it immediately.

I have tried with:


Nothing changes.

Intenta darktable --disable-opencl


I tried in the .bat:
.\bin\darktable --disable-opencl --configdir “.\config”


Use CMD to run the commands.

Try darktable -d all to see what the error in the log is. The log in windows is in a hidden folder.

We might need to move this to another thread since it is a bit off topic.

Trata usando el command line y no bat.

There was some Windows 11 specific shortcut setting that was needed AFAIR, but can’t find the link. Check here or dt GitHub.

Custom build is working fine on Windows11 with nvidia rtx30xx series here, no shortcut or special things needed.

There was that thing where some Windows11 devices got a ‘opencl emulator’ installed, using dx12 to run opencl or something. But I’m guessing that disabling opencl would help to fix that as well :man_shrugging:

Tried without success:

I show hidden items in windows file explorer and I don’t see any hidden folder where the log is (or I don’t know where it is, or there isn’t one).

Muestro elementos ocultos en el explorador de archivos de windows y no veo ninguna carpeta oculta donde esté el log. (o no sé donde está, o no la hay).

My history is:
I have DT4.0.0.0 installed on Appdata.

Then I have a folder to test Sigmoid: DarkTable 3.9.0+925~g911f71370
I have another folder to test Tone Eequalizer: DarkTable 3.9.0+1781~gb8cdc71b6-dirty
And I have another folder to test Light Reconstruction-> segmentation based: DarkTable 4.1.0+148~g242c03e75

The latter is the last one that works for me.

And all the installation files weighed about 111 Mb.

From that I remember Bill changed something:
“This week I updated to the new universal C run time build tools, so please let me know if there are any problems.”

Since then they no longer worked for me on Surface 8 with Iris Xe.
Their installation files weighed 84 Mb.

And since then the Nightly PKG didn’t work either.

Mi historial es:
Tengo instalado DT4.0.0 en Appdata

Luego tengo una carpeta para probar Sigmoid: DarkTable 3.9.0+925~g911f71370
Tengo otra carpeta para probar Tone Eequalizer: DarkTable 3.9.0+1781~gb8cdc71b6-dirty
Y tengo otra carpeta para probar Light Reconstrucction-> segmentation based: DarkTable 4.1.0+148~g242c03e75

Este último es el último que me funciona.

Y todos los archivos de instalación pesaban sobre 111 Mb.

A partir de ese recuerdo que Bill cambió algo:
“This week I updated to the new universal C run time build tools, so please let me know if there are any problems.”

Desde entonces ya no me funcionaban en Surface 8 con Iris Xe.
Sus archivos de instalación pesaban 84 Mb.

Y tampoco me funcionaban desde entonces las Nightly PKG.

  • I read a lot of information in the manual to turn on some debug settings, but I cannot see any debug information. Where can I find those debug logs? The Windows version of dt by default logs its debug information to the following places:Windows 10: C:\Users\[username]\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txtWindows 7: C:\Users\[username]\AppData\Local\Microsoft\Windows\Temporary Internet Files\darktable\darktable-log.txt

darktable-log.txt (361,0 KB)

It is not an OpenCL issue.

It seems to load fine until this last line:

2.584292 [camera_control] loaded 4 port drivers.

Do you have a camera connected to the PC? Trata de empezar darktable sin esas conneciones.

No, I don’t have any devices connected to the surface tablet, except for the keyboard and mouse via bluetooth.

On the amd ryzen I only have a mouse connected by usb.

Just wondering, am I correct in assuming that this build has the ‘BUGFIXES new iop cache issues #12393’ fixes in it? I’m new to Github - so this is probably a silly question :open_mouth:
Edit: I mean this latest windows insider build.

I guess it was a silly assumption… I just installed this version and it still crashes, on subsequent exposure adjustments, albeit without giving any errors.
I’ll try next week’s version :smile:

It is not. That PR was merged today and bill did his build last night.

Check to see if the nightly builds run and try that one instead.

Yes, I thought that must be it. Where do I find windows nightly builds? (another questionable question :face_with_hand_over_mouth:)

The nightly PKG will have the windows install file if you log in GitHub.

But the nightly failed to build for the last 3 days.

The nightly builds are failing because of this:

FAILED: lib/darktable/plugins/lighttable/libgamepad.dll

I boot the windows PC and build the current master on UCRT. Installed it without a problem.