Filmulator "Nightly" Builds: Now for Windows and Linux

Since lately the master (and even the dev) branch is way behind, I’d suggest you get this AppImage rather than pulling from master. I’ll try to keep this updated with a relatively stable recent build.

Updated 2022-01-23: change linearity of NR Strength, fix compact cameras’ lens preferences
Filmulator_v0.11.2rc11.AppImage (40.5 MB)
Filmulator_v0.11.2rc11.exe (32.9 MB)

Updated 2022-01-04: fix flickering histogram (infinite loop in image fetching)
Filmulator_v0.11.2rc10.AppImage (40.5 MB)
Filmulator_v0.11.2rc10.exe (32.9 MB)

Updated 2021-12-29: fix highlight recovery for extended low ISO values
Filmulator_v0.11.2rc9.AppImage (40.5 MB)
Filmulator_v0.11.2rc9.exe (32.9 MB)

Updated 2021-12-15: fix LensFun corrections, fix Panasonic black points (no Windows version for now) (2021-12-16 added Windows version)
Filmulator_v0.11.2rc8.AppImage (40.5 MB)
Filmulator_v0.11.2rc8.exe (32.9 MB)

Updated 2021-11-12: add some missing DLLs to Windows build, hopefully it doesn’t need too many more
Filmulator_v0.11.2rc7.exe (32.6 MB)

Updated 2021-11-10: fix bug with lensfun correction and leveling, improve noise reduction
Filmulator_v0.11.2rc6.AppImage (40.5 MB)
Filmulator_v0.11.2rc6.exe (32.4 MB)

Updated 2021-10-29: reorder pipeline to fix white balance in extreme conditions, and more
Filmulator_v0.11.2rc5.AppImage (40.5 MB)
(the Windows build is broken at the moment)

Updated 2021-07-07: make it behave properly when no camconst.json has been downloaded
Filmulator_v0.11.2rc4.AppImage (40.5 MB)
Filmulator_v0.11.2rc4.exe (39.8 MB)

Updated 2021-06-27: fix memory leak in NR, slightly reduce memory usage overall
Filmulator_v0.11.2rc3.AppImage (40.5 MB)
Filmulator_v0.11.2rc3.exe (39.8 MB)

Updated 2021-06-24: big change including experimental noise reduction - NR settings not saved
Filmulator_v0.11.2rc2.AppImage (40.5 MB)
Filmulator_v0.11.2rc2.exe (39.8 MB) - updated with missing DLL

Updated 2021-04-07: allow importing symlinks, make help button to reveal tooltips instantly
Filmulator_v0.11.2rc1.AppImage (40.4 MB)
Filmulator_v0.11.2rc1.exe (39.5 MB)

Updated 2021-02-14: the mid-pipeline histograms follow the cropped image
Filmulator_v0.11.1rc9.AppImage (40.3 MB)
Filmulator_v0.11.1rc9.exe (39.5 MB)

Updated 2021-02-12: white balance picker and stored white balance settings
Filmulator_v0.11.1rc8.AppImage (40.3 MB)
Filmulator_v0.11.1rc8.exe (39.5 MB)

Updated 2021-02-04: let the user override the DCIM import-in-place error
Filmulator_v0.11.1rc7.AppImage (40.3 MB)
Filmulator_v0.11.1rc7.exe (39.5 MB)

Updated 2021-1-31: fix TIFF shutter speed, make CLI raw argument open straight to Filmulate tab
Filmulator_v0.11.1rc6.AppImage (40.3 MB)
Filmulator_v0.11.1rc6.exe (39.5 MB)

Updated 2021-01-28: fix TIFF ISO sensitivity metadata
Filmulator_v0.11.1rc5.AppImage (40.3 MB)
Filmulator_v0.11.1rc5.exe (39.5 MB)

Updated 2021-01-26: several bugfixes that need testing
(Linux build is taking a while)
Filmulator_v0.11.1rc4.exe (39.5 MB)
Filmulator_v0.11.1rc3.exe (39.5 MB)

Updated 2021-01-10: several keyboard shortcut refinements
Filmulator_v0.11.0rc7.AppImage (40.3 MB)
Filmulator_v0.11.0rc7.exe (39.5 MB)

Updated 2021-01-06: properly do not import files that cannot be edited
Filmulator_v0.11.0rc6.AppImage (40.3 MB)
Filmulator_v0.11.0rc6.exe (39.5 MB)

Updated 2021-01-03 again: fix “reduce memory usage” option
Filmulator_v0.11.0rc5.AppImage (40.3 MB)
Filmulator_v0.11.0rc5.exe (39.5 MB)

Updated 2021-01-03: make converted DNGs ignore camconst whitepoint. Also display version number in Settings.
Filmulator_v0.11.0rc4.AppImage (40.3 MB)
Filmulator_v0.11.0rc4.exe (39.5 MB)

Updated 2021-01-02: fix repeated file imports
Filmulator_v0.11.0rc3.AppImage (40.3 MB)
Filmulator_v0.11.0rc3.exe (39.5 MB)

Updated 2021-01-01: adapt 14-bit whitepoint to 12-bit Nikon raws correctly
Filmulator_v0.11.0rc2.AppImage (40.3 MB)
Filmulator_v0.11.0rc2.exe (39.5 MB)

Updated 2020-12-31: use camconst.json from RT to correct whitepoints
Filmulator_v0.11.0rc1.AppImage (40.3 MB)
Filmulator_v0.11.0rc1.9.exe (39.5 MB)

Updated 2020-12-20: fix exif writing for tiff
Filmulator_v0.10.2rc4.AppImage (40.3 MB)
Filmulator_v0.10.2rc4.exe (39.0 MB)

Updated 2020-12-17: fix pasting breaking the preload, remove tiff exif writing again (and adjusted jpeg exif writing)
Filmulator_v0.10.2rc3.AppImage (40.3 MB)
Filmulator_v0.10.2rc3.exe (39.0 MB)

Updated 2020-12-01: fix jumpy scrolling behavior and queue auto-scrolling
Filmulator_v0.10.2rc2.AppImage (40.3 MB)
Filmulator_v0.10.2rc2.exe (38.9 MB)

Updated 2020-11-30: preload next adjacent image for faster image switching
Filmulator_v0.10.2rc1.AppImage (40.3 MB)
Filmulator_v0.10.2rc1.exe (38.9 MB)

Updated 2020-11-15: lots of UI changes to ease onboarding of new users
Filmulator_v0.10.0rc5.AppImage (40.3 MB)
Filmulator_v0.10.0rc5.exe (38.9 MB)

Updated 2020-11-10: disable the crop while leveling the image
Filmulator_v0.10.0rc4.AppImage (40.2 MB)
Filmulator_v0.10.0rc4.exe (38.9 MB)

Updated 2020-11-08: made leveling available on the preview-res image, fixed cropping which got broken by leveling
Filmulator_v0.10.0rc3.AppImage (40.2 MB)
Filmulator_v0.10.0rc3.exe (38.9 MB)

Updated again 2020-11-06: now leveling works for all lenses.
Filmulator_v0.10.0rc2.AppImage (40.2 MB)
Filmulator_v0.10.0rc2.exe (38.9 MB)

Updated 2020-11-06: added leveling feature (works only for recognized lenses, oops!)
Filmulator_v0.10.0rc1.AppImage (40.2 MB)
Filmulator_v0.10.0rc1.exe (38.9 MB)

===== Database Version Break =====

Updated 2020-10-23: shortened some German tool names, crop handles flash on initiating crop
Filmulator_v0.9.1rc8.AppImage (40.2 MB)
Filmulator_v0.9.1rc8.exe (38.9 MB)

Updated 2020-10-20: now you can force English in German locales, and TIFF exif writing is enabled again.
Filmulator_v0.9.1rc7.AppImage (40.2 MB)
Filmulator_v0.9.1rc7.exe (38.9 MB)

Updated 2020-10-18: now with a preliminary German translation
Filmulator_v0.9.1rc6.AppImage (40.2 MB)
Filmulator_v0.9.1rc6.exe (38.9 MB)

Updated 2020-10-16 again: made the raw file argument not require -i flag
Filmulator_v0.9.1rc5.AppImage (39.0 MB)
Filmulator_v0.9.1rc5.exe (38.8 MB)

Updated 2020-10-16: fixed CLI importing of new images
Filmulator_v0.9.0rc4.AppImage (39.0 MB)
Filmulator_v0.9.1rc4.exe (38.8 MB)

Updated 2020-10-15: added -i command line flag
Filmulator_v0.9.1rc3.AppImage (39.0 MB)
Filmulator_v0.9.1rc3.exe (38.8 MB)

Updated 2020-10-12: various ui tweaks (see below)
Filmulator_v0.9.1rc2.AppImage (39.0 MB)
Filmulator_v0.9.1rc2.exe (38.8 MB)

Updated 2020-10-06: fix bug with highlight rolloff, display the actual film area number
Filmulator_v0.9.1rc1.AppImage (39.0 MB)
Filmulator_v0.9.1rc1.exe (38.5 MB)

Updated 2020-09-15: fixed import bug with directory recursion
Filmulator_v0.9rc13.AppImage (39.0 MB)
Filmulator_v0.9rc13.exe (38.5 MB)

Updated 2020-09-12: added keyboard shortcuts, removed calendar, fixed bug with time zones
Filmulator_v0.9rc12.AppImage (39.0 MB)
Filmulator_v0.9rc12.exe (38.5 MB)

Updated 2020-09-02: finally got Windows building again
Filmulator_v0.9.0rc11.exe (39.4 MB)

Updated 2020-08-29: fixed scrolling in lens selection, added scrollbars everywhere.
Filmulator_v0.9.0rc11.AppImage (40.4 MB)

Updated 2020-08-28: fixed scrolling everywhere, and added a scrollbar to the queue
Filmulator_v0.9.0rc10.AppImage (40.4 MB)

Updated 2020-07-23: fix a bug in thumbnail loading in the editor that reduced apparent responsiveness
Filmulator_v0.9.0rc9.AppImage (40.4 MB)
Filmulator_v0.9.0rc9.exe (39.3 MB)

Updated 2020-07-17: uses a different file dialog and folder dialog to help startup issues on Windows.
Filmulator_v0.9.0rc8.AppImage (40.6 MB)
Filmulator_v0.9.0rc8.exe (39.3 MB)

Updated 2020-07-16: uses Qt Quick Compiler instead of dynamically loading the QML files, to hopefully prevent slow startup on Windows.
Filmulator_v0.9.0rc5.AppImage (40.5 MB)
Filmulator_v0.9.0rc5.exe (39.2 MB)

More debug: Filmulator_v0.9.0rc6.exe (39.2 MB)

Fixing lensfun initialization and destruction to try to fix intermittent startup crashes
Filmulator_v0.9.0rc7.AppImage (40.5 MB)
Filmulator_v0.9.0rc7.exe (39.2 MB)

Updated 2020-07-14: better print statements for startup times, including timestamps now.
Filmulator_v0.9.0rc4.exe (39.1 MB)

Updated 2020-07-13: includes CR3 support, Windows version has a terminal window for now so you can see debug output for debugging startup times.
Filmulator_v0.9.0rc3.exe (39.1 MB)

Updated 2020-07-05: fixed two bugs when trying to load a missing raw file
Filmulator_v0.9.0rc1.AppImage (40.3 MB)
Filmulator_v0.9.0rc1.exe (39.1 MB)

Updated 2020-06-18: made some Samsung DNGs properly parse as color images, fixed the display of some ugly fractional shutter speeds
Filmulator-d753ba6-x86_64.AppImage (40.3 MB)
FilmulatorSetup.exe (39.0 MB)

Updated 2020-06-11: fixed a performance regression that reduced the responsiveness of sliders.
Filmulator-ba4e765-x86_64.AppImage (40.3 MB)
FilmulatorSetup.exe (39.0 MB)

Updated 2020-06-10: Replaced the heartbeat error notifications with error icons because they were consuming tons of CPU power on Windows.
Filmulator-49e6658-x86_64.AppImage (40.1 MB)
FilmulatorSetup.exe (39.0 MB)

Updated 2020-06-07: now we have a Windows build! (no real changes)
FilmulatorSetup.exe (39.0 MB)

Updated 2020-04-30: version 0.9, now with lens corrections via profile!
Filmulator-0b606d0-x86_64.AppImage (40.1 MB)

===== Database Version Break =====

Updated 2020-04-26 again: added a slider to control auto CA correct iterations. (updated because the first version didn’t actually set the iteration count)
Filmulator-e83992d-x86_64.AppImage (40.1 MB)
FilmulatorSetup.exe (38.8 MB)

Updated 2020-04-26: Partway through Lensfun implementation. Test the database search (has no impact on processing) and update fetching.
Filmulator-b29baa2-x86_64.AppImage (40.1 MB)
FilmulatorSetup.exe (38.0 MB)
FilmulatorSetup.exe take 3 (38.4 MB)

Updated 2020-04-14: Icons to clean up the UI, dropped the deletion feature. The Windows build isn’t working at the moment.
Filmulator-7b724ee-x86_64.AppImage (38.5 MB)

Updated 2020-01-08: fix a bug in import-in-place/update locations
Filmulator-7c5ddfc-x86_64.AppImage (38.5 MB)
FilmulatorSetup.exe (33.6 MB)

Updated 2019-12-28: using an older gcc to try to solve an AppImage compatibility issue. No changes to the code, so no new Windows build.
Filmulator-ed1d6f5-x86_64.AppImage (38.4 MB)

Updated 2019-12-10: dramatically speed up “forget” operation when the database is large
Filmulator-525440d-x86_64.AppImage (38.5 MB)
FilmulatorSetup.exe (33.5 MB)

Updated 2019-11-17: fix layout issues, fix divide by zero artifacts affecting images containing zero values
Filmulator-5b5b7a7-x86_64.AppImage (38.7 MB)

Updated 2019-11-14: added “forget” from database, added additional processing parameter “shadow rolloff point”. This has a database change so be careful!
Filmulator-b2ac379-x86_64.AppImage (38.7 MB)

Even faster enqueuing now:
Filmulator-b2f766f-x86_64.AppImage (38.7 MB)
FilmulatorSetup.exe (33.4 MB)

Updated 2019-11-02: added “enqueue all” button, added sraw and monochrome support
Filmulator-af7d0f0-x86_64.AppImage (38.7 MB)
FilmulatorSetup.exe (33.4 MB)

Updated 2019-10-22 - added raw histogram
Filmulator-c8d3265-x86_64.AppImage (38.7 MB)
Windows build coming when I figure out msys2 package management in Azure. here 2019-10-23
FilmulatorSetup.exe (33.4 MB)

Updated 2019-10-07 - finished Qt Quick Controls 2 conversion. Windows build coming later after I figure out how to get a newer LibRaw.
Filmulator-git.f38bc26-x86_64.AppImage (38.7 MB)

Updated 2019-10-01 - changed to Qt Quick Controls 2 for a lot of the controls, added a second progress bar for Import in the tabs at the top (only visible while importing), updated base distro to Ubuntu Xenial from Trusty, so the AppImage won’t run on ultra-old distros
Filmulator-git.060321a-x86_64.AppImage (38.7 MB)

Updated 2019-08-25 - expanded the range of the tint slider
Filmulator-git.5d2383f-x86_64.AppImage (32.5 MB)
FilmulatorSetup.exe (29.2 MB) (uploaded 2019-09-02)

Updated 2019-06-21 - overall speed enhancements thanks to @heckflosse
Filmulator-git.5aa82b4-x86_64.AppImage (32.5 MB)

Updated 2019-06-17 - faster librtprocess build
Filmulator-git.f40c8d8-x86_64.AppImage (32.5 MB)

Updated 2019-06-16


Could you change the title of the thread to
Filmulator “Nightly Builds”

Windows 64-bit builds



I’ve updated the Linux build again, this time with some more speed enhancements.

1 Like


I’m having troubles running these two nightly builds. They both give me a segmentation fault, even though I’m able to run the 0.7.0 AppImage from the GitHub repo.

The only info I can glean is the following from gdb:

Reading symbols from ./Filmulator-git.5aa82b4-x86_64.AppImage...
(No debugging symbols found in ./Filmulator-git.5aa82b4-x86_64.AppImage)
(gdb) run
Starting program: /home/austin/downloads/Filmulator-git.5aa82b4-x86_64.AppImage 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/".
[Detaching after fork from child process 1100]
process 1096 is executing new program: /tmp/.mount_FilmulQJQR7M/usr/bin/filmulator-gui
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/".
[New Thread 0x7fffefa43700 (LWP 1104)]
[New Thread 0x7fffeedce700 (LWP 1105)]

Thread 1 "AppRun" received signal SIGSEGV, Segmentation fault.
0x00007ffff5c78fb7 in QVariant::QVariant(QVariant const&) () from /tmp/.mount_FilmulQJQR7M   /usr/bin/../lib/


Edit: Well, they run just fine in an Ubuntu VM. It seems they don’t like my ArchLinux machine, but I have no idea why.

Edit2: It runs fine if I open it with root privileges. Strange.

Are you doing chmod a+x filmulator.appimage?

Try deleting the database ~/.local/share/filmulator/filmulatorDB.

@CarVac That fixed it, thanks!

I updated the Linux build again. This increases the upper limit of the Tint slider from 3 to 10 (now 0.10 to 10), and makes it logarithmic for easier control.

This is because I got an IR photo to play with and it needed to max out the Tint setting.

I’ve just released the first version of Filmulator with a real installer, built on Azure Pipelines CI.

1 Like

I’m in the process of moving from Qt Quick Controls 1, which is deprecated, to Qt Quick Controls 2. It’s done except for the calendar in Organize, which is a little buggy anyway… I’ve gotta figure out how to handle that later tonight/in the future.

Please test and report any unusual behavior you notice. (besides the removal of the Output tab)

Hello @CarVac
I’m trying this version of Filmulator

on a Win10 64 bit system and while it works on raw files coming from Samsung NX300, Samsung NX1, Canon EOS1100D, it doesn’t work very well on raw files coming from Panasonic GX85/GX80.

In particular, while Filmulator does load the Panasonic GX85/GX80 files, they come out having strange colours: from my comparisons with Rawtherapee, Filmulator rendering of the GX85 raw files looks almost identical to Rawtherapee rendering when setted on Input profile = No Profile, hence I suppose Filmulator, for some strange reason, doesn’t apply any input profile color matrix for this camera.

Hence, I’ve tried converting some GX85 raw files to dng files, using adobe dng converter and doing this I obtained the following results:

-Sometimes Filmulator is able to open those dng files, and when it does, the results have the right
-More than often, Filmulator refuse to open those dng files

More precisely, when it refuses to load the files, two cases are possible:

  1. The console output gives the following line: " Error: Failed to read Panasonic IFD Makernote header"
    In this case Filmulator does not crash, and if I enable the “Update file locations” button and then try to import the same file again, SOMETIMES, it gets loaded correctly and the console output the following lines
    “importWorker replace location: C:/MyImagesDirectory/MyWannaBePicture.dng
    importWorker replace STsearchID: 3db3a8010d23def5f556c960ea0b4b920001”
    Other times, even when doing this “procedure”, it continue to output the line " Error: Failed to read Panasonic IFD Makernote header" each time I press the Import button

  2. The console produces lots of lines, it seems Filmulator is doing its behind the scenes job, then Filmulator suddenly crashes; see the output of the console in the image below:

Hope this helps!

P.S. FIlmulator is really a great piece of code!!! I’m observing and waiting it from your first “release” back to 6-7 years ago! Unfortunately at that time it was “a bit unstable” :smiley: , hence I’m patiently waiting from that time that Filmulator grows on its legs :smiley:
If it doesn’t mind you, can I ask you just some questions?
-Does Filmulator apply some kind of “tone curve” in addition to your special “analog tone mapping” ?
-Does Filmulator apply some sort of Sharpening to the image? I know that tone mapping/local contrast does somewhat augment the perceived sharpness of an image, but stil, the Filmulator output seems almost ready for the printing!

1 Like

Could you upload a sample raw file (both original and DNG conversion) for me to try?

If it’s not supported in LibRaw, then it won’t have the necessary color profiles. It should work, but let me see what’s happening.

DNGs sometimes have weird metadata issues. Right now Filmulator does a poor job of actually working with metadata, so this could be an opportunity to improve.

Regarding your questions:

  1. There is a built-in pre-film tone curve to roll off the highlights (adjustable) and a fixed post-film tone curve that brightens the shadows. The latter was based on what I always did to every image in RawTherapee after running the original command-line version.
  2. There is no added sharpening. All that edge crispness comes from the tone mapping. And yes, it really makes for great prints with minimal additional work. In the future we may get early-pipeline capture sharpening in librtprocess which would be good at counteracting soft lenses and diffraction, as well.

Sure, find attached one of the one I was testing: don’t pay attention to the fact that the shot is underexposed, I did shot it that way on purpose, it was one of various exposure shots I was trying to test the dynamic range of Panasonic GX85 :slight_smile:

Just a little update on my previous post:
Initially, the file you’ll find attached, was the one showing always the behavior number 2), while on other files I was testing, sometimes I had behavior 1) (and I were able to open them after applying my “rescue procedure”), sometimes I had the behavior 2) and Filmulator crashed.

Now, instead, after uninstalling Filmulator (and deleting the folder that Filmulator creates in the AppData for putting its database) and then reinstalling it, even when a file shows behavior 1), following my “rescue procedure” doesn’t work, because it always leads to the behavior number 2): in fact, the file seems to load, sometimes also the thumbnail of the loaded image appears in the stripe below, but then Filmulator output on the console all the lines of the screenshot in my previous post, the one that ends with the line “Size of EXIF JPEG segment is larger than 65535 bytes”, and then Filmulator crashes…

P1010239.dng (10.5 MB) P1010239.RW2 (18.5 MB)

I will add capture sharpening to librtprocess in about 3 weeks when I’m back from holidays.


Okay, so on the Linux AppImage we always have the latest version of LibRaw, and the RW2 works just fine. But indeed the DNG doesn’t work. I’ll have to deal with it.

However, the Windows build uses a pre-packaged (from MSYS2) LibRaw and it’s probably not the latest version, so that needs to be compiled from the latest version as well.

Ok, got it.

I have to add, hoping it can be useful, that the older versions available here

show behavior 1) less frequently than the latest one ( v0.8 if I’m not wrong…) and, up to now, doing a lot of tentatives, never shown behavior 2), hence have never crashed!!

Obviously I’m talking of “.dng” raw files

Those builds are done differently than the CI build I uploaded here, so they may have a newer LibRaw version.

I don’t see why the exif stuff would behave any differently, though.

I added a raw histogram to Filmulator, which now features three mini-histograms plus the final histogram.

The histograms also got some enhancement: they now scan every pixel in the image instead of 1/25 of the pixels (which was why they were noisy and varied a lot between preview and final image before), they’re multithreaded so even with that change they still are imperceptibly brief to compute, the background is now slightly lighter gray for improved readability, the line widths now scale more continuously with UI scale, the lines are less likely to stick out of the frame, and the behavior when the image is clipped on the light side of the histogram is displayed more accurately.

In implementing the raw histogram, I discovered some processing mistakes (white saturation point) and fixed them. This is especially noticeable for Fuji cameras.

Seems the Windows build is unhappy because the CI system is using Qt 5.10 when it should be on 5.13 (and Filmulator currently needs 5.12).

1 Like