Filmulator "Nightly" Builds: Now for Windows and Linux

Maybe the build uses SSE4, which is not supported by your CPU…


On the contrary, I believe it does.

It supports SSE4.1 but not SSE4.2

You’re right that SSE4 usually means SSE4.2.

Try the latest version I just posted at the top of the thread, which has newer versions of some libraries.

I’m not sure if your processor is the issue, but usually the raw files are the issue. Could you upload one here for me to test?

I just added an “Enqueue All” button to the Organize tab, letting you easily work on large older batches of images.

In developing that, at one point the last image I had enqueued was the only sRaw I’ve ever taken (for and when clicking on it the program crashed… turns out that after switching to librtprocess I forgot to account for raw files that don’t need demosaicing, like Canon sRaw and mRaw, and the Nikon D810 sRaw (but not the D850 sRaw, which is converted back to Bayer data after resizing), and the Leica M Monochrom cameras.

So now those are supported once more.

1 Like

And after noticing some slow performance on doing Enqueue All on a hard disk, I just made it faster.

1 Like

You can now tell the database to forget about images. Set one or more image ratings to X in the queue in the right click menu, right click on any queue image, and click “forget”; this’ll remove from the database all images that are currently in the queue. Yes, you see that the delete button is there (which will in the future delete the files in question) but that’s not implemented.

I also added a new processing parameter: Shadow Rolloff Point. This lets you add a toe before the film simulation, and can make images look an awful lot like film.

Because there’s a new parameter, this requires updating the database. It should automatically back up the database in case anything goes wrong.


I’ve fixed some layout issues with the queue, and I made the processing parameter number displays fixed-point so that you don’t get the ... ellipsis cutting off the end. That was a real problem when the Shadow Rolloff Point would switch to scientific notation and become impossible to reaod.

Also, I added an epsilon to a denominator in the Shadow Rolloff Point curve calculation which fixes issues when the input image contains zeros and Shadow Rolloff Point itself is set to zero.

Do not use the forget function!

It may lose the locations of files you’ve imported before!

(I need to fix this asap!)

Actually, the forget function is fine.

I screwed up my database while I was writing and testing parts of the functionality, but the nightly build I released doesn’t actually cause the problem.

1 Like

I just dramatically sped up the forget function for large databases. My database has over 15k photos, and deletion would take 7 seconds. Now it’s around 40 ms.

1 Like

I found and fixed a bug in Import In Place/Update Locations that occurred as a result of implementing the forget function.

1 Like

I have downloaded and used the most recent Appimage version (Filmulator-7c5ddfc-x86_64) this afternoon. I had some problems importing and more annoyingly, saving the images (saving was not possible). I had tried the “forget” function but it did not work. The calendar in the organizer section was also behaving strangely (more on this later). I was about to report the problems here but during my last try, I could import a file and process it easily. Saving the image was no problem in either format! Whatever the hiccup was, it had gone.

Now, I was playing with an earlier Filmulator Appimage and trying to change the settings this morning “with the same problems”!!! So I guess the problem might have something to do with Filmulator’s thumbnail DB (?) which I believe is shared by the Appimage files. Hence, the forget function (which worked finally) made Filmulator operate nicely again).

However, a strange thing still happens (always, repeatedly, consistently) when I click on the calendar at the Organize part. Filmulator ALWAYS selects the next day of the month when I click on a date. If I click on 9, 10 is selected; if I click on 28, 29th is selected and so on. I wonder if this is happening only on my system. Could that be so?

Regarding the database: all installs should use the same database, however you shouldn’t use older versions of the AppImage with databases touched by the newer AppImage. The latest AppImage should save a duplicate of the database prior to changing the schema, however.

I had a similar problem on my system prior to the 2019-10-07 version, but I have zero problems at the moment.

Could you elaborate on this?

If I click on 9, 10 is selected

If you click on 9 in the calendar, which day becomes highlighted in the calendar? Which day becomes highlighted in the Date Histogram (you can find this from the tooltip you get if you hover over a day)

If you click on 9 in the Date Histogram, what day is highlighted in the calendar? In the Date Histogram?

Does the number of photos you can see match the number in the date histogram tooltip?

If you restart the application, is the same day still selected?

Click 9 (on the calendar) —> 10 is highlighted on the calendar / 9 (correct) is seen on the histogram.

Click 9 (on the histogram) —> 10 is highlighted on the calendar


!!! Both (Calendar and Histogram) move 1 day forward!

The only thing I can think of to fix the behavior causes them to move backwards by one day on restarting for me (while all the other behavior I asked you about continues to work perfectly fine for me both before and now).

Time to do more experimentation.

What are your time zones set to in both Import and Organize? There should be three separate ones.

It should have been UTC +3
However, I did not set it yet (anywhere) because I did not realize it might be relevant for my present work.
(Now I tried setting them all and they remained as I defined them after restart. No problem).

Regarding the thumbnail DB issue, I may well have tried the recent version improperly.

Thank you for responses, by the way… :slight_smile:

Now with icons! (see the quarantine dev log)

I ditched the deletion feature because I couldn’t decide on the right way to implement it.


I got the Windows build working again, so here’s a glimpse into the lens correction feature implementation as it stands now.

When you load the program, go to the Settings tab and in the second column, press the Update button to download the Lensfun database for Filmulator. Then restart the program (this may change in the future) and try searching for lenses in the Filmulate tab to see what there is.

It doesn’t actually do anything to the photos yet, but the UI is coming together.

EDIT: the Windows build is missing some DLLs. Hold on for a few minutes for a new build.

1 Like