GIMP AppImage (continuous integration)


(Carmelo Dr Raw) #463

Could you post the full GIMP terminal output? Only the part when launching gimp is needed.

Thanks!


(Boris Hajdukovic) #464

Hi, @Carmelo_DrRaw

Here is output:

https://pastebin.com/srJu1CQP


(Boris Hajdukovic) #465

Among other things, it says:

/home/s7habo/.config/GIMP-AppImage/2.10/plug-ins/gmic_gimp_qt: /tmp/.mount_Puw5fV/usr/lib/libssl.so.1.0.0: version `OPENSSL_1.0.2’ not found (required by /usr/lib/x86_64-linux-gnu/libcurl.so.4)

but i have that installed:


(Carmelo Dr Raw) #466

You should not have the GMIC-Qt plugin in the .config folder, as it conflicts with the bundled one. I guess the one from the .config folder is a copy of the one installed from PPA, right? This cannot be done, since the AppImage uses its own version of most of the system libraries (hence the library conflict you are getting).

Could you please remove /home/s7habo/.config/GIMP-AppImage/2.10/plug-ins/gmic_gimp_qt and try again?

Here is the relevant portion of the log.

Skipping duplicate plug-in: '/tmp/.mount_Puw5fV/usr/lib/gimp/2.0/plug-ins/gmic_gimp_qt'
.............
Calling custom execve(/home/s7habo/.config/GIMP-AppImage/2.10/plug-ins/gmic_gimp_qt) function
/home/s7habo/.config/GIMP-AppImage/2.10/plug-ins/gmic_gimp_qt: /tmp/.mount_Puw5fV/usr/lib/libssl.so.1.0.0: version `OPENSSL_1.0.2' not found (required by /usr/lib/x86_64-linux-gnu/libcurl.so.4)
/tmp/.mount_Puw5fV/usr/bin/gimp.bin: LibGimpBase-WARNUNG: gimp.bin: gimp_wire_read(): error

(Boris Hajdukovic) #467

Yes, that was actually the case. But what I wondered when I started your AppImage first, I didn’t change anything in the plugin folder and it didn’t work. After that I downloaded the new gimp_gmic_gt version offered on the G’MIC site and saved it there to test if it works. When you asked me to send terminal output, I deleted the entire".config/GIMP-AppImag" folder before I did that!

Anyway, it works now! Many thanks for your AppImage and time!


(Carmelo Dr Raw) #468

I have just created an AppImage package for the official GIMP 2.10.4 release: https://github.com/aferrero2707/gimp-appimage/releases/download/continuous/gimp-release-2.10.4.glibc2.15-x86_64.AppImage

Happy editing!!!


#469

Thank you!


(Stefan Chirila) #470

Just letting you guys know I’ve tried opening a SVG vector with the gimp image and it’s failing. Says file format isn’t supported. :frowning:

@Carmelo_DrRaw


#471

Yep, it is because the nufraw plugin is installed.

This is the problem with plugins preinstalled in an appimage. No real way to remove/disable them.


(Stefan Chirila) #472

ugh. is there really no fix :frowning: ???


(Carmelo Dr Raw) #473

@stefan.chirila @rich2005 give me a couple of days to look into that and find a solution that does not completely exclude the nuFraw plug-in…


(Stefan Chirila) #474

Thanks a bunch!
Is it that the two plugins conflict with each other? I have the new gimp run fine by means of flatpack but I’d rather have an image :stuck_out_tongue:


(Carmelo Dr Raw) #475

I guess so…


(Stefan Chirila) #476

Well that’s too bad. Your work on this is very much appreciated by the way! :slight_smile:


#477

A work around is to install DarkTable, Then go into the settings and choose DarkTable instead of NuFRAW for RAW import. Now you can open SVG’s without issue. This is what I do.


(Stefan Chirila) #478

thanks for the workaround; but what I don’t understand is why it misinterprets a vector with .SVG extension as a raw file :frowning:


(Stefan Chirila) #479

@racer-x am having trouble finding that option :frowning:


(Stefan Chirila) #480

@racer-x never mind, found it :slight_smile: ty


#481

@stefan.chirila More reason to use darktable. :slight_smile: My guess is that the app reads the file header rather than the extension name and misinterprets it.


(Stefan Chirila) #482

@afre my love love and dedication to RawTherapee goes quite deep :slight_smile: