GIMP AppImage (continuous integration)

(Carmelo Dr Raw) #524

A new version of the GIMP AppImage is available for download. The main difference with the previous ones is that it now enabled most of the optional GIMP features:

Optional Features:
  Levin matting engine:      yes
  Language selection:        yes
  Vector icons:              yes
  Dr. Mingw (Win32):         no
  Relocatable bundle:        no
  Default ICC directory:     /usr/share/color/icc
  Debug console (Win32):     no
  32-bit DLL folder (Win32): no
  Detailed backtraces:       yes

Optional Plug-Ins:
  Ascii Art:                 no (AA library not found)
  Ghostscript:               yes
  Help Browser:              no (WebKit not found)
  JPEG 2000:                 yes
  MNG:                       yes
  OpenEXR:                   yes
  WebP:                      yes
  Heif:                      yes
  PDF (export):              yes
  Print:                     yes
  Python 2:                  yes
  TWAIN (Win32):             no
  Webpage:                   no (WebKit not found)
  WMF:                       yes
  X11 Mouse Cursor:          yes
  XPM:                       yes
  Email:                     needs runtime dependency: xdg-email

Optional Modules:
  ALSA (MIDI Input):         no (libasound not found or unusable)
  Linux Input:               yes (GUdev support: no (libgudev not found))
  DirectInput (Win32):       no

One known issue, on which I am working at the moment, is internationalisations support, which seems to be broken.

As usual, the up-to-date packages can be downloaded from https://github.com/aferrero2707/gimp-appimage/releases.

Enjoy!!!

2 Likes

#525

Works just fine. Thank you!

Claes in Lund, Sweden

1 Like

#526

The latest release fixes my mouse issue ! :partying_face: :tada: :confetti_ball:

0 Likes

(Carmelo Dr Raw) #527

Glad to know! I must say that this is entirely a merit of the GIMP developers.

1 Like

(Marcello Cecchetti) #528

Thank you for the Appimage it’s working really fine and saves me a lot of troubles when updating version!

I’m using it with Ubuntu Mate 64 bit 18.04.1, i have a little problem with the icon that isn’t Schermata-IconaGimp in the menus.

I attach a screenshot. This happens with every mate theme, being it Cupertino or traditional or redmond.

Thank you in advance.

0 Likes

(Carmelo Dr Raw) #529

Happy to hear that!

I will investigate the icon problem, I have created an issue on GitHub not to forget about it: https://github.com/aferrero2707/gimp-appimage/issues/25

1 Like

#530

This happens also with lubuntu 14.04.5 .

Screenshot attached (the first gimp entry is the one from ubuntu repos, the one without icons the appimage)2018-12-28-093944_840x995_scrot

0 Likes

#531

Hi, i am using GIMP_AppImage-release-2.10.8-withplugins-x86_64.AppImage from https://github.com/aferrero2707/gimp-appimage/releases .

I was trying to add grain via G’MIC, but seems it isn’t possible to do so. I get a preview timeout.

Thank you in advance.

0 Likes

(Carmelo Dr Raw) #532

Is this the only GMIC filter that doesn’t work for you? Ping @David_Tschumperle for possible know issues?

0 Likes

(Boris Hajdukovic) #533

No, have same issue with film emulations also. G’MIC from GIMP_AppImage-release-2.10.8-withplugins-x86_64.AppImage:

Appimg1

G’MIC from GIMP_AppImage-git-2.10.9-withplugins-20190228-x86_64.AppImage:

Appimg2

and G’MIC from ppa otto-kesselgulasch/gimp:

Appimg3

I think this is a problem with appimage.

1 Like

(Boris Hajdukovic) #534

@Carmelo_DrRaw,

sorry I forgot to say that I use Kubuntu 18.04.

0 Likes

(Carmelo Dr Raw) #535

@David_Tschumperle do you have any idea what could be the reason for the preview timeout that @s7habo is reporting? Or how to investigate it?

0 Likes

(Boris Hajdukovic) #536

@David_Tschumperle, @Carmelo_DrRaw:

in the G’MIC settings dialog you can set timeout, but it doesn’t work. No matter what value I set, I immediately get timeout message.

Appimg4

0 Likes

(Carmelo Dr Raw) #537

Do other settings work, or are all of them ignored?

0 Likes

(Boris Hajdukovic) #538

Other settings work (changed preview layout, theme and logos):

Appimg5

0 Likes

(Boris Hajdukovic) #539

By the way, I noticed that your GIMP AppImage is much faster than Otto’s ppa or flatpak version. So I prefer to use your AppImage. :wink:

Nice work! :1st_place_medal:

1 Like

(Boris Hajdukovic) #540

@Carmelo_DrRaw,

sorry for spamming but I’ve just experimented a little bit and I notice that every time I select a filter or LUT from the list, the “Update filters” button becomes active as well. Where does G’MIC get its filters from? Are they stored locally or does he go to the internet every time?

I have now tried all LUTs and except (Expired) all Instant Consumer LUTs work. All Instant Pro LUTs work too. For all others I get timeout.

Notice: I always update filters before I start to work with G’MIC!

0 Likes

(Carmelo Dr Raw) #541

I really don’t know for the moment… let’s wait until @David_Tschumperle has a chance to read this messages, I hope he can shed some light!

2 Likes

#542

I have tried again but for me no lut is working (only seems to work if you don’t choose the preset and leave it to none).

And also grain.

Seems that it is impossible to download preset, maybe to a read only tmp dir for g’mic downloads? Or maybe to g’mic now a bit old version?Gmic

I attach a screenshot.

0 Likes

#543

I don’t know if it will make a difference, but the current version is 2.4.5. You have a pre-release version of 2.4.3

0 Likes