GIMP AppImage (continuous integration)

#544

Yes but pre 2.4.3 is integrated in the Appimage, i think it isn’t feasible to upgrade without rebuilding the appimage.

(Carmelo Dr Raw) #545

@ggc @Bilbo let me have a look later today. The GMIC version in the AppImage should be automatically updated to the latest available… which version of the AppImage are you using?

1 Like
#546

i am using GIMP_AppImage-release-2.10.8-withplugins-x86_64.AppImage from https://github.com/aferrero2707/gimp-appimage/releases

(Carmelo Dr Raw) #547

Could you try the very latest one?
https://github.com/aferrero2707/gimp-appimage/releases/download/continuous/GIMP_AppImage-git-2.10.9-withplugins-20190228-x86_64.AppImage

1 Like
#548

Same problem (i’m using ubuntu mate 18.04.2 now). Seems also here the Gimp icon is missing. Thank you.

.

(Carmelo Dr Raw) #549

In my case, when I hit the “OK” button to apply the filter (even if the preview has timed out), I get the following error:

*** Error in ./fx_simulate_film/_fx_cluts/*if/(...)/*if/*repeat/*if/*local/ *** Unreachable network file 'https://gmic.eu/gmic_cluts.gmz'.

I suspect the two problems are related. I will try to figure out why network access does not work…

1 Like
#550

yes i get this too if pressing ok

(Carmelo Dr Raw) #551

I’m on it…

2 Likes
(G'MIC staff) #552

Maybe some things, if it may help :
G’MIC uses calls to the library libcurl to retrieve files from the G’MIC domain https://gmic.eu , as a few filters require external data to be loaded (loaded files go to the G’MIC resources folder, which is often $HOME/.config/gmic ).

(Carmelo Dr Raw) #553

Thanks @David_Tschumperle. After some more investigations, it turn out that the error returned by libcurl is CURLE_SSL_CACERT_BADFILE. That is, the CA certificate is not accessible for some reasons… I have to see if that is a problem of environment variables.

3 Likes
(Carmelo Dr Raw) #554

@ggc @s7habo @Bilbo @David_Tschumperle
After more investigations, it turn out that there is a mismatch between the LibCURL version that is bundled in the AppImage (and used by G’MIC to download the CLUTs) and the CA certificates that are available in systems like Ubuntu 18.04

The more reliable solution I have found is to disable the LibCURL support in G’MIC/CImg, and let the code fall back to external CURL/WGET commands for downloading network files. Either curl or wget should normally be present on all Linux systems, so that should not be a big limitation.

@David_Tschumperle is that OK for you?

I have prepared a new AppImage package with this fix included. Could you please test it and see if the film emulations now work properly for you as well?

Thanks!

4 Likes
(G'MIC staff) #555

Thanks for the investigation !

1 Like
(Boris Hajdukovic) #556

Yes!!!

Nice Job @Carmelo_DrRaw! Thanks a lot!! :+1::sunglasses::fist_right::fist_left:

3 Likes
#557

Thank you it works!

1 Like
#558

Btw, i have tried with Fedora 29 and works too :grinning:

And unfortunatly missing menu icon there too.

(Carmelo Dr Raw) #559

@Marcello_C @ggc the missing icon problem should be finally fixed in the latest packages from today. Could you please check & confirm?

1 Like
#560

Work fine icon is finally here, thank you!!!

I only have a %U in the integrated entry in the menu, that leads to an error when i launch the appimage, but it’s enought to remove it. Maybe it’s due to the previous install.

Gimp2 Schermata%20a%202019-05-19%2020-39-54

1 Like
(Carmelo Dr Raw) #561

I vaguely remember having issues with the %U key as well in the past, but I forgot the details. On the other hand, %U is a valid key according to the freedesktop specifications… I will investigate.

1 Like