Installed 4.8 and lost external editor

I have installed DT 4.8 and now I lost the possibility to use my external editor. And there’s no ‘edit’ option any more in Lighttable and no ‘collection’ option under the export tab. Other DT updates I installed in the past found the editor automatically I suppose, because I never had this problem before. I have been trying to correct this and according to a video of Andy Astbury I have to click ‘Lua script installer’ in the left/below corner of Lighttable. But there’s no such thing in that corner. I have already installed GIT. I don’t know what to do now and would appreciate any help very much.

Jan.

1 Like

Hi, there’s a known problem for some cases, fix is in the works (lua scripts doesn't work with darktable 4.8.0 for windows - #25 by wpferguson). Similar topics:

OK, thanks for the quick reply. I am using Windows 10.
Tried to reinstall DT 4.6.1, but got the message that the user database (library.db) is too new. So I just have to wait for the fix.

When you upgraded, darktable made a copy of the old database (data.db and library.db). You can roll back to those, if you wish.

See INSTALL last version - #11 by kofa.

1 Like

Followed the link and changed the DB’s. Does not work. I must have something done wrong, because I do not exactly understand it what to change. Should I change the db-pre files or just the db files or both?. I don’t know much about computers, so I may have changed the wrong db files.

Jan

When you upgrade from 4.6 to 4.8, data.db and library.db are renamed to data.db-pre-4.8 and library.db-pre-4.8.
To roll back to 4.6:

  • close 4.8, if running and uninstall it;
  • rename data.db and library.db (e.g. to data.db-backup-4.8 and similarly for library.db);
  • rename data.db-pre-4.8 and library.db-pre-4.8 to data.db and library.db, respectively;
  • install 4.6.

Thank you.
I did the above. I do not get the error message any more, but still the external editor and the Lua script installer in the below/left corner are missing.
Is it possible to delete the whole darktable map under ‘appdata/local’ and install version 4.6.1 as if it was a first install of DT, or do I ask something stupid now?

Jan

You can open darktablerc (it’s in the same directory as your databases) in Notepad (make sure you save it without a .txt extension when you save it).

There are a bunch of lines that start with lua

lua/_scripts_install/debug=FALSE
lua/_scripts_install/dont_show=FALSE
lua/_scripts_install/remind=
lua/executable_paths/gimp='/usr/bin/gimp'
lua/executable_paths/git='/usr/bin/git'
lua/executable_paths/mv='/usr/bin/mv'
lua/gimp/run_detached=
lua/script_manager/category_selector=1
lua/script_manager/check_update=TRUE
lua/script_manager/contrib/AutoGrouper=FALSE
...
lua/script_manager/update_script_choices=1
lua/script_manager/use_color=

If you see lua/_scripts_install/dont_show=TRUE, maybe change that to FALSE. Alternatively, delete all those lines, darktable will replace them with sane defaults.

And, inside your config directory, there is probably also a directory called lua. You can try renaming it to lua.bak.

If I do those two things (remove all lines starting with lua/ from darktablerc, and rename the directory, next time I start darktable, the script manager is visible in the bottom left corner. To proceed, you will need git installed.

The documentation of the script installer will point you to the site from which you can install git, too (it’s at the bottom of the page).

[quote=“kofa, post:8, topic:44543”]
lua/_scripts_install/dont_show=FALSE
[/quote] is false, so I deleted all of the LUA lines and reinstalled DT 4.6.1. But the result was the same: no ‘lua scripts installer’ line. I already have GIT installed.

Have you tried deleting/renaming the lua directory? (Reinstalling darktable won’t help, that won’t fix / remove any configuration, only the software.)

@wpferguson , any ideas? I myself don’t use Lua scripts, was just trying to help.

Yesterday I have renamed the lua directory and reinstalled DT, but still no external editor and no lua script installer line in the below/left corner of the lighttable.

Jan

I deleted DT again and renamed the whole Darktable folder in ‘appdata/local’, then reinstalled DT 4.6.1 and that worked. I have my external editor back now. I hope that DT 4.8 will also have that option. Thanks a lot for taking the time to help me.

Jan

Now that I know how to get 4.6.1 working properly with the external editor, I upgraded to 4.8. Last time I did not upgrade, but uninstalled 4.6.1 before installing 4.8. Upgrading worked much better then clean install: I kept my external editor (Affinity photo). I shows up in the Lighttable and I can click ‘edit’. Problem is: the external editor does not open and I get an error message ‘error opening affinity photo’. So certainly better, but not perfect.

Jan

I run windows and Gimp and ON1 work fine in the external editor in 4.8…actually I am a little past 4.8 as I use a dev build…but it should be very close…

Affinity Photo will not work any more and I have installed the alternate version that is not a Windows app but is installed in the Program Files as normally it was in the past so must be some other block there introduced by the new AP version… but GIMP and ON1 photo raw work fine for me… not sure how it gets broken but I often update even as much as once a week…

There’s a workaround for Affinity Photo version that’s installed in Windows. I used that workaround since this AP version came out and it worked well in all of the former versions of DT I used. So I think there’s something in DT 4.8 that prevents is from loading.

So not working for you either?? Thx. Let me know if you have a tip or find a way to sort it…I wonder if it’s a security thing at all??

I’d guess the problem was something around this, but who knows.

1 Like