Local Lab build


(Alberto) #481

You’re right, the dev version crashes in the same way.
I’ve made with this “dev” version an example, you can use it to reproduce the problem:

https://filebin.net/t701yy1qc4g4tuqg

I have the same problem with any rw2 when "Special Chroma” is selected, with “standard chroma” or without color toning everything works.

image


#482

@alb1x3

Thanks for testing.
In order devs be aware of crash, could you open a bug report at
https://github.com/Beep6581/RawTherapee/issues , regarding the dev branch crash?


(Morgan Hardwood) #483

I opened an issue:


(Ingo Weyrich) #484

I fixed it:

Edit: currently it’s fixed in dev branch only


#485

@jdc could you merge dev?


(Desmis) #486

I have been away some days :slight_smile:
I just merge wiith dev - very big merge !!!

I hope no error!

jacques


#487

RawTherapee_newlocallab_5.4-944-g5472673b9_WinVista_64.zip

uploaded at
https://keybase.pub/gaaned92/RTW64NightlyBuilds/


(dngimage) #488

RawTherapee_newlocallab_5.4-944-g5472673b9_WinVista_64.zip

from:

https://keybase.pub/gaaned92/RTW64NightlyBuilds/

is running fine here.


(todd) #489

Looks like there are some new/different output profiles with this right? Instead of RT_SRGB which I usually use in my processing profiles, it switched to RTv4_SRGB automatically in this build and my first image output with this the image was all washed out. Took me a bit to find the reason and haven’t messed with it any further yet but switched to “sRGB color space profile” and the result was back to normal (not washed out looking).


(Morgan Hardwood) #490

@todd if the output looked washed-out when you used RTv4_sRGB, try RTv2_sRGB. If the v2 output looks fine, the program you’re using to view the output is no good - use a better program. ICC v4 was published in 2001.


(todd) #491

Strange. Issue is not present today… Go figure… Thanks


(dngimage) #492

@jdc,

I like LocalLab’s inverse blur effect but would love it even more if the blur would look more like Lensbaby Sol. Is it possible to have two blur effects in LocalLab? or one more bokeh like?

LocalLab Lensbaby Sol effect:

https://www.dpreview.com/sample-galleries/2833132410/lensbaby-sol-45-sample-gallery/1007654425


(dngimage) #493

New RawTherapee_newlocallab_5.4-1005-g47f0564d2_WinVista_64.zip

from:

https://keybase.pub/gaaned92/RTW64NightlyBuilds/

is running fine here.


(Jean-Paul) #494

I have a problem validating the NewLocalLab version settings on 1366X768 screens of Linux laptops with Cinnamon or KDE. I can’t access the three boots at the bottom of the window. If necessary I can put a screenshot.


(todd) #495

Just tried a few of your recent builds on my WIn10 PC… Haven’t had any problems with any builds this year that I can recall.
RawTherapee_dev_5.4-795-g6f6cdd113_WinVista_64 = is working
RawTherapee_newlocallab_5.4-1156-ge9d4dede4_WinVista_64 = is crashing
RawTherapee_waveletnew_5.4-962-g8d3862206_WinVista_64 = is crashing

Wiped out my options in appdata this time for full fresh install and still crashing. Can’t remember what to do if I run the debug exe to give you further details… Both the crashing builds open then crash and immediately disappear when I try to open a folder.


#496

I also couldn’t get RawTherapee_ newlocallab _5.4-1156-ge9d4dede4_WinVista_64 to work on Windows 10. As soon as you click on a folder containing images in the file browser, it shuts itself down.


#497

There are some issues with the last MSYS2 updates as reported by @TooWaBoo .
As I am coming back from travel, let me one or two days to check and rebuild.
I will inform you here when it is ok or at least running with perhaps some glitches.


#498

Thanks much appreciated!


#499

Should be available now


(todd) #500

Not seeing them in RTW64NightlyBuilds by the usual names but there does look to be one new one - RawTherapee_dev_5.4-918-gae12a4186_WinVista_64.zip