RawTherapee 5.5 is one week away

testing

#21

If you open an X-trans .RAF it should show the section for X-trans instead of Bayer.


(Alberto) #22

Hi,

Yes, sort of. We have changed the spline interpolation procedure. It seems this is catching a lot of people off-guard, so we are trying to fix this for the final release. See also:

You need to use different regions for modifying different channels:
22

this is neither a bug nor a regression.


(Carmelo Dr Raw) #23

Interestingly, I got the same kind of message when trying to run RT with wine under Linux. However, as far as I ca tell the program runs fine in Windows 10.
Which windows version are you using?


#24

Do you mean that the curve would change both simultaneously?
Then I would disagree. I would rather prefer having two sets of RGB curves so I could use one set in color and the other in luminosity mode.


(Morgan Hardwood) #25

It’s clean as a whistle.
https://www.virustotal.com/#/file/6833e2710dfeb89652841c83a18875e64f8de04fa0a68b693c3f96a662035fea/detection


(Shreedhar Inamdar) #26

I have been experimenting with the new Rawtherapee 5.5 RC1. It is working fine. No issues. Fantastic work and many thanks to the devs.

However, what is the reason behind addition of the Softlight module?
I am asking this because I use screen and multiply blend modes far more often than the softlight mode (when using GIMP).
SO a related enquiry would be : is it possible to have a drop down menu in that module and be able to choose the blending mode? The name of the module will then have to be changed to Blend Mode or something like that.


(Todd Prior) #27

Thanks Morgan


(Rick Scheibner) #28

Thank you, will check that out. I was actually just opening an old .CR2 file for testing purposes, but I’ll check it out again with a Fuji RAW file instead.


(Stefan Chirila) #29

@McCap mean having two separate ones so that one doesn’t have to choose between regular and luminosity


#30

Windows 7 Home Premium with Service Pack 1.


(Stefan Chirila) #31

@agriggio thanks for the explanation. Yeah I thought it’s not a mistake but a feature; still I could imagine wanting to do both some colour tweaks and luminosity tweaks on the same picture :stuck_out_tongue: not a deal breaker though


(Luca) #32

I’m having the same RTCharls’ issue.

Windows 7 Pro 64bit with Service Pack 1 - 8GB RAM - i7 2600 3.4GHz

RT5.4 is running fine.
RT 5.5rc1 (tried the “official” build, the gaaned’s build and also the Carmelo’s portable build) all builds produced an error message: “The procedure entry point ScriptIsComplex could not be located in the dynamic link library GDI32.dll.”

There is another topic with this point: RT 5.5 doesnt run on Win 7


#33

I installed RC1 on my Windows 10 machine. I can open RAWs directly from the app but when I try with right click > open with It just shows some command prompt box. Note: I have not spent too much time troubleshooting yet…


#34

@chaimav which build were you using of the RC1/where was it downloaded from?


#35

The one linked from RawTherapee.com


#36

Ok I think that means the build was generated by @Carmelo_DrRaw who might know what is going on.


(Morgan Hardwood) #37

A screenshot and more info would be helpful.


#38

Sorry. Its on my home computer which I need to vie for time on with a couple of teenage girls… As I said, I have barely had any time to troubleshoot it yet. But here is what I have done:
Download and install with default settings.
Uninstall 5.4.
Right click on .RAF file and choose open with > [navigate to the .exe and select].

I did follow the link the link from the start menu to unsure I had the right .exe. And opening RT first and opening the .RAF from the GUI worked fine.


(Carmelo Dr Raw) #39

@HIRAM @gaaned92
FYI, I am trying to update my automated build environment to use the MSYS2 packages (the same that @gaaned92 is using). Hopefully this will improve the package reliability…


#40

If you installed Rawtherapee with the installer,

  • in file context menu you should have the entry: Open with RawTherapee

  • in directory contect menu: Browse with Rawtherapee