Release of G'MIC 2.4.0

changelog

(dumb) #62

Finally implemented a CubeHelix filter with start and end colours. It works an absolute treat.

image

Also I want to get custom command boxes into a remplementation of UltraWarp and in the CSG filter that I’ve built but I’ve no idea how to do it.


(Boris Hajdukovic) #63

Wow @Iain,

This is fantastic filter!

Would it be difficult to implement an option to see a masked image instead of the mask itself, like in the Slice Luminosity filter? In this way you could immediately see what exactly is masked, which could be useful for complex images.


(dumb) #64

CubeHelix got a major upgrade. It’s got thresholds, a better gamma control, ‘hue flattening’ (which scales the individual helix dimensions with the difference between the start and end colours) and even an option to bypass the greyscale conversion for abstract colour effects.

image


(dumb) #65

Upgraded a trio of filters. The mesh blend filter can use any 256x256 RGBA image as a LUT (I can add other colour spaces later on) to blend two images together. The bomb blend filter uses a randomised LUT to scramble colours. The JIFF bomb filter uses compression artefacts and colour scrambling, but it also solidifies alpha channels and has a weird way of working with grid interpolation, yielding an interesting effect:

image


#66

I actually found one strange use of JIFF self bomb, it can be used to mimic network errors where images are screwed up in boxes with the aid of color transfer. It looks very similar to that. Also, I think they would be great to try on images found on http://amiga.lychesis.net/.

Tests with the updated filter using self-modes -

image
image
image

Original: http://amiga.lychesis.net/application/PIImage.html


(G'MIC staff) #67
  • 2018/10/04 : release of version 2.4.0

(Morgan Hardwood) #68

@David_Tschumperle inclusion of 2.4.0 in Gentoo/Sabayon is pending on c-koi/gmic-qt tagging 2.4.0:
https://bugs.gentoo.org/633950#c35


(G'MIC staff) #69

Done !


(Morgan Hardwood) #70

Thank you @David_Tschumperle


#71

I noticed that for some images the preview is not at the proper aspect ratio. I have noticed this at least several versions back. Maybe it has always been an issue; I am not certain. Perhaps, it is a win10 only problem… Take for example [PlayRaw] 2: Morgin.

image

CTRL + R doesn’t do anything.

Might have to do with the window size or shape, by itself or relative to the screen. I have a feeling that this happens when the image is narrow or wide beyond a certain extent.

If I draw a box around the face to zoom in, the ratio stays the same; but I can type CTRL + R to fix the aspect.

Before key combination

image

After key combination

image


(G'MIC staff) #72

That is strange indeed. It does not behave like this here, on my Ubuntu linux, with the LXDE window manager. I’ll be able to test this on Windows only tomorrow unfortunately.


#73

Any updates? Is it yet another downside with using Windows? :slight_smile:


(G'MIC staff) #74

Had not time to check, sorry. I’ll give a try soon hopefully (holidays are coming next week, in France).


(G'MIC staff) #75

@afre, I’ve tested G’MIC on Windows (XP), for displaying an image of size 2864x4303, just like your example image. I don’t get a weird aspect ratio, so I’m not sure what is going on.


#76

Actually I’ve seen occasional messed up aspect even on linux, but had great difficulty finding the exact steps to reproduce it reliably. Maybe I’ll try again to pinpoint it…


#77

Yes, there have been several issues. My problem is that I don’t report it right away, or I do touch on it in one of my longer or edited posts but it is so cryptic that I forget how it occurred. :blush:

I believe it also happens when the window is extra wide with multiple images or a single image, and even when I select or zoom into one of the images or that one image, the aspect ratio is messed up.

The reason that I notice this is because the behaviour changes. But again, I don’t know the specifics such as version numbers. I guess what I am saying is that this is an intermittent problem.


(Mau Cro) #78

constrained sharpen (and others filters) cut layers names with “)”

GMC filter - details - constrained sharpen (and others filters too)
cut layers names with “)”

(100 ms) -> (100 ms
(140 ms) -> (140 ms

and this is bad for gif animations timing

how to reproduce
create an image
rename layer -> (100 ms)
apply details - constrained sharpen
layer name after -> (100 ms

thanks


(G'MIC staff) #79

@Mau_Cro, thanks for the report. I’ve tried a quick fix.
Could you please try to ‘refresh’ your filters (refresh button), and see if it fixes this issue ?
Thanks!


(Mau Cro) #80

work only in case “)” is the last letter of the name.

(100ms) -> (100ms) --> ok
(100ms)-1 -> (100ms --> cut
(100ms) -2 -> (100ms --> cut
123456)aggg -> 123456 --> cut

for me its enough, for others could be a problem


(G'MIC staff) #81

@Mau_Cro, this should be OK now, with parentheses inside layer names, at various positions.

@afre, I’ve worked a bit on the aspect ratio in the G’MIC image visualizer. Hopefully, this should be more robust now. Could you please test with the latest pre-release version (2.4.1_pre) from today ? Thanks ! Link : https://gmic.eu/files/prerelease/ (compiled today for Windows, Ubuntu and Debian9).