Test RawTherapee 5.6-rc1

(Paul Miller) #21

The only options are like this (option click or no option click makes no difference):

The default setting is “looks like 1680x1050”, the more space setting is “looks like 1920x1200”. Using the “more space” setting there is more room on screen, so more of the RawTherapee UI fits in, but the icons are still too big. All the “larger text” settings are worse.

This is the top left of the Editor in “more space”:

I don’t actually need a solution to this (I mostly use darktable or PhotoFlow), I’m just trying the build to be helpful.

0 Likes

#22

Tried AppImage on Ubuntu Mate 18.04.2 64 bit.

  1. Preferences tab takes a lot to show up (read 7-8 seconds)

  2. Changing font size takes another pair of seconds ( i3-2100 CPU @ 3.10GHz )

  3. Even for me icons are too big, i have tried changing font size to 9, but icons are still much bigger than 5.5 (and it isn’t good since my main monitor is “only” 1680x1050, and my notebook is 1024x768)

I have tried a pair of developments and everything was fine.

Thank you in advance.

0 Likes

(Peter) #23

Runs well in Windows 7. Same console issue as 5.5 but can live with that.

0 Likes

#24

I was using a nightly build which crashes every time I try batch processing this specific Nikon D600 image. sunset,enghave.nef.pp3 (11.8 KB)
Sadly this version also crashes to desktop the same way. I don’t see any error messages anywhere, it just processes for a few seconds and then goes >poof<.

0 Likes

#25

Hi @JoaCHIP,
Are you on Win or Linux or …?
Could you also please upload the .nef?
I am quite suspicious of the comma character
you have between sunset and enghave…

Have fun!
Claes in Lund, Sweden

0 Likes

(Morgan Hardwood) #26

@mannikon what is the issue, when does the console window open?

0 Likes

(Peter) #27

Only opens when right clicking image and then open with.
Small discussion on this a few weeks back.

0 Likes

#28

Here’s the nef file. I realize that a comma is quite an unusual character to use in a filename, but extensive analysis of different operating systems has showed me that it is in fact not very risky to use.
But regarding the crash: I’m on Windows 10 (64bit) build 1803, Intel i7 2600, 16 GB ram, R.T. installed on an SSD drive, images stored on a normal drive.
sunset,enghave.nef (19.2 MB)

0 Likes

(Jean-Christophe) #29

@paulmiller @ggc @HIRAM I’ve created a new icon-size-fix branch to fix the font scaling issue, but I’m shooting in the dark since I don’t experience (Win7 here). What is the gtk version on your side ? The problem might occur for Gtk3.18 and lower, and especially for MacOS (but not only). It would be great if you could test it shortly.

( https://github.com/Beep6581/RawTherapee/compare/icon-size-fix )

1 Like

#30

I’m on gtk 3.24.7. I will have a look at that later after the bbq :meat_on_bone:

0 Likes

(Morgan Hardwood) #31

@JoaCHIP cannot reproduce the crash. Please file a proper bug report in GitHub: http://rawpedia.rawtherapee.com/How_to_write_useful_bug_reports

0 Likes

(Jean-Christophe) #32

@paulmiller @ggc

…and using the verbose mode would be also helpful (verbose parameter in your options file) .

0 Likes

#33

reproduced here with raw and pp3. It crashes also with 5.5
If either CIECAM2 or wavelet is deactivated, there is no crash.

Thread 1007 received signal SIGSEGV, Segmentation fault.
[Switching to Thread 4108.0x768]
0x0000000000a9700b in LUT<float>::operator[]<float, float, void> (
    this=<optimized out>, index=-nan(0x400000))
    at D:/RAWTHERAPEE/RTSOURCE/rawtherapee/rtengine/LUT.h:437
437         T operator[](V index) const
(gdb) bt full
#0  0x0000000000a9700b in LUT<float>::operator[]<float, float, void> (
    this=<optimized out>, index=-nan(0x400000))
    at D:/RAWTHERAPEE/RTSOURCE/rawtherapee/rtengine/LUT.h:437
        idx = -2147483648
        diff = -nan(0x400000)
        p1 = <optimized out>
        p2 = <optimized out>
#1  0x0000000000a90d4b in rtengine::curves::setLutVal (lut=...,
    val=@0x3e77c6ac: -nan(0x400000))
    at D:/RAWTHERAPEE/RTSOURCE/rawtherapee/rtengine/curves.h:83
        m = <optimized out>
        m = <optimized out>
#2  0x00000000007ece2a in rtengine::Chromacurve::Apply (
    Cr=@0x3e77c89c: 1.40129846e-45, this=0x100000000)
    at D:/RAWTHERAPEE/RTSOURCE/rawtherapee/rtengine/curves.h:839
No locals.
#3  rtengine::ImProcFunctions::ciecam_02float (this=0x46fffe0046fffe00,
    ncie=0x17066590, adap=<optimized out>, pW=<optimized out>,
    pwb=<optimized out>, lab=<optimized out>, params=<optimized out>,
    customColCurve1=..., customColCurve2=..., customColCurve3=...,
    histLCAM=..., histCCAM=..., CAMBrightCurveJ=..., CAMBrightCurveQ=...,
    mean=<optimized out>, Iterates=<optimized out>, scale=<optimized out>,
    execsharp=<optimized out>, d=<optimized out>,
    dj=@0x3e77cbe8: 0.999996662, yb=<optimized out>, rtt=<optimized out>,
    showSharpMask=<optimized out>)
    at D:/RAWTHERAPEE/RTSOURCE/rawtherapee/rtengine/improcfun.cc:1375
        Cc = -nan(0x400000)
        Ccold = -nan(0x400000)
        userColCurve = @0x100000000: <incomplete type>
        protect_red = <optimized out>
        sk = <optimized out>
        ko = <optimized out>
        parsat = 0.800000012
        coef = 409.599976
        dred = <optimized out>
        J = <optimized out>
        Q = <optimized out>
        M = <optimized out>
        Cpro = -nan(0x400000)
        spro = 0
        h = <optimized out>
        Jpro = 0
        Mpro = 0
        C = <optimized out>
        s = <optimized out>
        hpro = 12.5288076
        Qpro = 0
        j = <optimized out>
        z = {1.062971, 1.08074462, 1.15451312, 1.09842861}
        J = {11.4512835, 11.5661983, 11.9864044, 11.7376528}
        Q = {126.34436, 126.976723, 129.262711, 127.914398}
        M = {4.08845282, 4.08818483, 4.06061935, 4.00284481}
        zbuffer = <optimized out>
        k = <optimized out>
        x = {1.13707602, 1.16306603, 1.2527349, 1.2041297}
        h = {294.816071, 299.150146, 303.55191, 310.129822}
        c655d35 = <optimized out>
        xbuffer = <optimized out>
        y = {1.14787316, 1.17072952, 1.25834692, 1.20458984}
        C = {4.00743723, 4.00717449, 3.98015499, 3.92352533}
        s = {17.9887733, 17.9433365, 17.7239094, 17.6898727}
        ybuffer = <optimized out>
        i = <optimized out>
        minQThr = 71.0733643
        maxQThr = 1.70997608
        Cbuffer = <error reading variable Cbuffer (value requires 4266597464 bytes, which is more than max-value-size)>
        Qbuffer = <error reading variable Qbuffer (value requires 4266597464 bytes, which is more than max-value-size)>
        Mbuffer = <error reading variable Mbuffer (value requires 4266597464 bytes, which is more than max-value-size)>
        sbuffer = <error reading variable sbuffer (value requires 4266597464 bytes, which is more than max-value-size)>
        Jbuffer = <error reading variable Jbuffer (value requires 4266597464 bytes, which is more than max-value-size)>
        hbuffer = <error reading variable hbuffer (value requires 4266597464 bytes, which is more than max-value-size)>
        t2e = {t = <optimized out>, baseFrequency = 4578660250722937661}
        Xw = 0.95498066200246889
        nc = 4.40136026e+33
        xw = <optimized out>
        pfl = 1.02021635
        czj = 1.70360684
        c_ = 1.08335078
        Zw = 0.94892822171619828
        zw = <optimized out>
        deg = <optimized out>
        minQ = 10000
        xws = <optimized out>
        algepd = 63
        hist16Q = {maxs = 0, maxsf = 0, data = 0x0, clip = 0, size = 0,
          upperBound = 0, owner = 1, maxsv = {0, 0, 0, 0}, sizev = {0, 0, 0,
            0}, sizeiv = {0, 0}, dirty = true}
        reccmcz = 1.86615038
        wiprof = <optimized out>
        n = 0.0500000007
        degout = <optimized out>
        zw1 = -3.32812438e+27
        QproFactor = 1.21706069
        f2 = 1.83111262
        aw = 59.1285172
        zw2 = 1.2527349
        nbbj = 1.3199091
        maxQ = -1000
        fl = 1.08335078
        ciedata = false
        la2 = <optimized out>
        xwd = <optimized out>
        Xwsc = 0.96460195849111185
        wip = {{1.34594333, -0.255607486, -0.0511117987}, {-0.544598877,
            1.50816727, 0.0205351003}, {0, 0, 1.21181285}}
        hist16JCAM = {maxs = 0, maxsf = 0, data = 0x0, clip = 0, size = 0,
          upperBound = 0, owner = 1, maxsv = {0, 0, 0, 0}, sizev = {0, 0, 0,
            0}, sizeiv = {0, 0}, dirty = true}
        ncb = 1.3199091
        yws = <optimized out>
        Zwout = 0.82445071516124746
        pilotout = <optimized out>
        rstprotection = 100
        nj = 0.0500000007
        mchr = 1.3199091
        hue = 373.36087
        needJ = <optimized out>
        cz = 1.70360684
        flj = 1.70997608
        t1e = {t = 4880404672822292017, baseFrequency = <optimized out>}
        hist16_CCAM = {maxs = 0, maxsf = 0, data = 0x0, clip = 0, size = 0,
          upperBound = 0, owner = 1, maxsv = {0, 0, 0, 0}, sizev = {0, 0, 0,
            0}, sizeiv = {0, 0}, dirty = true}
        height = 1071255498
        epdEnabled = <optimized out>
        hasColCurve1 = true
        ncbj = 1.3199091
        pow1n = -3.32812438e+27
        width = 1066178895
        Yw = 1
        yw = 100
        curveMode = (rtengine::procparams::ColorAppearanceParams::TcMode::BRIGHT | unknown: 1072598834)
        hasColCurve2 = false
        LabPassOne = 250
        c = 0.689999998
        ywd = <optimized out>
        Zwsc = 0.82445071516124746
        hasColCurve3 = true
        c2 = <optimized out>
        zws = <optimized out>
        xw1 = -2.48813958e-05
        curveMode2 = (rtengine::procparams::ColorAppearanceParams::TcMode::BRIGHT | unknown: 1066308616)
        xw2 = 1.13707602
        wh = 373.36087
        coefQ = 1.3199091
        f_l = 1.08335078
        f = 4.40136026e+33
        Xwout = 0.96460195849111185
        pilot = <optimized out>
        curveMode3 = (unknown: 1067065580)
        hist16J = {maxs = 32766, maxsf = 32766, data = 0x2a83a540, clip = 3,
          size = 32768, upperBound = 32767, owner = 1, maxsv = {32766, 32766,
            32766, 32766}, sizev = {32767, 32767, 32767, 32767}, sizeiv = {
            140733193420799, 140733193420799}, dirty = true}
        needQ = <optimized out>
        la = <optimized out>
        nc2 = 1.83111262
        nbb = 1.3199091
        zwd = <optimized out>
        t1L = 63
        yb2 = <optimized out>
        schr = 0.0500000007
        gamu = 119
        yw1 = 1.86223197
        awj = 71.0733643
        alg = 1065881455
        chr = 1.21691608
        highlight = 218
        yw2 = 1.16306603
        pow1 = 1.86615038
        epsil = 9.99999975e-05
        a_w = 373.36087
        coe = 1.83111262
        bufferLength = 1066649366
#4  0x0000000000000000 in ?? ()
No symbol table info available.
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
0 Likes

#34

@Morgan: Thanks for the info. I managed to stabilize things by starting with the “Default” preset instead of the custom default I had made earlier on. My current default comes from a nightly build, so I should probably get rid of it and start from scratch. Clean slate.

It’s getting late here, but I’ll be back testing soon. If I still get crashes after cleaning up my defaults, I’ll file a proper bug report, so that you have some more useful info. (Don’t worry, I’m not about to leave RawTherapee. I’m far too fond of the quality it always gives me! :grinning:)

1 Like

#35

Trying now to compile the rc mixed with the five modified files (i’m sure there could be a better way, but should work)

I have found out also that verbose=false is in ~/.config/RawTherapee-version

My gtk is here.

ii libgtk-3-0:amd64 3.22.30-1ubuntu2 amd64 GTK+ graphical user interface library
ii libgtk-3-bin 3.22.30-1ubuntu2 amd64 programs for the GTK+ graphical user interface library
ii libgtk-3-common 3.22.30-1ubuntu2 all common files for the GTK+ graphical user interface library
ii libgtk-3-dev:amd64 3.22.30-1ubuntu2 amd64 development files for the GTK+ library

0 Likes

#36

Tried but icons are still much bigger, especially icons spacing.

Screenshots:

5.5

5.6rc1

I haven’t found out where the verbose option should create a file, in the console there is almost nothing.

0 Likes

(Morgan Hardwood) #37

They’re not bigger, just more padding.

0 Likes

(Morgan Hardwood) #38

@ggc is your “5.6rc1” screenshot using @Hombre’s icon-size-fix branch? Can you confirm that using this branch the icon sizes are fine (ignore the padding), whereas without the patch in the official 5.6-rc1 release they are too big?

0 Likes

(Jean-Christophe) #39

As @Morgan_Hardwood said, there’s more padding in the new version. I had to modify the RawTherapee theme quite a lot to make it DPI independant, based on @TooWaBoo’s work. I know that it uses more space, but fine tuning this will take too much time, so someone should probably create a slim version from scratch.

0 Likes

#40

RT 5.6 rc1 works fine on Windows 10 (8Gb RAM, Intel i7)

0 Likes