Testing : Qt-based version of the G'MIC plug-in for GIMP


(Silvio) #41

Hello David,

Just tested the new .exe installer on:
Windows 7 (64 bit);
Windows 8.1 (64 bit).

It works GREAT on both systems ! :slight_smile:

It is extremely fast and stable.
In addition, the new dark them is really cool as well :slight_smile:

Thanks a lot for you hard work !


#42

Works with Manjaro KDE 64 bits. Better interface than Gtk (not a surprise)
Thanks!


(David Tschumperlé) #43

I’ve also posted some new binary packages, including ZArt and the Qt-standalong G’MIC interface (not a plug-in), for testing ! Do not hesitate to test !


(Silvio) #44

Hello David,

Just unzipped the stand-alone version to try it.
It does not work.
The folder has 3 files:
copying
readme
gmic_qt.exe (around 7.487 Kb)

When I click on gmic_qt.exe (Windows 7 - 64 bit) a window message appears (it looks like libgcc_s_seh-1.dll is not available on my system):

BTW, the Gmic_CLI_pre-Wind64 version works fine instead :slight_smile:


(Lyle Kroll) #45

Got that same error. Not sure what the issue is. :slight_smile:


(David Tschumperlé) #46

@lylejk, @Silvio_Grosso : yes that is actually one of the .dll necessary to run the program, but I thought I’ve put it in the .zip archive for gmic_qt. You can try copying it from the archive gmic_gimp_qt64.zip to test. Anyway, I’ll add it in a new archive today. Thanks for reporting !


(David Tschumperlé) #47

Thanks @sguyader for your feedback.
Would it be possible for you to send me your G’MIC 1.7.9 fave file, so we can check why the import fails ?
Same request for you @lylejk !

Would be nice if you could send me the file ‘gimp_faves’, which corresponds to the old way favorites were stored.
Thanks by advance !


(Sebastien Guyader) #48

David,

In fact I was running the gmic-2.0 plugin. In the .config folder, my faves were stored in a gui_faves file, not in gimp_faves. Here are the two files:
https://filebin.net/zajy3udkzo2xwxjf


(David Tschumperlé) #49

Ah OK, so this may explain the weird import.
The new Qt-plug-in only imports from last stable G’MIC version, so 1.6.9.
It doesn’t import filters from previous 2.0.0_pre releases.


(David Tschumperlé) #50

And looking at your file gimp_faves, I see you have indeed only 4 favorites, so what the Qt plug-in did seems to be correct in your case.
Now @lylejk, we need yours to understand what is going on !


(Lyle Kroll) #51

Just sent you a private message with my gui_faves (saved as .txt extention, since I could not attach it otherwise) per your request, David. :slight_smile:


(David Tschumperlé) #52

Just replied Lyle :slight_smile:


(Lyle Kroll) #53

Just replied back, David. About to chill before I get ready for my weekend swings shift (today’s my Monday. :frowning: lol) so may not be able to confirm any effort with it until this evening. :slight_smile:


(David Tschumperlé) #54

OK Lyle, so I’d be very interested by a precise description of the bug, what were the steps you did, what kind of installation of GIMP you use, where are stored your fave files, etc…
If we can reproduce the bug, we’ll be able to fix it probably. Otherwise, no chances :slight_smile:


(Silvio) #55

Hello David,

Just downloaded the new stand-alone version of:
gmic-qt-2.0.0_pre-win64

It works fine with png images but not with jpeg images (tried several jpeg images and all fail).

On Windows 7 (64 bit) to reproduce this issue:

  1. Launch the gmic_qt.exe
  2. A window to select an image appears
  3. As soon as you select a jpeg image this window dissapears and nothing occurs (no message error either…).
    It is odd because it does not look like a crash…
    Quite simply gmic_qt is no longer visible.

When you open a png image everything works fine.
When you save your change as png a new image is created.
On the contrary, if you decide to save your change as jpeg nothing occurs (no jpeg image is saved)


(Lyle Kroll) #56

Installed GIMP; copy past from zip all versions of G’MIC used. the favs are stored in the gmic folder under roaming. The only bug I get is the QT version keeps asking to import the favs but no favs get imported. It then runs as it should sans the favs of course. I might see if I can create a fav within the plugin and see if that stops the nag. :slight_smile:

edit:

I was able to save a fav, but when I restarted the QT version, it again asked me to import favs and the fav that I did save disappeared. Very strange, David. :slight_smile:

edit:

When I deleted the gmic_faves file, the QT worked normally and then even the saved fav saved. I’m planning on removing the old G’MIC plugin anyway (keep 2_0_0 gtk) since Brian updated his plugins to be compatible with the new 2_0_0 GTK gmic, so I suppose there’s no reason to even bother troubleshooting this issue, David since there appears some old 1.7.9 preset that causes a coniption with the QT version. Just glad the QT version now works without errors (after I deleted the 1.7.9 gimp_faves file that is). :slight_smile:

edit:

Guess what? I duplicated my 2_0_0 favs saving that file as gmic_faves and that file worked. Don’t have to recreate the favs thank God. lol

Happy I am. :slight_smile:


(David Tschumperlé) #57

Thanks for the details Lyle.
Not sure what the bug is, we’ll probably investigate that someday.


#58

The dark theme is ideal, thanks :slight_smile:

Can we still define GUI filters in user.gmic?
It seems as though the commands are parsed and can be used, but any GUI definitions are ignored (on windows at least).

I also noticed some slightly odd preview aspect ratio behaviour; it seems to be something to do with preview zoom (0) and changing aspect. The only example I have is with “deinterlace 2x” and 16:9 - the preview is wrong but output is still OK.


#59

I figured out what stops user.gmic defined GUI filters from working:

It now requires a space after the filter name before the colon, for example:

#@gui My filter: my_filter, my_filter_preview(1)

will not work, but

#@gui My filter : my_filter, my_filter_preview(1)

works fine!


(Lyle Kroll) #60

I’m just glad all is now well. Had to put 1.7.9 back for some script-fus and python plugins that still use it. Of course the faves no longer works in 1.7.9, but I have no plans on using 1.7.9 since qt (even 2_0 gtk) runs so much faster. Can’t wait until the beta ends. I suspect there will be a simple PS plugin that can call the QT stand-a-lone soon. I’ve not played with the stand-a-lone yet due to the missing files issue. May do so next week (have to get to work in a few hours). Thanks again for you and your team’s herculean efforts. G’MICs still the best asset ever for processing. Once GIMP actually does go to 2.10x, I’m looking forward to high bit editing as well (assuming that g’mic can transfer high bit processing natively back to GIMP and doesn’t convert results to 8-bit). :slight_smile: